My PC became pretty slow! Can someone help?

I’'m using a quite old laptop that, once installed Manjaro, came back to life. Unfortunately, after some months of regular use it became always slower and now it is quite hard to use. I have very little knowledge of Linux and I would like to know if there is something wrong in my settings.

The output of inxi -Fza is:

  Kernel: 5.5.8-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.5-x86_64 
  root=UUID=0ff4a319-3d96-4639-a58b-2ce60d42c6a1 rw quiet 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 2089W7X v: ThinkPad T500 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 2089W7X serial: <filter> BIOS: LENOVO 
  v: 6FET70WW (3.00 ) date: 04/17/2009 
  ID-1: BAT0 charge: 47.8 Wh (100.0%) condition: 47.8/56.2 Wh (85.1%) 
  volts: 12.5 min: 10.8 model: Panasonic 42T4622 type: Li-ion 
  serial: <filter> status: Full 
  Info: Dual Core model: Intel Core2 Duo P8400 bits: 64 type: MCP 
  arch: Penryn family: 6 model-id: 17 (23) stepping: 6 microcode: 60F cache: 
  L2: 3 MiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 9046 
  Speed: 2298 MHz min/max: 800/2267 MHz Core speeds (MHz): 1: 2298 2: 2264 
  Vulnerabilities: Type: itlb_multihit status: KVM: Vulnerable 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds 
  status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Mobile 4 Series Integrated Graphics vendor: Lenovo 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:2a42 class-ID: 0300 
  Device-2: Lenovo UVC Camera type: USB driver: uvcvideo bus-ID: 1-6:4 
  chip-ID: 17ef:4807 class-ID: 0e02 
  Display: x11 server: X.Org 1.20.11 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev, vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.3x8.3") 
  s-diag: 398mm (15.7") 
  Monitor-1: LVDS1 res: 1280x800 hz: 60 dpi: 99 size: 330x210mm (13.0x8.3") 
  diag: 391mm (15.4") 
  OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express (CTG) 
  v: 2.1 Mesa 21.0.2 direct render: Yes 
  Device-1: Intel 82801I HD Audio vendor: Lenovo ThinkPad T400 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:293e 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.5.8-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.25 running: no 
  Device-1: Intel 82567LM Gigabit Network vendor: Lenovo ThinkPad T400 
  driver: e1000e v: 3.2.6-k port: 1840 bus-ID: 00:19.0 chip-ID: 8086:10f5 
  class-ID: 0200 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel PRO/Wireless 5100 AGN [Shiloh] Network driver: iwlwifi 
  v: kernel port: 1c60 bus-ID: 03:00.0 chip-ID: 8086:4237 class-ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  Local Storage: total: 149.05 GiB used: 27.98 GiB (18.8%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital 
  model: WD1600BEVS-08VAT1 size: 149.05 GiB block-size: physical: 512 B 
  logical: 512 B speed: 1.5 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: 1A13 scheme: MBR 
  ID-1: / raw-size: 144.92 GiB size: 141.65 GiB (97.74%) 
  used: 27.92 GiB (19.7%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 4.12 GiB used: 56 MiB (1.3%) 
  priority: -2 dev: /dev/sda2 maj-min: 8:2 
  System Temperatures: cpu: 45.0 C mobo: 40.0 C 
  Fan Speeds (RPM): fan-1: 1984 
  Processes: 159 Uptime: 28m wakeups: 1 Memory: 1.87 GiB 
  used: 1.17 GiB (62.5%) Init: systemd v: 247 tool: systemctl Compilers: 
  gcc: 10.2.0 Packages: pacman: 1278 lib: 429 flatpak: 0 Shell: Bash 
  v: 5.1.0 running-in: xfce4-terminal inxi: 3.3.04
  1. In the future, when providing code/output, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text so that the output looks like this:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
    Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
    Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur.
    Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

    instead of like this:

    > Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

    (as that makes both our lives much easier)

  2. No need to do anything right now as I’m an editor here on this site and have fixed it for you already. However, in the future I might not see your post so review my edits by pushing the orange pencil above the post I just fixed. :wink:

  3. What you see it quite normal: a Core2 Duo with 2GB of RAM and a 5400 RPM HDD is just slow nowadays,

  4. However the specifications for a 2089W7X allow for 8GB maximum RAM so I’d try to find that second hand.

  5. I’d also buy a new 256GB SSD and install that inside the machine and hook up the old HDD with a USB cable and adapter and dd everything over.

  6. That way, you should have a brand new machine that will give you another 3-5 years of :heart: for about 150€…


P.S. You will not believe what your machine is still capable of after executing #4 and #5 above! :man_shrugging:


Hi @Krullino and welcome to the forum!
I’m just here to reinforce what @Fabby wrote.

  • I have a laptop with a dual core, 6th gen core i3 and it originally came with 4gb of ram and a 500gb HDD.
  • Almost a year ago I got tired with it just being slow and purchased more RAM and an SDD and I’ll tell you: my life changed! :joy:

You can’t imagine how much performance you leave behind when you don’t have enough RAM and your HDD is holding you down.
That said, if your computer has a DVD drive and you don’t use it, there are some pretty cool adapters that allow you to fit a second disk in you pc (at the cost of loosing the DVD drive obviously). This way you can use the HDD as a general storage media and have the OS booting from the SSD.

As for your problem, I experienced a similar issue with an old tablet lately and I ended up just reinstalling, but my advice would be to try and clean you system before recurring to drastic measures: check and clean the pacman cache, look for old and unused programs, maybe give pacman a clean following this article on the wiki!



Idk if this would contribute to any kind of slowness or not (e.g. some packages not playing well with an old kernel), but kernel 5.5 has been EOL (end of life) for a year now. You should swap to kernel 5.4 or 5.10

Other than that, like the others have said, more RAM and an SSD would make it much faster than any kernel change.


Just as an addition to what has already been reported by other companions.
I use an even lighter environment and yet the manjaro is somewhat slow on my machine.
However, I do not blame the system in any way, but my hardware, which is the slowest of history, see:

inxi -SMDm                                                       
  Host: pccreto Kernel: 5.11.14-1-MANJARO x86_64 bits: 64 
  Desktop: LXQt 0.16.1 Distro: Manjaro Linux 
  Type: Laptop System: Positivo Informatica SA product: C14RV01 
  v: 1.00.05_SIM serial: <superuser required> 
  Mobo: Positivo Informatica SA model: C14RV01 v: SIM 
  serial: <superuser required> BIOS: American Megatrends v: 1.00.05 
  date: 10/03/2012 
  RAM: total: 3.74 GiB used: 1.26 GiB (33.6%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
  Local Storage: total: 298.09 GiB used: 106.34 GiB (35.7%) 
  ID-1: /dev/sda vendor: Western Digital model: WD3200BPVT-00JJ5T0 
  size: 298.09 GiB

T+ + So long

1 Like

RAM and SSD.
I’m tighter than a ducks ass, but I had 4GB since I was an egg and 8GB since 2013.

I held off on SSD until 4 years ago - it’s revolutionary for boots/reboots and makes it more fun to launch GIMP.

You’ll feel the pain if you fill up that 2GB and start swapping on an old WD hard drive…

30 minutes to load GIMP maybe?

1 Like

To ALL of You, just thank you!!! Your advises are much appreciated. I will try all of the solutions mentioned and make this old machine shine again!

P.S. next time I will use the 3 backticks, promised =)

1 Like

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.