My laptops energy use builds up in sleep mode. Up to 30W. What's wrong?

Dear community,

I’m a happy new user of Manjaro (KDE) and really impressed with the ease of use and good looks of the system. The only thing that bothers me is that my laptop energy use seems to be building up when in sleep mode, up to 30W. This of course making it pointless because that’s higher than actually using it.

I cant seem to upload the graph from ‘Energy’, but while in sleepmode, over time the energy consumption rises in a linear line from something like 13 W to almost 30 W (in an hour, even higher, like 35 if it is for several hours).

My laptop is the new Dell Inspiron 16 plus (7620, with the Nvidea RTX 3060).

Could someone please help me to fix this issue?
Thank you so much!

Maybe relevant data:
OS: Manjaro Linux x86_64
Host: Inspiron 16 Plus 7620
Kernel: 5.15.65-1-MANJARO
Uptime: 34 mins
Packages: 1418 (pacman), 20 (flatpak)
Shell: bash 5.1.16
Resolution: 3072x1920
DE: Plasma 5.25.5
WM: KWin
Theme: [Plasma], Breeze [GTK2/3]
Icons: [Plasma], breeze [GTK2/3]
Terminal: konsole
CPU: 12th Gen Intel i7-12700H (20) @ 4.600GHz
GPU: Intel Alder Lake-P
GPU: NVIDIA GeForce RTX 3060 Mobile / Max-Q
Memory: 3837MiB / 15682MiB

How are you measuring the power consumption?

With the app ‘Energy’ that comes standard with Manjaro.

post system info:
inxi -Faz
and install the 5.19.7-1 kernel, select it in grub menu and test with it

underneath you’ll find my output. I tried to install the 5.19 kernal but it doesn´t boot. Normally when I boot I get some text about verified blocks or something and then my KDE login screen, with the 5.19 i get a whole lot of text (seems like hardware/version verifications) and then it just stops. And after waiting for like 15 to 30 minutes it just turns off the laptop. This goes for the normal 5.19 als wel as the fallback thingy in the GRUB loader. So im afraid thats not an option?

System:
 Kernel: 5.15.65-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
   parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
   root=UUID=e3e9199a-ce14-4827-b437-cc51ad7eccf8 rw quiet
   resume=UUID=c5ccbe85-19b7-4bc8-9b4c-2887f33438b5 udev.log_priority=3
 Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
   dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:
 Type: Laptop System: Dell product: Inspiron 16 Plus 7620 v: N/A
   serial: <superuser required> Chassis: type: 10 serial: <superuser required>
 Mobo: Dell model: 0V98G2 v: A00 serial: <superuser required> UEFI: Dell
   v: 1.5.1 date: 08/12/2022
Battery:
 ID-1: BAT0 charge: 71.7 Wh (100.0%) condition: 71.7/84.3 Wh (85.1%)
   volts: 13.1 min: 11.4 model: BYD DELL M59JH24 type: Li-poly
   serial: <filter> status: full
CPU:
 Info: model: 12th Gen Intel Core i7-12700H bits: 64 type: MST AMCP
   arch: Alder Lake gen: core 12 level: v3 built: 2021+ process: Intel 7 (10nm
   ESF) family: 6 model-id: 0x9A (154) stepping: 3 microcode: 0x421
 Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
   cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
   L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
 Speed (MHz): avg: 458 high: 541 min/max: 400/4679:4700:3500 scaling:
   driver: intel_pstate governor: powersave cores: 1: 508 2: 478 3: 459 4: 464
   5: 448 6: 421 7: 477 8: 500 9: 416 10: 415 11: 467 12: 416 13: 518
   14: 400 15: 400 16: 486 17: 400 18: 487 19: 472 20: 541 bogomips: 107560
 Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
 Vulnerabilities:
 Type: itlb_multihit status: Not affected
 Type: l1tf status: Not affected
 Type: mds status: Not affected
 Type: meltdown status: Not affected
 Type: mmio_stale_data status: Not affected
 Type: retbleed status: Not affected
 Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
   prctl and seccomp
 Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
   sanitization
 Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
 Type: srbds status: Not affected
 Type: tsx_async_abort status: Not affected
Graphics:
 Device-1: Intel Alder Lake-P Integrated Graphics vendor: Dell driver: i915
   v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
   active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 0000:00:02.0
   chip-ID: 8086:46a6 class-ID: 0300
 Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Dell
   driver: nvidia v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+
   status: current (as of 2022-08) arch: Ampere code: GAxxx process: TSMC n7
   (7nm) built: 2020-22 bus-ID: 0000:01:00.0 chip-ID: 10de:2520
   class-ID: 0300
 Device-3: Microdia Integrated_Webcam_FHD type: USB driver: uvcvideo
   bus-ID: 1-6:3 chip-ID: 0c45:6739 class-ID: 0e02
 Display: x11 server: X. Org v: 21.1.4 compositor: kwin_x11 driver: X:
   loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa gpu: i915
   display-ID: :0 screens: 1
 Screen-1: 0 s-res: 3072x1920 s-dpi: 96 s-size: 812x508mm (31.97x20.00")
   s-diag: 958mm (37.71")
 Monitor-1: eDP-1 model: BOE Display 0x09d5 built: 2021 res: 3072x1920
   hz: 60 dpi: 226 gamma: 1.2 size: 345x215mm (13.58x8.46") diag: 407mm (16")
   ratio: 16:10 modes: 3072x1920
 OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 22.1.7
   direct render: Yes
Audio:
 Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Dell
   driver: sof-audio-pci-intel-tgl
   alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
   chip-ID: 8086:51c8 class-ID: 0401
 Device-2: NVIDIA GA106 High Definition Audio vendor: Dell
   driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:228e
   class-ID: 0403
 Sound Server-1: ALSA v: k5.15.65-1-MANJARO running: yes
 Sound Server-2: JACK v: 1.9.21 running: no
 Sound Server-3: PulseAudio v: 16.1 running: yes
 Sound Server-4: PipeWire v: 0.3.57 running: yes
Network:
 Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
   bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
 IF: wlp0s20f3 state: up mac: <filter>
Bluetooth:
 Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 1-10:4
   chip-ID: 8087:0033 class-ID: e001
 Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
   rfk-block: hardware: no software: yes address: see --recommends
RAID:
 Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
   v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev:
   class-ID: 0104
Drives:
 Local Storage: total: 953.87 GiB used: 351.95 GiB (36.9%)
 SMART Message: Unable to run smartctl. Root privileges required.
 ID-1: /dev/nvme0n1 maj-min: 259:0 model: CL4-3D1024-Q11 NVMe SSSTC 1024GB
   size: 953.87 GiB block-size: physical: 512 B logical: 512 B
   speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: 25301111
   temp: 50.9 C scheme: GPT
Partition:
 ID-1: / raw-size: 936.72 GiB size: 920.94 GiB (98.32%) used: 351.93 GiB
   (38.2%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
 ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 28.8 MiB
   (9.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
 Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
 ID-1: swap-1 type: partition size: 16.85 GiB used: 0 KiB (0.0%)
   priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
 System Temperatures: cpu: 35.0 C mobo: N/A
 Fan Speeds (RPM): N/A
Info:
 Processes: 425 Uptime: 14m wakeups: 216 Memory: 15.31 GiB used: 4.36 GiB
 (28.4%) Init: systemd v: 251 default: graphical tool: systemctl
 Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1438 pm: pacman pkgs: 1418
 libs: 374 tools: pamac pm: flatpak pkgs: 20 Shell: Zsh v: 5.9 default: Bash
 v: 5.1.16 running-in: konsole inxi: 3.3.21

(Ps. i had to put a space between X and Org instead of a dot because if not the forum sees it as link)

edit your post and use formatting, click this icon in editor: </> and copy the output there …
you have a new hardware, so the 5.19 would be better suited for you …
so uninstall it and install the 5.18.19-3 (soon to be end of life) and try with it …

I don’t know this program. But how can it measure if the machine is suspended?

1 Like

I really don´t know. For as far as I know its a standard program that ships with Manjaro KDE…

I Just noticed an absurd battery drain while on stand by and thought it to investigate the energy stats…

the 5.18 has the same problem… Also won´t boot.

it’s a dell

See Hibernation for kernel parameters & initramfs configuration.

S3 Sleep is not supported. S0ix however works reasonably, loosing roughly 0.5% battery per hour. "RAID" needs to be changed to "AHCI" for S0ix to work. Without S0ix activated the laptop looses around 2% battery per hour.

NVIDIA's open source driver reliably disables the NVIDIA card. It is possible to use the proprietary driver, however as of August 2022 when it is used the NVIDIA GPU sometimes randomly turns on, drawing approximately 8W of extra power.

https://wiki.archlinux.org/title/Dell_Inspiron_16_Plus_(7620)#Power_Management

check the archwiki for further search like “power management”. you’ll be forced to dig deeper in this and to adjust it manually

Thank you for your answer!
Ill try that. Do you happen to know if i can switch in my bios from RAID to AHCI just like that? i mean without doing a reinstall of the os? I only run Manjaro on this machine (no windows).

no it’s not that simple but there are tweaks. check the internet and youtube for tutorials how to do this or better backup and feel safe. better safe than sorry

OK Thanks! Will do :slight_smile:

And… is that something to worry about? Or would i have to open a new topic for that?

you not being able to boot with the newer kernel could be related to ibt, so open this:
kate /etc/default/grub
and inside the GRUB_CMDLINE_LINUX_DEFAULT add this parameter:
ibt=off
dont remove anything from there, add it to existing parameters, save the file and update grub:
sudo update-grub
reboot and select the 5.19 kernel in the grub menu, - if you dont have it no longer installed, install it first before rebooting …
also switch to ahci from raid, if there are issues with switching just reinstall, since it is fresh install anyway

Dear Brahma,

Does this mean that where it says
GRUB_CMDLINE_LINUX_DEFAULT=“quiet resume=UUID=c5ccbe85-19b7-4bc8-9b4c-2887f33438b5 udev.log_priority=3”

I can press enter and type a new line underneath with the ‘ibt=off’?

this is how it would look like with the parameter at the end:

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=c5ccbe85-19b7-4bc8-9b4c-2887f33438b5 udev.log_priority=3 ibt=off"

then save it, update grub, select the 5.19 kernel in the grub menu

Thank you so much! That did the trick. I’m now running 5.19 :slight_smile:

interesting that its still not fixed, and some users still have to use this parameter …
now switch in bios from raid to ahci, to fix the sleep/battery issue …
you should have no issue switching it in linux…

OK, for that it is just going to the bios and change it if im correct?