My keyboard doesn't work till I hit it

Well, I know this is not a Manjaro bug, but most likely you will find interesting.

During boot up my keyboard doesn’t work till I literally start hitting it. Then it works without problems for the rest of the session.

What are the physics behind this? Thanks.

1 Like

Faulty wiring, slight loose component, etc.
…or maybe thats just what it likes? :wink:


Your keyboard does have suicidal thoughts or just too old to handle all that pressure anymore. time to buy a new one. :wink:


Drop kick it real hard…then by a new one is the answer! :wink:

1 Like

2009… its mouse just died… He feels alone.


Have you tried not hitting it and just wait a while?? :smiley:

It seems that it won’t work anyway, but I will have a more thoroughly look.

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

P.S. In the future, please please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most :
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.
P.P.S. Please replace your keyboard ASAHP…

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.