My iGPU lost 30-50% of performance, need help

For last 2-3 days I’ve noticed weird performance loss on my laptop. It started with weird throttling to half the FPS in Dos2 and now it’s… Well, If before at the start of Unigine Valley my fps was 40+, now it’s 30 and bellow. Depends. But, I’ve also noticed some weird CPU performance loss(30% or so), but it was only when I tried 5.15LTS (but same happened on live cd Linux mint).

Overall I tried playing with CoreCtrl, Ryzenadj, different kernels, different timeshift points, switching between Xorg and Wayland - nothing.

When I was playing with Ryzenadj, before all that happened, I changed --skin-temp-limit, thinking it’s a bit different thing and that I have default value wrote down. About the time first problem occurred, but I think a bit after that. After that I tried setting it to values from 0 to 90000 - doesn’t seem to affect anything. And for what I know - ryzenadj resets all parameters to default ones anyway.

My laptop is already really weak, now it’s just garbage. I don’t know what to do next and I need help.

My specs:

  Kernel: 6.1.49-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.1-x86_64
    root=UUID=aabcad23-aa76-449c-93dd-e561645d860c rw rootflags=subvol=@
    quiet splash resume=UUID=fa0c5767-c220-4b64-a738-2510f7578ede
  Desktop: GNOME v: 44.4 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM v: 44.1
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Acer product: Swift SF314-43 v: V1.04
    serial: <superuser required>
  Mobo: LN model: Sake_CA v: V1.04 serial: <superuser required> UEFI: Insyde
    v: 1.04 date: 07/28/2021
  ID-1: BAT1 charge: 35.9 Wh (79.6%) condition: 45.1/53.2 Wh (84.8%)
    volts: 12.2 min: 11.6 model: COSMX AP20CBL type: Li-ion serial: <filter>
    status: not charging
  Device-1: hid-98:b6:ea:79:06:a6-battery model: GuliKit Controller XW
    serial: N/A charge: N/A status: N/A
  Info: model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22
    process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x68 (104) stepping: 1
    microcode: 0x8608102
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1398 high: 1527 min/max: 1400/4056 boost: enabled
    scaling: driver: acpi-cpufreq governor: ondemand cores: 1: 1400 2: 1397
    3: 1400 4: 1400 5: 1381 6: 1386 7: 1311 8: 1366 9: 1527 10: 1398 11: 1414
    12: 1400 bogomips: 50325
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_rstack_overflow mitigation: safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Lucienne vendor: Acer Incorporated ALI driver: amdgpu
    v: kernel arch: GCN-5 code: Vega process: GF 14nm built: 2017-20 pcie:
    gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:164c
    class-ID: 0300 temp: 41.0 C
  Device-2: Quanta HD User Facing driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3:2 chip-ID: 0408:a094
    class-ID: 0e02
  Display: wayland server: v: with: Xwayland v: 23.2.0
    compositor: gnome-shell driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: 0
  Monitor-1: eDP-1 model: AU Optronics 0x683d built: 2019 res: 1920x1080
    dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6 Mesa 23.1.6-2 renderer: AMD Radeon Graphics (renoir
    LLVM 15.0.7 DRM 3.49 6.1.49-1-MANJARO) direct-render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio
    vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.1
    chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor
    vendor: Acer Incorporated ALI driver: snd_rn_pci_acp3x v: kernel
    alternate: snd_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci,
    snd_rpl_pci_acp6x, snd_pci_ps, snd_sof_amd_renoir, snd_sof_amd_rembrandt
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  API: ALSA v: k6.1.49-1-MANJARO status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 0.3.78 status: off tools: pw-cli
  Server-4: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    vendor: Lite-On driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 01:00.0 chip-ID: 14c3:7961 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IF-ID-1: tap-easytether state: down mac: <filter>
  Device-1: Lite-On Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-4:3 chip-ID: 04ca:3802
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.2
    lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c010c
  Local Storage: total: 476.94 GiB used: 348.47 GiB (73.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PDP3512B-AA1
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: EDFK0S03 temp: 46.9 C
    scheme: GPT
  ID-1: / raw-size: 451.93 GiB size: 451.93 GiB (100.00%)
    used: 346.9 GiB (76.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 1024 MiB size: 1022 MiB (99.80%)
    used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 451.93 GiB size: 451.93 GiB (100.00%)
    used: 346.9 GiB (76.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 451.93 GiB size: 451.93 GiB (100.00%)
    used: 346.9 GiB (76.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 24 GiB used: 1.57 GiB (6.6%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 45.0 C mobo: N/A gpu: amdgpu temp: 41.0 C
  Fan Speeds (rpm): N/A
  Processes: 368 Uptime: 38m wakeups: 2514 Memory: total: 16 GiB note: est.
  available: 14.98 GiB used: 4.72 GiB (31.5%) Init: systemd v: 253
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 1572 libs: 492 tools: pamac Shell: Zsh v: 5.9
  running-in: gjs inxi: 3.3.29

Hello @anon7296107 :wink:

Performance loss happens mostly on laptop because of heat. Clean you laptop first, so that cooling works as expected. :wink:

1 Like

I lost 30% in a few days.

And give me some credit :slight_smile: I thought of overheating the first thing. I have this issue even if it’s the start of a benchmark and my laptop is cold. I monitored my temps.

Plus before the issue my laptop wouldn’t throttle much from hot temps, it would simply work at max performance and then turn off :slight_smile:

set your governor to performance and test again. it’s possible that the default governor-settings have changed and now your always running with limited cpu-performance.

cpupower frequency-set -g performance

1 Like

Look, if a GPU or CPU is exposed to high temperatures for a long time, then at some point a performance loss becomes noticeable. Sometimes it’s not a gradual descent, but an exponential one until the hardware dies after you reach a threshold. It all depends on how you treat laptops. As you then tell me:

then I have only pity on your laptop.

1 Like

Monitor things first when you use it and do your tests. This will tell more than talking out of thin air and claiming this or that. Temperatures, fan speed, and all you can monitor, you monitor, then you’ll have a better picture of what happens.

Also if reverting back to a previous update when there was no issue doesn’t change anything, then it is most likely hardware failing, or just too high ambient temperature and I would stop messing with the software side then.

Maybe by messing with software you broke something, especially if you bypass protections to get the max performance out of the hardware, it will have an effect on the life span of the hardware.

1 Like

No, that’s not it unfortunately :slight_smile:

Well, I mean I know that high temps can dmg the hardware, but… So rapidly? Only damaging igpu in my APU and without any artifacts, with just a performance loss? I didn’t know that’s possible.

You know, you could’ve asked politely “Maybe you can provide more information on temperatures before and after the problem has occurred” or “Do you know your usual temps before the problem?”.

But no, you decided to be rude and inconsiderate. Without knowing the situation you suggest that I have no idea about such parameters and diminishing the value of what I’m saying

And say that I should

Very helpful, thank you.

sorry but you’re playing the blame-game… it’s your (!) part to describe the problem in a proper way and to deliver useful informations !

1 Like

And he could’ve remind about it without being a dick.

people like you are the reason why a lot of others stop to give a helping hand. none of us is paid and it’s too often that noobs start claiming and it’s the usual xy-problem in the end. and you call them “dick” ?
do the math !

1 Like

I call them out for being rude. It’s okay to be bored with similar situation where people ask help without giving enough information, but it’s not okay to act rudely towards them because of it.

I’m dealing for a few days with my only laptop loosing it’s already limited GPU power, trying different things, ignoring other stuff that has to be done because of it, I’m freaking stressed. I forget to mention temperature because I tossed it out as a potential reason a long time ago and some random guy starts talking with me rudely because of it. How do you think I feel?

All in the situation where it’s really obvious that If I play with RyzenAdj - I know what a freaking throttling is. It’s honestly insulting to suggest that I would try different kernels, distro, timeshifts and wouldn’t think to check if my laptop is just throttling. It’s the first thing that people check.

I think you have an issue (in your head) if what I wrote is insulting, being a dick, and all the ■■■■ talk you did about me. Over sensitive kids nowadays. My post was kinda nice actually, constructive at least. You’ll have bigger issues in life if my nice post makes you react this way. And one day by talking to people like tat for no reason, you’ll have surprises.


And the issue is - my distro probably got corrupted one of the times my laptop was turning off from overheating.
Secondary problem is that 5.15LTS doesn’t work for my laptop anymore, for some reason, reducing my performance by about 30% as well, only for CPU too.
So when I tested on LinuxMint, that still has 5.15LTS - this problem prevented me from seeing the main issue.

Running a few tests on EndeavourOS showed that my hardware seems to be alright. Performance is on the level it supposed to be.

Case closed.

Sorry, I could’ve reacted better. Like I said, I was stressed and exhausted. I wouldn’t post about this problem here if I wasn’t dealing with it for a few days for myself, being desperate.

But you really need to work on your wording, because this:

Is a bad wording at best and deliberately disrespectful and diminishing at worst.
When people come with a problem you don’t just say “you’re talking out of thin air”. It’s incredibly hostile and if you’ll say it too often - you’ll just drive people away from your forum.

Also suggesting me to “do my tests” isn’t great too. How do you know I didn’t do them before the issue? You don’t, because it isn’t true. You just made an assumption and spent whole paragraph “educating” me based on it.

I have no issues at all with other stuff in the post.

Honestly, I now see once again a reminder - better to solve my problems myself. :sweat_smile:
Because you all said to me were just generic things. Which is okay, I didn’t give you a whole picture. But to avoid you saying them, I’ll need to make my post in such detail, that I’ll take same time as it would to solve the problem. And it’s true for most of the stuff.

Have a good day :slight_smile:


Have a nice day too, no hard feelings, but as a reminder because you want to double down, this is a technical support forum, not an emotional support forum, sorry.

Great that you eventually found the issue, and by yourself :+1:

1 Like

perfect !

and the next time start asking about problems at the endeavour-forum :stuck_out_tongue_closed_eyes: you’ll be amazed about their nice and friendly behaviour :smiling_face: :rofl: :crazy_face:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.