My Gnome Disk Manager mysteriously stopped working

I’m running Manjaro Mate on a Lenovo desktop PC, and this morning my Gnome Disk Manager (executable file “gnome-disks”) suddenly stopped working. When I attempt to launch it from Brisk Menu Launcher, my mouse pointer turns into an animated swirly for 15 seconds but nothing happens.

This is after installing several new packages (mostly file managers – looking for something that I like better than Caja) this morning, so there is a possibility this problem may be caused by a package conflict.

But the problem may be caused by something else, so I figured I’d ask here before wasting hours uninstalling (and later reinstalling) packages.

I ran “journalctl | tail -n 20” but I see nothing relevant in the time frames when I’m trying to launch “gnome-disks”. So, what else can I try to see what the cause of this program not launching is?

What happens when you launch it from terminal. share output

1 Like

Ah! Never thought of that. Let me try that… HMMM!!! It actually launches! No output at all to the terminal, the caret disappears until I exit the app. And the app works normally.

Now let me try launching from menu again… nope, won’t launch from menu. That’s quite odd.

That’s odd. Well, let’s see what the menu entry is running. It should be:

❯ cat /usr/share/applications/org.gnome.DiskUtility.desktop | grep Exec

Make sure you don’t have a custom desktop file in ~/.local/share/applications/ that’s doing something different.

Yes, that’s exactly the result I get from running that command. I’ve also determined that if I put a launcher directly on my bottom panel, the app launches. But it won’t launch from Brisk Menu, and it won’t launch from Classic Menu. (I put both on my panel to test that.)

I solved the problem! It turned out to be a bad launcher. When I deleted the launcher and made a new one, it now works fine.

Your question led me down the path to the solution; thanks! Your suggestion that I open the app in a terminal rather than through menu led me onto the right path. I thought, "Well, if it launches from a terminal… and it launches from the panel… but it doesn’t launch from the launcher in Brisk Menu… and yet, Brisk Menu itself is working… then it must be the launcher that’s broken. So I erased the launcher and made a new one called “Gnome Disk Manager” with command “/usr/bin/gnome-disks”, and it now works fine! Odd, because the old launcher had the right command, and yet wasn’t working.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.