My fan wont turn on

I ran lm_sensors and my fans wont show up. Which leads me to think I didnt set something up correctly. I am not sure what I need to offer via information or anything like that so just ask if you want to look at anything.

You might want to mention which fan. The case, cpu, or graphics card fan? Then what hardware you are using.

All of them, I am sorry I should of specified.

to do so post the output of

inxi --admin --verbosity=7 --filter --no-host --width 

use the option of preformatted text and place it in there.

  Kernel: 5.15.0-53-generic x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15.0-53-generic
    root=UUID=593dbb30-69dd-45ad-ad77-74d05c68389e ro quiet splash
  Desktop: Cinnamon 5.4.12 tk: GTK 3.24.33 wm: Mutter vt: 7
    dm: LightDM 1.30.0 Distro: Linux Mint 21 Vanessa base: Ubuntu 22.04 jammy
  Type: Laptop System: Microsoft product: Surface Laptop Go
    v: 124I:00057T:000M:0000000D:0B:04F:1C:05P:48S:01E:0Y:0K:0U:02
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: Microsoft model: Surface Laptop Go serial: <superuser required>
    UEFI: Microsoft v: 9.101.140 date: 04/30/2021
  ID-1: BAT1 charge: 22.4 Wh (62.9%) condition: 35.6/39.7 Wh (89.7%)
    volts: 7.7 min: 7.6 model: SMP Z91 type: Li-ion serial: <filter>
    status: Discharging cycles: 132
  RAM: total: 7.36 GiB used: 2.43 GiB (33.0%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-1035G1 bits: 64 type: MT MCP arch: Ice Lake
    family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xB2
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 1100 high: 1101 min/max: 400/3600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1100 2: 1100 3: 1101
    4: 1100 5: 1101 6: 1101 7: 1101 8: 1100 bogomips: 19046
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
    avx512_vnni avx512_vpopcntdq avx512bw avx512cd avx512dq avx512f avx512ifma
    avx512vbmi avx512vl bmi1 bmi2 bts clflush clflushopt cmov constant_tsc
    cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms
    est f16c flexpriority flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp
    hwp_act_window hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed
    rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect ss ssbd sse
    sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi vpclmulqdq vpid
    x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Iris Plus Graphics G1 vendor: Microsoft driver: i915
    v: kernel ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:8a56 class-ID: 0300
  Display: x11 server: X.Org v: driver: X: loaded: modesetting
    unloaded: fbdev,vesa gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1536x1024 s-dpi: 96 s-size: 406x270mm (16.0x10.6")
    s-diag: 488mm (19.2")
  Monitor-1: eDP-1 model: LG serial: <filter> built: 2020 res: 1536x1024
    hz: 60 dpi: 148 gamma: 1.2 size: 263x175mm (10.4x6.9") diag: 316mm (12.4")
    ratio: 3:2 modes: 1536x1024
  OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 22.0.5
    direct render: Yes
  Device-1: Intel Ice Lake-LP Smart Sound Audio driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_icl bus-ID: 00:1f.3
    chip-ID: 8086:34c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.0-53-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:34f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: temporary dynamic scope: global
  IP v6: <filter> type: dynamic mngtmpaddr noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:4 chip-ID: 8087:0026 class-ID: e001
  Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 3.0
    lmp-v: 5.2 sub-v: 237e hci-v: 5.2 rev: 237e
  Info: acl-mtu: 1021:4 sco-mtu: 96:6 link-policy: rswitch sniff
    link-mode: peripheral accept
    service-classes: rendering, capturing, object transfer, audio, telephony
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 119.24 GiB used: 19.9 GiB (16.7%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
    model: HFM128GDGTNG-87A0A size: 119.24 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 80041C00 temp: 25.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 118.74 GiB size: 116.32 GiB (97.96%) used: 9.95 GiB (8.6%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
    uuid: 593dbb30-69dd-45ad-ad77-74d05c68389e
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 5.4 MiB (1.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: F3E9-E87B
  ID-3: /home/grimsongrimelt raw-size: N/A size: 116.32 GiB
    used: 9.95 GiB (8.6%) fs: ecryptfs source: ERR-102
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-3:2 info: Elan Micro Touchpad and Keyboard
    type: Keyboard,Mouse driver: hid-generic,hid-multitouch,usbhid interfaces: 2
    rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 04f3:0c5b class-ID: 0301
  Device-2: 3-5:3 info: Elan Micro ELAN:ARM-M4 type: HID
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 04f3:0c5a class-ID: 0300
  Device-3: 3-10:4 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-4: 4-0:1 info: Super-speed hub ports: 6 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 32.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 260 Uptime: 8m wakeups: 4 Init: systemd v: 249 runlevel: 5
  tool: systemctl Compilers: gcc: 11.3.0 alt: 11 Packages: apt: 2089 lib: 1035
  flatpak: 0 Shell: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.13

It just doesnt detect the fan.

please open the packet-manager and install the following package:

do a reboot and post any changes.

NOTE: you must enable the aur-packages to install it.

Did you follow: lm_sensors - ArchWiki, especially the setup section?

Yes I did

I cant seem to find the package, I found the github page for it thought but it is ment for arch linux, would it still work?

as said, you must enable the option to use the aur-packages in package-manager ! after this install it from the package-manager.
settings-> third-party-supply

If step 3 doesn’t output any sensor data then you might need to reconfigure i guess, or your hardware is not supported at all at worst case :woman_shrugging:

(I can’t give you any advice on which probes to allow that are not probed by default because i dont use that package)

It does not show me the option for that. One second im just gonna install the Aur-package through the terminal then try again to look for it.

Ok so you contradict your self, you didn’t :crazy_face:

All AUR packages are meant for Arch, Manjaro is Arch based… :wink:

The command lm_sensors just doesnt work. So when I tried to do it, it just didnt work. Probably should of said that, thought I did. My bad.

Thats the name of the package, read that wiki page to see which commands you can/should use :stuck_out_tongue:

PS: The lm_sensors package is in the official repos (extra), it is not an AUR package…

Linux Mint 21 Vanessa base: Ubuntu 22.04 jammy


omg you’re right :exploding_head:


your on linux-mint not manjaro as @manyaro01 already stated. sorry, but you should check the linux-mint forum in this case.

1 Like

@Grimsongrime , sorry but how can you expect people of a different distro to help solve your problem in this case?
We are all helpfull, but there is a limit in abilities to find the cause when we use a different distro as you…

So please be so kind to ask on their forum instead like @Olli said, its not because we don’t like that distro or dont want to help, but more because it’s most likely a distro related thing.

1 Like

@Grimsongrime or otherwise download manjaro and install it. maybe you’ll get a new manjaro-user.