My experience with Manjaro OpenBox installation

So for last 4-5 months I’ve been using the Manjaro i3 edition and for the most part I really liked it, the biggest problem was that things like simple bluetooth and sound manager were missing so it made setting some stuff up really hard. So when I had to reinstall I was exploring my options and found the Manjaro OpenBox edition, watched some reviews on youtube and really liked it.

Before I made the decision whether OpenBox is for me I wanted to try it first, so I played around in the liveboot for a while(actually I am making this post from the liveboot) and I really felt in love with it. Everything was so fast and smooth, the system settings were really friendly and the keybindings were really similar to my previous i3 setup.

So everything sounds great right? Well…

After I installed it and booted, the resolution was 1280x720, I am pretty sure it is the same issue as https://forum.manjaro.org/t/manjaro-openbox-resolution-issue/73236 (I also have dell xps 13 9730)

Well I tried fixing it with xrandr and even tho it was pretty easy to get the display to 1920x1080, the polybar was still 1280px wide and the wallpaper shifted and generally it looked pretty bad.

Another weird thing was that when you press

[super] + e

in the liveboot version, xed text editor opens, but in the installed version the only thing that happens is that error gets thrown that “coudn’t find subl3” or something like that, which is really weird.

I thought that maybe running a system update could help so I updated everything using the pamac package manager and after reboot the system became kinda slow and basically everything stopped working. First thing that appeared on the screen was some error with blueman, next thing was when I hit [super] + e error was thrown that it couldn’t find terminal.

I might be a Linux noob, but I think that it is really weird when things like this happen and I am really sad that even tho it worked so well in liveboot, it was very different after the install.

probably @linux-aarhus test something and forgot to change binding to xed

Mistakes are normal and I guess should be expected if only one person work on distro or bigger project :wink:

1 Like

For the sake of those considering the i3 edition I would like to correct two errors in your first paragraph:

  1. the bluetooth manager is available from the Mod+z (morc_menu) and
  2. the alsacontrol sound manager is available from the Mod+shift+b (b_menu).
3 Likes

do you mean xps 9370? theres an arch wiki for 9370 and 9360 filled with useful info. they are both good sources of info.

exactly what did you do?

you mean this one?

 Warning: blueman: directory permissions differ on /usr/share/polkit-1/rules.d/filesystem: 750  package: 755
fixed with:
sudo chmod 755 /usr/share/polkit-1/rules.d/filesystem

i mainly use openbox and it’s been absoluely great since i started using it a little over a month ago iirc. are you sure the update finished properly? you may want to run it again from terminal/TTY
sudo pacman -Syyu

announcements/troubleshooting

1 Like

:lollipop:


I have no problems with Openbox on any of my systems. I think the Dell systems is quite overrated. I guess it works great with Ubuntu because that is what they put on their Linux dedicated systems. As soon as you start experimenting you run into issues of different kinds.

Slight OT on experimenting

The Manjaro #bladebook is an example of hardware which Manjaro has been specifically designed to work on. If you try an Ubuntu on #bladebook you will discover your touchpad is not working.

The ABook V142 is a system which has a similar issue but this time with the wireless network. If you install Ubuntu the wireless will work in live during install but not after reboot but do you use Manjaro then a driver is installed with the ABook specific ISO.

Solutions you can try

Try opening the root menu Super+Space

Select PreferencesSystemSettings ManagerMonitor

Set your preferred screen resolution.

Also you can edit the ~/.config/openbox/autostart and move the entry for xfsettingsd to the top of the file.

For the missing application you can install it using pamac.

pamac build sublime-text-dev

It is not installed due to distribution issues and it is a neglect on my side the shortcut is hardcoded - I will fix it in the settings package.

1 Like

Ye, I guess that my laptop for some reason just doesn’t work with your manjaro edition, I am sorry If I made it sound like it is your thing that is broken and not mine, really didn’t mean to say that. I was just curious for how can something like that happen (liveboot so great and install so bad), but ye I guess I will go back to the i3 edition which worked pretty well for the most part. <3

I admit that I didn’t know about the bluetooth manager, but I knew about the alsacontrol sound manager and to be honest it never worked well for me, not sure if it is the manager’s fault or alsa’s fault, but I could never get an USB headset to work, even tho it showed up in the alsacontrol manager. Also the reason why I needed the bluetooth manager is because I would like to use bluetooth headphones and I really don’t know if I could get them working using Alsa.

I know that you can run install_pulse and get PulseAudio, but there isn’t any manager for that right? Not sure if it is hard to install it or not so…

Anyways, I am installing manjaro i3 edition again, because it has been best distro edition I’ve ever used, the only problem being the sound, but I am pretty sure I could solve it if I was a bit more capable.

I really did not intend to suggest something is broken - as I don’t think it is - just that some systems in certain situations requires a more effort on the users side than just OOB to overcome system specific issues.

the xps models seem to have a higher number of odd issues than others, as do the newer precision models but still usually fixed after a few changes suggested in the arch wiki.

@snakeone although your model is 9370, the arch wiki for 9360 is still applicable for the most part and has more info than the 9370 wiki, same might be said for other similar models in the precision line.

Most Bluetooth issues are solved by first unpairing the device with any device it may have been previously paired to and starting over with the pairing on the new system. It will then just appear as another audio device in alsamixer - use F6.

1 Like

Well I don’t know about bluetooth devices, but I really can’t get USB headset to work.

I open AlsaMixer, the USB headset shows up I select it and I can even hear sound in my headset when I adjust the volume or when I mute/unmute it makes a sound, but all the sound on my system just keeps coming out of the speakers. I am not sure if I am supposed to somehow save the configuration, but no matter if I stay in AlsaMixer or I leave the sound plays from speakers and when I reopen AlsaMixer the defaul sound card is selected again.

EDIT: When I turn on the mic playback thing and exit AlsaMixer, I can still hear all of the sound coming in the USB mic in the headset, but for some reason all the system sounds are still being played out of the speakers.

When in alsamixer find either “Auto Mute” and/or “Headphone Jack Sense” and try enabling/muting those.

To save the alsa config “sudo alsactl store” in a terminal.

There is an automute in the default sound card and it works well in combination with jack headphones, but there is nothing like that in the USB sound card settings. Looks like no USB headset for me, even tho it worked perfectly when using Ubuntu or the openBox liveboot.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.