My Ethernet is not working on Manjaro 18.0.4 Gnome

#1

Hey,
I am using latest Manjaro 18.0.4 Gnome, somehow my ethernet was working only sometimes, and when it wasn´t I needed to reboot the pc to Windows and then coming to manjaro for it to work. Now it stopped working and I don´t know what to do. I already tried to boot on older kernels, changing to static ip via nmtui and none of these helped me :disappointed:.
I hope that somoene can help me, beucase it is working just fine on windows, but on manjaro not.
Thanks,
Miguel de Carvalho

#2

post output

inxi -n
#3
Network:
 Device-1: Intel Wireless-AC 9260 driver: N/A
 Device-2: Intel I211 Gigabit Network driver: igb
 IF: enp24s0 state: down mac: 30:9c:23:df:41:98
#4

I would suggest installing and testing both older and newer kernels. Try at least two or three alternate kernels, starting with 5.1. Install kernels through Manjaro Settings Manager, and always have at least two kernels installed at all times for safety.

Please post a full inxi:

inxi -Fxxxz
#5

I have this kernels installed:

- 5.0.9
- 5.0.7
- 4.19.36-1

Wifi is not working neither, and it is a bit difficult to get logs to here xD but I am going to try

#6

Can you use USB phone tethering for an internet connection. I would highly suggest installing kernel 5.1 if possible.

Windows may possibly be interfering with your LAN or Wifi, try this:

Disconnect any other network devices that do not require troubleshooting. This includes LAN cables, USB to Ethernet adapters, and USB phone tethering.

Power down the laptop and remove the battery and power plug. Let the laptop sit without power for a few minutes. Then, hold down the power button for approximately 30 seconds. Pressing the power button will help drain all left over power from the unit’s motherboard.

Then reattach the AC power (no battery), and restart. Boot into your bios, then reset the bios to the factory defaults, save the default settings. See if it will boot correctly with the factory default settings. If not, you may have to change a few settings in the BIOS (such as secure boot) to get Manjaro to boot correctly. After rebooting your adapter may be properly detected and initialized.

Run this command:

rfkill list

Does it return yes for blockages?

1 Like
#7

Wifi is back but ethernet no.

0:  hci0: Bluetooth
  Soft Blocked: no
  Hard Blocked: no

1: phy0: Wireless LAN
  Soft Blocked: no
  Hard Blocked: no
#8

Run these commands, please post all inputs and outputs:

sudo modprobe -r igb
sudo modprobe igb
sudo ip link set enp24s0 up
sudo systemctl restart NetworkManager
#9
  • Kernel 5.1 is successfully installed but I cant boot on it. It fails and get stuck

  • inxi -Fxxxz

Network:
  Device-1: Intel Wireless-AC 9260 driver: iwlwifi 
  IF: wlo1 state: down mac: 46:83:35:06:b2:7e 
  Device-2: Intel I211 Gigabit Network driver: igb 
  IF: enp24s0 state: down mac: 30:9c:23:df:41:98 
miguel@miguel-desktop ~> inxi -Fxxxz
System:
  Host: miguel-desktop Kernel: 5.0.9-2-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.3.0 Desktop: Gnome 3.32.1 wm: gnome-shell dm: GDM 3.32.0 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: Micro-Star model: B450 GAMING PRO CARBON AC (MS-7B85) 
  v: 1.0 serial: <filter> UEFI: American Megatrends v: 1.60 date: 03/06/2019 
CPU:
  Topology: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ 
  rev: 2 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 92429 
  Speed: 1540 MHz min/max: 1550/3850 MHz boost: enabled Core speeds (MHz): 
  1: 1462 2: 1469 3: 1537 4: 3509 5: 3745 6: 1539 7: 1540 8: 3757 9: 1536 
  10: 1432 11: 3502 12: 1540 
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1070 Ti] vendor: Micro-Star MSI 
  driver: nvidia v: 418.56 bus ID: 1c:00.0 chip ID: 10de:1b82 
  Display: x11 server: X.Org 1.20.4 driver: nvidia compositor: gnome-shell 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 1070 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 418.56 
  direct render: Yes 
Audio:
  Device-1: NVIDIA GP104 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 1c:00.1 chip ID: 10de:10f0 
  Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 1e:00.3 chip ID: 1022:1457 
  Sound Server: ALSA v: k5.0.9-2-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel bus ID: 17:00.0 
  chip ID: 8086:2526 
  IF: wlo1 state: down mac: <filter> 
  Device-2: Intel I211 Gigabit Network vendor: Micro-Star MSI driver: igb 
  v: 5.4.0-k port: f000 bus ID: 18:00.0 chip ID: 8086:1539 
  IF: enp24s0 state: down mac: <filter> 
  IF-ID-1: enp3s0f0u3 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:
  Local Storage: total: 1.42 TiB used: 79.24 GiB (5.5%) 
  ID-1: /dev/sda vendor: Crucial model: CT240BX500SSD1 size: 223.57 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: R013 scheme: GPT 
  ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-08WN4A0 
  size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> 
  rev: 1A02 scheme: GPT 
  ID-3: /dev/sdc vendor: Western Digital model: WD3200AAJS-08L7A0 
  size: 298.09 GiB speed: 3.0 Gb/s serial: <filter> rev: 3E03 scheme: GPT 
Partition:
  ID-1: / size: 59.35 GiB used: 26.00 GiB (43.8%) fs: ext4 dev: /dev/sda4 
  ID-2: /home size: 260.91 GiB used: 52.97 GiB (20.3%) fs: ext4 
  dev: /dev/sdc2 
  ID-3: swap-1 size: 32.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdc1 
Sensors:
  System Temperatures: cpu: 38.6 C mobo: N/A gpu: nvidia temp: 49 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:
  Processes: 381 Uptime: 23m Memory: 15.67 GiB used: 2.47 GiB (15.7%) 
  Init: systemd v: 242 Compilers: gcc: 8.3.0 Shell: fish v: 3.0.2 
  running in: gnome-terminal inxi: 3.0.33 
  • sudo modprobe -r igb
miguel@miguel-desktop ~> sudo modprobe -r igb
[sudo] password for miguel: 
miguel@miguel-desktop ~> 
  • sudo modprobe igb
miguel@miguel-desktop ~> sudo modprobe igb
miguel@miguel-desktop ~>

*sudo ip link set enp24s0 up

miguel@miguel-desktop ~> sudo ip link set enp24s0 up
                         
miguel@miguel-desktop ~> 
  • sudo systemctl restart NetworkManager
miguel@miguel-desktop ~> sudo systemctl restart NetworkManager
                          
                         
miguel@miguel-desktop ~>
#10

There was no error raising your adapter, so you should have some kind of connectivity on your LAN now.

#11

I tried again and I dont have.
If I open nmtui and try to activate theenp24s0`, I got a "Could not ativate connection: Connection ' Wired Connection 1' is not avaible on device enp24s0 because device has no carrier".

#12

If you have the wired and your wireless connections configured for the same IP address they can clash with you trying static settings.. Reboot your router, go through your router settings. Try a different port on the router. Try a different cable. Try a completely different router if you have a spare. Test the lan connection on a different network. Test the lan on a live disk.

Please post the output of the following commands:

hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status" 

With your wifi deactivated:

ping -c5 8.8.8.8
ping -c5 google.com 
#13

I rebooted and the ethernet is working now. But I can´t boot the kernel 5.1

#14

Simply uninstall kernel 5.1. Install kernel 5.0 if you want to test it out. Please mark your thread solved if that takes care of your issues.

Glad that got things working.

#15

Thanks for helping me out.

1 Like
#16

You're very welcome.

1 Like
#17

Another one bytes the dust. ha ha. :+1::+1::+1:

2 Likes
#18

I am getting this problem again. I didn´t use pc for a day and when I turned it on, ethernet wasn´t working anymore.

#19

Please post the output of the following commands:

inxi -Fxxxz
hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status"
lsmod |sort
grep -r "blacklist\|install\|options"  /etc/modprobe.d/ /etc/modules-load.d/ /usr/lib/modprobe.d/ 

Did you boot Windows again?

If you booted into Windows again, you will likely have to do another hard power cycling. As I mentioned a while back this sounds like Windows messing with your networking.

See if unplugging the network cable after a shutdown makes any difference. Try plugging/unplugging it after restarting.

Are you leaving both adapters activated at the same time? If you are using wifi your LAN cable is best left unplugged. If you are using your LAN as your main connection then disable your wifi via your function keys (or a hardware switch).

Did you reboot your router?

I would suggest setting a static IP address for your LAN adapter via mac address association in your routers settings.

This statement tells me next to nothing.

Can you ping your router?
Can you ping google?
Is your adapter reported as up.
Is your driver loaded.
Have you tested your lan from a live disk.
Have you tested your lan at a friends/neighbours.