My Clock Runs An Hour Behind But The Usual Hotfixes Aren't Working

Hey everybody, I’ve been scouring this forum for the last few days trying to figure out this bad-boy bug but I have come up short. First, some general information about the system I’m running:

OS: Manjaro Nabia 20.2 Nabia
Kernel: 5.4.72-1 MANJARO
Is installed on and being booted from a 128gB USB stick

Here’s what I have tried so far:

  • I have edited the regedit of the windows installation of the laptop
  • I have set the time manually in the BIOS
  • I have ran just about every configuration of timedatectl

What happens, essentially, is that my clock is always running one hour behind the actual time.

Setting the time in BIOS fixes this problem for five minutes, and then it jumps back an hour again. The time on the Windows 10 installation on the PC is correct. Here’s what timedatectl returns:

Local time: Thu 2020-11-05 14:24:57 CET

Universal time: Thu 2020-11-05 13:24:57 UTC

RTC time: Thu 2020-11-05 13:24:57

Time zone: Europe/Stockholm (CET, +0100)

System clock synchronized: yes

NTP service: active

RTC in local TZ: no

The Local Time is correct, the Universal Time and RTC time is not. Setting
timedatectl local-rtc 1
timedatectl set-time “(the time)”

sets RTC time to be correct, but doesnt change the time on the clock widget in the top right.

I even tried setting the timezone to be one hour later than the one i am in, but again, this has had no effect on the system time. Most people manage to solve their issue within one or two commands, yet my timedatectl seems to be extremely stubborn.

Any ideas of what I could do? Thank you!

Did you set it to properly read the system time as UTC?

That is not true; from your output, everything looks OK.

Remember, UTC is constant. It does not change/care one whit about daylight savings time.

So, as a quick, totally hack test, I’ll hover my mouse over the little edit icon in your OP…times in this test are my localtime (EST -0500)

Edit time: 5 Nov 2020, 0853.

My time now is 0908.

date -u && date
Thu Nov  5 02:08:57 PM UTC 2020
Thu Nov  5 09:08:57 AM EST 2020

Corresponds to ~15 mins. It’s correct here.

Note the UTC time (mine and your OP). The corresponding difference is correct, see?

So, again, based on what your timezone is in your OP, it is +1 hour ahead of UTC.

This is all correct.

Did you set it to properly read the system time as UTC?

I followed the guidelines for regedit on windows on the archwiki article for system-time, if there are further steps then I am not aware of those.

So, again, based on what your timezone is in your OP, it is +1 hour ahead of UTC.

Then what do I do? The timezone I have set runs one hour later than the timezone I am in, so at 12:00 here the clock is 13:00 there. Yet, at 12:00 here my Manjaro shows 11:00. The extra hour isn’t even added.

I tried playing around with setting different timezones but the clock remained unchanged.

I think the issue is solved?

I set my timezone to my local one, set set-local-rtc to 0 and set-ntp to false, and suddenly my clock jumped forward an hour. That seemed to be the winning combination that solved the puzzle. Thanks for the help! Can I mark a thread as solved?

You need to set your BIOS time to the UTC timezone, and configure your Linux to have HW-Clock (aka BIOS/RTC time) set to UTC.
THEN you can enable NTP and set your timezone to +0100.

If it is not correct after you have run your M$ then you need to adjust that in M$ to be UTC also.
(M$ is noob when it comes to RTC because all BIOS times should be in UTC so the user can have it displayed in other time-zones without affecting the real time/date)

NTP is to keep your clock synchronized with the internet time servers all around the globe…
So you should never disable NTP, else you can run into problems with various stuff…

No need to resort to external sources in this case.

And - as @TriMoon points out - you need to ensure your bios clock is correct - this can usually be done from a correct configured Manjaro using

# hwclock --systohc --utc

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.