Music players quit working (Manjaro 20.2.1)

My music players suddenly stopped working. When I try to play a music file, there’s no sound. It’s like the volume is set to mute. I have this with Cantata, Clementine, and cmus. Guayadeque and VLC both still play music files, however. I also tried opening the files in Chromium, and that worked, too. I have this problem with both MP3s and OGGs.

I tried using pacat < /dev/urandom to test out PulseAudio, and I got white noise out of it, so apparently PulseAudio works. What does Cantata, Clementine, and cmus use that Guayadeque does not? Guayadeque and Clementine both use GStreamer, so I guess it can’t be that. Since Cantata uses MPD, I thought that there might be a problem there. There was an issue with it setting the file, but I fixed that, and the sound still hasn’t come back.

I’m on Manjaro 20.2.1. Here’s what I got from lspci for audio devices:

Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series]

I would rather not use Guayadeque, since I like Clementine a lot better. Any ideas?

Found it!

It turned out that those music players had become muted in pavucontrol somehow. I unmuted it in the Playback tab in pavucontrol.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.