Multimedia keys on keyboard in cinnamon stopped working after Update

Since the update to cinnamon 4.8.0 recently the multimedia keys on my keyboard (play/pause, forward, back) stopped working in spotify and all the other applications they were working in previously. When pressing the forward and back keys I just get a not available sign on the screen (the crossed circle), pressing play/pause weirdly triggers a screenshot.

I’m guessing the keybindings have somehow changed, but I can’t find where to change them back or understand why they changed in the first place. Anyone know about this issue? How can I fix this?

1 Like

I’m seeing the same thing after the update on my T61 and T420 Thinkpads.

Settings > Keyboard > Shortcuts

I checked there and the keybindings seem to be set correctly. Still don’t work correctly though… Something seems broken.

Try reinstalling udev

This is also happening on Arch systems Seems there is a udev issue, reinstalling the three packages should fix it:
sudo pacman -S systemd systemd-libs libgudev

This didn’t work for me, I keep having the same issues… has it worked for anyone else?

Edit: Before anyone tells me to, I also rebooted after reinstalling :wink:

Me too, neither! :grinning:

Was the system restarted?

Yes, I rebooted. I tried again just now with the same result. Pressing play/pause still captures a screenshot.

Yeah, something got screwed up in udev… udev is part of systemd and something went wrong. Even the cups service was disabled in systemd. In this last update.

OK, this IS fixed in Arch… My desktop is running arch and the issue is gone, and my laptop is running Manajro,
Arch version of systemd is 247.1-1, Manjaro is 246.6-1 udev is part of systemd…

Once, Manjaro updates to the newer version, issue should be fixed.


Thanks for checking in to this for us!

I’m running cinnamon on testing branch and haven’t had any of the issues people have been posting about. Either I’m lucky or the updates are in the testing branch already

Thanks @DeLinuxCo for your help!
Guess we’ll have to wait for the new systemd to trickle down into the stable repos.

I can’t believe no one has tried, or did the obvious: take the keyboard out of the cinnamon!


The same is happening to me, with the additional of, at certain time, the SUPER+ shortcuts stop working (as in SUPER+E to open Nemo, for instance)


Ive changed my repositories to the “test”, updated everything and started working again (sudo pacman -Syyuu)

I installed a large update today, and the problem appears to be fixed now.

im on xfce and 3 months later im still having the same problem with all updates installed. none of the multimedia keys work and also the volume encoder. im running pulseaudio and jack on top. i pipe pulseaudio into jack via the below script.

also the pulseeffects dont work so i suspect a pulseaudio problem which of course is a wild guess because i dont understand the mechanism. the volume encoder affects the levels in volume control of pulseaudio for sure.

is there a summary of how the multimedia keys work? what exactly do i need to reinstall for this to be fixed?

pulseaudio -k
killall jackd
sleep 1

jackd --autoconnect a -R -d alsa hw:0 -p 128 -n 2 &
sleep 1

pulseaudio --start
pactl load-module module-jack-sink channels=2
pactl load-module module-jack-source
pacmd set-default-sink jack_out

a2jmidid -e &