Multimedia keys are breaking Xorg

I’m having a bizarre problem within i3 where some multimedia keys are seemingly “breaking” Xorg. The mode of “breaking” is rather bizarre: some basic mouse and keyboard functions work, but most important stuff does not: I can not switch workspaces (keybindings with meta and numbers) mouse clicks don’t appear to be working.

I tried looking at what these keys are first using xbindkeys --key. I was expecting the keys that were not breaking to be XF86Forward and XF86Back but, to my surprise, they instead showed up as simply Next and Prior.

I then tried the keys that are breaking X. Unfortunately XBindKeys can’t seem to capture them. I looked at xev and it gives some stuff I can’t make sense out of, here is a picture that I had to capture with a camera because Xorg is FUBAR at this point:

My questions are, at this point, probably obvious:

  • How do I stop these inputs from breaking Xorg?

  • Further, can I rebind them to something useful instead?

Some additional context that may or may not be relevant: this machine is on a TV and I have been experimenting with “air mouse” devices. For the most part Xorg just thinks they are normal devices. I believe they talk to USB as simple mice and keyboards to achieve wide compatibility. I have found similar behavior on another keyboard with multimedia keys (still checking which keys do it), so I don’t really think it’s very particular to these weird “air mouse” things, but thought I’d mention it. (Update: Additionally, I am indeed seeing exactly the same behavior on two different “air mouse” devices. The “home” button [not the real home button, a little icon with a picture of a house] is the biggest culprit and is shown above.)

Update in case anyone is interested:

I still don’t entirely understand what happened here, but it turns out that whatever it was only occurs when Xorg was started from a virtual console using startx. When using the display manager, all these buttons work normally. I think there was some kind of passthrough command to the underlying terminal that was getting triggered.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.