Multi Monitor display configuration, configuration dialog missing checkbox for 'Primary' Display

i recently installed Manjaro KDE/Plasma on my xps 15 and there are a couple of issues I wanted to request help from the community on. (I am a noob on Linux so please excuse me if i incorrectly refer to certain components)

I am using Plasma on Wayland since this is the best / easiest option I came up with that supports mixed DPI configuration (4K laptop - 200% scaling , and external monitor - 100% scaling). I tried Wayland on Ubuntu's default Gnome but not all apps (including firefox) would scale correctly when moving from one desktop / screen to the other. surprisingly works really well on Plasma.

the issue I have is:

  1. as per the screenshot below in the 'Display configuration' Dialog, there is no option to 'set as Primary' display option. IF i recall correctly, on the live USB (installer) the option was appearing under the marked 'Enabled' Option
  2. I have to disable the Laptop display to get the external monitor get assigned as the primary display (re-enabling laptop after wards behaves as a secondary display). Every time I restart the machine the display configuration is reset and laptop display again becomes the primary display.

Any pointers/suggestions on how to fix this will be highly appreciated.

can you check the output of 'xrandr' and post it.

Are you sure that will work under


1 Like

yeah, not sure if that is helpful, looks like xandr output is virtual displays

Screen 0: minimum 320 x 200, current 5360 x 1440, maximum 8192 x 8192
XWAYLAND0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 350mm x 190mm
   1920x1080     59.96*+
XWAYLAND1 connected 3440x1440+1920+0 (normal left inverted right x axis y axis) 800mm x 340mm
   3440x1440     49.96*+

okay i'm no expert on wayland. it seems to me that the installation (live cd) runs with the x-server where it's possible to set the option of a primary display. i don't know if this option is avaible with wayland.

hmm.. sounds plausible... thanks.
will try to read up more on wayland.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by