MTP file transfer not working - Manjaro Cinnamon

Okay so first major issue and I hope to have it solved.
I want to connect my phone via USB to my computer, a simple common function i have done in every other distro under the sun and windows.
I dont want to make a remote FTP connection i want to simply plug my phone in and be detected by manjaro

Is there any way to resolve this issue in manjaro?

https://wiki.archlinux.org/index.php/Media_Transfer_Protocol

you need to enable/allow mtp on the phone itself.

2 Likes

Check if you have the gvfs-mtp package installed.

As @dlgt check your phones display. You may have a box telling you the phone is charging.

Tap the message and select file transfer.

2 Likes

Yeah I already enabled mtp on the phone, I had that enabled already as i do the same thing when using Ubuntu/Mint.
Figured this may or may not be a missing package thing (as well this is a community version after all so hey cant exactly blame that bit)

The only packages needed seems to be

  • gvfs
  • gvfs-mtp

There is of course several other packages but these makes it for me on Openbox.

gvfs - I think is acronym for Gnome Virtual File System - which probably already present as part of Cinnamon which is based on GTK3.

1 Like

yeah I am aware of gvfs I am not a newb here after all.
Still doesnt hurt to ask as since this is not a official spin of manjaro here

1 Like

I connect my phone now and then - it usually works as described earlier - so I don't know why you can't get it to work

1 Like

Well could have been easily a hiccup in my installer image as well, i have had that happen even after checking the md5 and all that junk.
I used etcher to write my USB and while its often very reliable it also might have been a factor.
I used etcher on windows too..... so maybe thats why?
Who knows

On the off chance that you have a OnePlus 3: MTP only works on Android P when enabled through the developer options. There is a bug that won't let you enable it normally.

No this is a samsung J3

You might need to add a custom udev rule for your phone.
In any case though, check that android-udev is installed.

I will consider that.
Again this could be something simple as a missing package, something not included in the cinnamon community edition of Manjaro.

Edit: AHA! Nope android-udev is not installed by default in the cinnamon community edition, i will install it and edit in if it solved my issue or not.

Double edit: that seemed to (mostly) work
But now i get a pop up that says:

Unable to open a folder for samsung android

No such interface "org.gtk.vfs,Mount" on object path /org/gtk/vfs/mount/1

But hey at least it (mostly) works now!

You might still have to add an udev rule though, see here for an example: Better Android device detection
gvfs-mtp must be installed.

Gvfs-mtp is indeed installed

I can confirm that file transfer between a Nexus 6P - Android 8.1.0 - is not borked in any way.

Connecting via USB - change connection status on phone to file transfer and Nemo opens with access to the phones internal storage - just double click folder and everything's there.

I cannot say what your issue is - this is just the live ISO - works OOB - but in a few minutes I will check the installed version - then do a full update - and check again.

However - I expect the result to be the same.

  • Reboot - test - :white_check_mark:
  • Full update - test :white_check_mark:

Note: This is a bare metal test

1 Like

Might sound stupid, but also make sure your phone is indeed in "file transfer" mode and unlocked.

Trust me if it was that issue I would not be making this topic as obviously..... I already thought of that :smiley:
I mean it could be an issue with this phone but the phone seemed to work fine on other distros.

If you have not found a solution - maybe I have :slight_smile:

I was going over the the possible packages which could be causing your issue.

If you have the package mtpfs installed in parallel with gvfs-mtp - it may create a non working mtp://phone_name/ folder.

Try uninstalling the package

sudo pacman -R mtpfs

And connect your phone.

2 Likes

Forum kindly sponsored by