MSM and ICU

#8

I’m updating now on a VM of plasma… will try to reboot… and build MSM

it will take some times… connection pretty slow… and will have a meeting… :wink:

EDIT: reboot… black screen… :thinking: wondering if it comes from plasma workspace or wt… as I don’t even have sddm.

0 Likes

#9

I confirm this on gnome unstable

error: failed to prepare transaction (could not satisfy dependencies)
:: installing icu (63.1-2) breaks dependency 'icu<63.0' required by manjaro-settings-manager
0 Likes

#10

I confirm that ICU break something with plasma…
with ICU 63.1 sddm doesn’t show up… trying to inverstigate

0 Likes

#11

I have cloned MSM and using the test PKGBUILD in the source folder the build fails with

-- Build files have been written to: /home/fh/Data/projects/manjaro-project/manjaro-settings-manager/build
[  0%] Automatic MOC for target msm_kernel_authhelper
[  1%] Generating org.manjaro.msm.keyboard.policy
[  1%] Automatic MOC for target msm
[  1%] Generating org.manjaro.msm.kernel.policy
/usr/lib/kauth/kauth-policy-gen: error while loading shared libraries: libicui18n.so.62: cannot open shared object file: No such file or directory
make[2]: *** [src/modules/keyboard/CMakeFiles/org.manjaro.msm.keyboard.policy-customtarget.dir/build.make:62: src/modules/keyboard/org.manjaro.msm.keyboard.policy] Error 127
make[1]: *** [CMakeFiles/Makefile2:1020: src/modules/keyboard/CMakeFiles/org.manjaro.msm.keyboard.policy-customtarget.dir/all] Error 2
make[1]: *** Waiting for unfinished job....
/usr/lib/kauth/kauth-policy-gen: error while loading shared libraries: libicui18n.so.62: cannot open shared object file: No such file or directory
make[2]: *** [src/modules/kernel/CMakeFiles/org.manjaro.msm.kernel.policy-customtarget.dir/build.make:62: src/modules/kernel/org.manjaro.msm.kernel.policy] Error 127
make[1]: *** [CMakeFiles/Makefile2:747: src/modules/kernel/CMakeFiles/org.manjaro.msm.kernel.policy-customtarget.dir/all] Error 2
[  1%] Built target msm_kernel_authhelper_autogen
[  1%] Built target msm_autogen
make: *** [Makefile:141: all] Error 2

I looks like the kauth-policy-gen component of KDE is hardcoded to expect icu 62.

0 Likes

#12

I confirm:

in my logs (I can’t copy past as I’m in TTY in VM)

sddm: error while loading shared libraries: libucu18n.so.62 connot etc etc..

love the “not a bug” here
https://bugs.archlinux.org/task/60637
if someone could explain where is really the problem :thinking:

seems it’s libQt5Core that still want old icu… then I guess Qt5base need a rebuild

on arch it’s qt5-base 5.11.2-2 (build on 22th)
icu 63.1 / poppler 0.70.0 rebuild
on my machine it’s qt5-base 5.11.2-2.1
seems we have a version from @philm buit on 27th (without the new ICU I guess)

0 Likes

#13
  • So sddm is not linked to icu.

It appears that setting the locale to en_US.UTF-8 solves the issue?

kauth-policy-gen seems to be linked to icu.

0 Likes

#14

I’m not investigating MSM right now… as I can’t start SDDM with the new ICU.

@linux-aarhus and your error is certainly related about to qt5-base package…

0 Likes

#15

I have downloaded and installed the qt5-base from Arch and I am in the process of building msm - which no longer fails and is installable, and runable with no errors.

But bear in mind - I am on Openbox - which might affect the outcome.

So it seems there must be a specific manjaro issue which needs solving as @philm is holding the Arch package back.

1 Like

#16

Will try to “downgrade” with the arch package to see if i see any side effect…
And will try to see why philm rebuild it if it’s somewhere on gitlab maybe there was error’s when he tried to rebuild msm as it was around the same time if I’m not wrong

EDIT: I lost the transluancy when moving window… but I’m not sure it’s related… i’m on VM and I had some problems… maybe it’s plasma-desktop

0 Likes

#17

XFCE and LightDM…

Removing MSM allowed update to be installed normally, but I think I can also confirm the qt5-base problem.

I run radeon-profile-git from the AUR, and it depends on qt5-base. After the update, I also get:

radeon-profile: error while loading shared libraries: libicui18n.so.62: cannot open shared object file: No such file or directory

As an aside, my locale is already en_US.UTF-8

ETA: reboot after upgrade with no problems, other than above.

0 Likes

#18

Has anybody tried the old trick to create a symlink to the new version, using the expected lib filename?

0 Likes

#19

https://wiki.manjaro.org/System_Maintenance

If a partial upgrade scenario has been created, and binaries are broken because they cannot find the libraries they are linked against, do not “fix” the problem simply by symlinking. Libraries receive soname bumps when they are not backwards compatible.

2 Likes

#20

I meant for troubleshooting only. Try, not use. :sweat_smile:

2 Likes

#21

I gave it a shot. Just started cascading…

radeon-profile: error while loading shared libraries: libicuuc.so.62: cannot open shared object file: No such file or directory

:slight_smile:

0 Likes

#22

seems to install qt5base 5.11.2-2 from arch solve the problem until phil rebuild it.
I don’t know what exactly the purpose of the patch phil include

I don’t see any direct side effect on plasma with the arch package

1 Like

#23

Fix dos’nt work for me on Xfce.

Zusammenfassung
Kann Abhängigkeiten nicht erfüllen:
nicht vorhandene Abhängigkeit 'icu<63.0' benötigt von manjaro-settings-manager

But there’s no hurry, I’ll re-install my backup if necessary. :slight_smile:

grafik

#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
CacheDir = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg      = pacman glibc manjaro-system
# If upgrades are available for these packages they will be asked for first
SyncFirst    = manjaro-system archlinux-keyring manjaro-keyring
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

IgnorePkg   = qt5-base
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
UseSyslog
Color
TotalDownload
# We cannot check disk space from within a chroot environment
CheckSpace
VerbosePkgLists

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Manjaro Linux
# packagers with `pacman-key --populate archlinux manjaro`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

[core]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[extra]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[community]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

[multilib]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist
0 Likes

#24

you need to put the qt5-base on ignore… otherwise it will be updated with the manjaro package that has 2.1 version.

and it does not solve the MSM confilct issue… only the breaking of plasma and some other QT apps with ICU 63.1 installed.

better to wait new version of qt5-base and MSM before updating if you’re not in hurry… :wink:

2 Likes

#25
Zusammenfassung
IgnorePkg   = qt5-base

Ahh, thank you, then we have to wait (a little :wink: )

0 Likes

#26

Got the updated qt5-base installed. Re-installed MSM. All is good with the world again. :sunny:

0 Likes

closed #27
0 Likes