MPV (SMPlayer), Nvidia, VC1 video codec, hardware acceleration - green screen is displayed instead of video

Any ideas on what to do about this (other than disabling hardware acceleration completely)?
GTX 970

you need ffmpeg & nvidia-utils & drivers nvidia

All this software is already installed.

Then transcode the video from VC1 to H264 using ffmpeg:

ffmpeg -i  input.mkv -map_metadata -1 -c:v libx264 -c:a libmp3lame -b:a 384K output.mkv

where input.mkv and output.mkv are the names of the input and output video…

:man_shrugging:

Worst Solution Possible :slightly_smiling_face:

The worst possible solution would be: Don’t watch that video! :stuck_out_tongue_winking_eye: :crazy_face:

No really: it could be a damaged download and ffmpeg can correct some errors that SMPlayer cannot… Have a try and feed back, please (I do this regularly).

:man_shrugging:

If disable hardware acceleration or use another player, the video will play normally.