Mpv not working well with vulkan api on gnome wayland after update

The ones in compute folder are exclusively for opengl if I’m not mistaken?

If you are trying to use vulkan as a backend and rgba16hf, I think you should stick to the shaders from the vulkan directory exclusively.

no, insude the vulkan folder there are compute and gather folders too, the only thing not available for vulkan is nnedi3.


All right then, but again:

Shaders in gather/ directory and compute/ directory are generally faster but requires recent version of OpenGL. Use these shaders only if they actually work (i.e. no blue screen and no noticeable distortion).

It’s you call, but I would still at least try the ones inside vulkan but outside those folders.

I have opengl 4.6 thats recent right? and like I said I just tried those 18 min ago (yep literally). I have to go now my teacher is literally throwing me out of the classroom so see you tomorow. Oh and it’s not just ravu, with profile=gpu-hq happens too. Bye

1 Like

Yeah it’s quite recent, but still, you know, some drivers from some vendors are worst than others, that something works in some configurations doesn’t mean it work as good in others, bugs exist, your hardware is quite old and not powerful, these shaders are done with powerful dedicated GPUs in mind…

I know, and the thing is that if it never worked then I would never asked for it, but it worked till I updated the system, the only thing I can think is to take the old iso and rip the vulkan-intel and mesa package and see if it works.

There you should have any old packages you might want. I wouldn’t go with a partially updated system just for this small thing myself, but whatever.

You could also try the opposite and see if newer git packages in the AUR solve the issue.

thanks, I will try the old version and if not work well opengl will be my video api, I dont want to compile from aur any core system package cuz the last time I did it for beignet to work it toke me 9h to compile llvm9, 5h clang9 and 20 min beignet it self, I dont wanna even imagine how much it will take to compile mesa or the vulkan driver.

ok I just installed vulkan-intel-20.2.1-2-x86_64.pkg.tar.zst (I have not rebooted) the system is still running and… it works!! thanks for your support. I just wish tomorrow I wont have to post another thread saying “my system not working for me downgrading intel vulkan drivers” XD.

1 Like

rebooted cuz lutris wasn’t launching and… now it does the system is still running (although now is the shaders the ones that flickers XD, but thats the “normal” behavior that had before and I am not recently playing as much as before so is not a big deal, I am sure that with an even older version it would fix it but for now this is how it stays, and if I copy a game well I will just update XD)

after a long time I have finally found the solution export ANV_QUEUE_THREAD_DISABLE=1 , this fixes the mpv vulkan issues and also fixes some vk error device lost on intel gpus.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.