Mpv drops frame A LOT

Hello there,
I’m using a nvidia/intel laptop and i use mpv a lot for my personal usage
Since the laptop is new, i’m experiencing a super weird issue
No matter what gpu acceleration method i use (even with no gpu acceleration at all), it just drops frame, especially if I pause the video and play it after a few seconds
It’s very weird and I haven’t found any solutions so far (screenshot included)

System info:

  Kernel: 5.17.15-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.17-x86_64
    root=UUID=15d30e75-a107-45c5-88ca-c53c47c61d7c rw rootflags=subvol=@ quiet
    apparmor=1 security=apparmor
    resume=UUID=59badd34-1362-4047-814d-ef3bee046382 udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82K1 v: IdeaPad Gaming 3 15IHU6
    serial: <superuser required> Chassis: type: 10 v: IdeaPad Gaming 3 15IHU6
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: No DPK serial: <superuser required>
    UEFI: LENOVO v: H4CN22WW(V1.07) date: 11/18/2021
  ID-1: BAT1 charge: 45.7 Wh (99.6%) condition: 45.9/45.0 Wh (102.1%)
    volts: 13.2 min: 11.5 model: SMP L20M3PC2 type: Li-ion serial: <filter>
    status: charging
  Device-1: hidpp_battery_0
    model: Logitech G304 Lightspeed Wireless Gaming Mouse serial: <filter>
    charge: 100% (should be ignored) rechargeable: yes status: discharging
  RAM: total: 15.41 GiB used: 2.76 GiB (17.9%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 11th Gen Intel Core i5-11300H bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 built: 2020 process: Intel 10nm family: 6
    model-id: 0x8C (140) stepping: 1 microcode: 0xA4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB L3: 8 MiB
    desc: 1x8 MiB
  Speed (MHz): avg: 1034 high: 1208 min/max: 400/4400 scaling:
    driver: intel_pstate governor: powersave cores: 1: 845 2: 950 3: 919 4: 1152
    5: 1208 6: 1094 7: 1101 8: 1009 bogomips: 49784
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
    avx512_vnni avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd
    avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2
    cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16
    cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp
    hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
    movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed
    rdt_a rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect ss ssbd
    sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
    tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi
    vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo
    driver: i915 v: kernel arch: Gen12.1 process: Intel 10nm built: 2020-21
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:9a49 class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: Lenovo
    driver: nvidia v: 515.57 non-free: 515.xx+ status: current (as of 2022-06)
    arch: Ampere process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 3
    speed: 8 GT/s lanes: 4 link-max: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 02:00.0 chip-ID: 10de:25a2 class-ID: 0302
  Device-3: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 1-6:4
    chip-ID: 5986:212b class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: kwin_x11 driver: X: loaded: modesetting gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x0a81 built: 2021 res: 1920x1080
    hz: 120 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.1.2
    direct render: Yes
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3 chip-ID: 8086:a0c8
    class-ID: 0401
  Sound Server-1: ALSA v: k5.17.15-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.52 running: yes
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-10:7 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.14 TiB used: 394.48 GiB (33.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZALQ256HBJD-00BL2 size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 5L2QFXM7 temp: 32.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: LFM4 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 91.98 GiB size: 91.98 GiB (100.00%)
    used: 25.78 GiB (28.0%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
    label: N/A uuid: 15d30e75-a107-45c5-88ca-c53c47c61d7c
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 612 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p5 maj-min: 259:5
    label: NO_LABEL uuid: 8B6B-957E
  ID-3: /home raw-size: 91.98 GiB size: 91.98 GiB (100.00%)
    used: 25.78 GiB (28.0%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
    label: N/A uuid: 15d30e75-a107-45c5-88ca-c53c47c61d7c
  ID-4: /run/media/mtn/Lin raw-size: 456.5 GiB size: 456.48 GiB (100.00%)
    used: 232.66 GiB (51.0%) fs: exfat dev: /dev/sda3 maj-min: 8:3 label: Lin
    uuid: 6EFF-FD15
  ID-5: /run/media/mtn/Win raw-size: 475 GiB size: 475 GiB (100.00%)
    used: 77.83 GiB (16.4%) fs: ntfs dev: /dev/sda2 maj-min: 8:2 label: Win
    uuid: BA60F0D860F09C77
  ID-6: /run/media/mtn/Windows raw-size: 125.42 GiB
    size: 125.42 GiB (100.00%) used: 58.22 GiB (46.4%) fs: ntfs
    dev: /dev/nvme0n1p3 maj-min: 259:3 label: Windows uuid: D290253790252387
  ID-7: /var/cache raw-size: 91.98 GiB size: 91.98 GiB (100.00%)
    used: 25.78 GiB (28.0%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
    label: N/A uuid: 15d30e75-a107-45c5-88ca-c53c47c61d7c
  ID-8: /var/log raw-size: 91.98 GiB size: 91.98 GiB (100.00%)
    used: 25.78 GiB (28.0%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
    label: N/A uuid: 15d30e75-a107-45c5-88ca-c53c47c61d7c
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 20 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p6 maj-min: 259:6 label: N/A
    uuid: 59badd34-1362-4047-814d-ef3bee046382
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 100 MiB fs: vfat label: N/A
    uuid: 2C1C-C34A
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 478 MiB fs: ntfs label: N/A
    uuid: 1A6026186025FB61
  ID-4: /dev/sda1 maj-min: 8:1 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:2 info: Logitech USB Receiver type: Keyboard,Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c53f class-ID: 0300
  Device-2: 1-2:3 info: Megawin Defender Gaming Keyboard type: Keyboard
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 0e6a:02c0 class-ID: 0301
  Device-3: 1-6:4 info: Acer Integrated Camera type: Video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 5986:212b
    class-ID: 0e02
  Device-4: 1-7:5 info: Integrated Express ITE Device(8295)
    type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0
    speed: 12 Mb/s power: 100mA chip-ID: 048d:c963 class-ID: 0300
  Device-5: 1-8:6 info: Integrated Express ITE Device(8176) type: Keyboard
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 048d:c966 class-ID: 0301
  Device-6: 1-10:7 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 38.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 304 Uptime: 57m wakeups: 8 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1
  Packages: 1303 pacman: 1287 lib: 340 flatpak: 16 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.19

Not sure if actually similar, but for some time i had a stuttering issue, that i fixed by manually increasing the demuxer buffer.
Alternatively, have you tried low latency playback?

mpv --hwdec=auto 4.mp4 ?

Nope nothing changed. The output:

Can't load unknown script: /home/mtn/.config/mpv/scripts/
 (+) Video --vid=1 (*) (h264 1920x1080 29.970fps)
 (+) Audio --aid=1 (*) (aac 2ch 44100Hz)
[ffmpeg] AVHWDeviceContext: Failed to query surface attributes: 20 (the requested function is not implemented).
[vo/gpu/vaapi-egl] failed to retrieve libavutil frame constraints
Using hardware decoding (vaapi).
AO: [pulse] 44100Hz stereo 2ch float
VO: [gpu] 1920x1080 vaapi[nv12]
AV: 00:01:45 / 00:07:25 (24%) A-V: -0.000
[ffmpeg/video] h264: mmco: unref short failure
(Paused) AV: 00:06:32 / 00:07:25 (88%) A-V:  0.000 Dropped: 39

It got worse actually

Can't load unknown script: /home/mtn/.config/mpv/scripts/
 (+) Video --vid=1 (*) (h264 1920x1080 29.970fps)
 (+) Audio --aid=1 (*) (aac 2ch 44100Hz)
AO: [pulse] 44100Hz stereo 2ch float
VO: [gpu] 1920x1080 yuv420p
(Paused) AV: 00:01:39 / 00:07:25 (22%) A-V:  0.000
[ffmpeg/video] h264: mmco: unref short failure
(Paused) AV: 00:05:09 / 00:07:25 (70%) A-V:  0.000
[ffmpeg/video] h264: mmco: unref short failure
[ffmpeg/video] h264: mmco: unref short failure
AV: 00:06:31 / 00:07:25 (88%) A-V:  0.000 Dropped: 42

But i’ve discovered something. If the charger is plugged to the laptop, the dropped frames reach 7 instead of 37 or something. If there’s something wrong with laptop power management, then why vlc doesn’t have any issues?

adjust your powersettings

There is likely nothing wrong - as in failure etc - it is a matter of configuration. Precisely what configuration - is for you to experiment on.

Perhaps VLC coders are smarter than mpv coders? Or the VLC code actively monitors the powersettings and adjust accordingly?

It makes sense in some way
I use tlp for power management and it’s all the configs:

--- TLP 1.5.0 --------------------------------------------

+++ Configured Settings:
defaults.conf L0004: TLP_ENABLE="1"
defaults.conf L0005: TLP_WARN_LEVEL="3"
defaults.conf L0006: TLP_PERSISTENT_DEFAULT="0"
defaults.conf L0007: DISK_IDLE_SECS_ON_AC="0"
defaults.conf L0008: DISK_IDLE_SECS_ON_BAT="2"
defaults.conf L0009: MAX_LOST_WORK_SECS_ON_AC="15"
defaults.conf L0010: MAX_LOST_WORK_SECS_ON_BAT="60"
defaults.conf L0011: CPU_ENERGY_PERF_POLICY_ON_AC="balance_performance"
defaults.conf L0012: CPU_ENERGY_PERF_POLICY_ON_BAT="balance_power"
defaults.conf L0013: SCHED_POWERSAVE_ON_AC="0"
/etc/tlp.conf L0153: SCHED_POWERSAVE_ON_BAT="1"
defaults.conf L0015: NMI_WATCHDOG="0"
defaults.conf L0016: DISK_DEVICES="nvme0n1 sda"
defaults.conf L0017: DISK_APM_LEVEL_ON_AC="254 254"
defaults.conf L0018: DISK_APM_LEVEL_ON_BAT="128 128"
defaults.conf L0019: DISK_APM_CLASS_DENYLIST="usb ieee1394"
defaults.conf L0020: DISK_IOSCHED="keep keep"
defaults.conf L0021: SATA_LINKPWR_ON_AC="med_power_with_dipm max_performance"
defaults.conf L0022: SATA_LINKPWR_ON_BAT="med_power_with_dipm min_power"
defaults.conf L0023: AHCI_RUNTIME_PM_ON_AC="on"
defaults.conf L0024: AHCI_RUNTIME_PM_ON_BAT="auto"
defaults.conf L0025: AHCI_RUNTIME_PM_TIMEOUT="15"
defaults.conf L0026: PCIE_ASPM_ON_AC="default"
defaults.conf L0027: PCIE_ASPM_ON_BAT="default"
defaults.conf L0028: RADEON_DPM_PERF_LEVEL_ON_AC="auto"
defaults.conf L0029: RADEON_DPM_PERF_LEVEL_ON_BAT="auto"
defaults.conf L0030: RADEON_POWER_PROFILE_ON_AC="default"
defaults.conf L0031: RADEON_POWER_PROFILE_ON_BAT="default"
defaults.conf L0032: WIFI_PWR_ON_AC="off"
defaults.conf L0033: WIFI_PWR_ON_BAT="on"
defaults.conf L0034: WOL_DISABLE="Y"
defaults.conf L0035: SOUND_POWER_SAVE_ON_AC="1"
defaults.conf L0036: SOUND_POWER_SAVE_ON_BAT="1"
defaults.conf L0037: SOUND_POWER_SAVE_CONTROLLER="Y"
defaults.conf L0038: BAY_POWEROFF_ON_AC="0"
defaults.conf L0039: BAY_POWEROFF_ON_BAT="0"
defaults.conf L0040: BAY_DEVICE="sr0"
defaults.conf L0041: RUNTIME_PM_ON_AC="on"
defaults.conf L0042: RUNTIME_PM_ON_BAT="auto"
defaults.conf L0043: RUNTIME_PM_DRIVER_DENYLIST="mei_me nouveau radeon"
defaults.conf L0044: USB_AUTOSUSPEND="1"
defaults.conf L0045: USB_EXCLUDE_AUDIO="1"
defaults.conf L0046: USB_EXCLUDE_BTUSB="0"
defaults.conf L0047: USB_EXCLUDE_PHONE="0"
defaults.conf L0048: USB_EXCLUDE_PRINTER="1"
defaults.conf L0049: USB_EXCLUDE_WWAN="0"
defaults.conf L0051: RESTORE_DEVICE_STATE_ON_STARTUP="0"
defaults.conf L0052: RESTORE_THRESHOLDS_ON_BAT="0"
defaults.conf L0053: NATACPI_ENABLE="1"
defaults.conf L0054: TPACPI_ENABLE="1"
defaults.conf L0055: TPSMAPI_ENABLE="1"

+++ System Info
System         = LENOVO IdeaPad Gaming 3 15IHU6 82K1
BIOS           = H4CN22WW(V1.07)
OS Release     = Manjaro Linux
Kernel         = 5.15.50-1-MANJARO #1 SMP PREEMPT Sun Jun 26 07:06:30 UTC 2022 x86_64
/proc/cmdline  = BOOT_IMAGE=/@/boot/vmlinuz-5.15-x86_64 root=UUID=15d30e75-a107-45c5-88ca-c53c47c61d7c rw rootflags=subvol=@ quiet apparmor=1 security=apparmor resume=UUID=59badd34-1362-4047-814d-ef3bee046382 udev.log_priority=3
Init system    = systemd 
Boot mode      = UEFI

+++ TLP Status
State          = enabled
RDW state      = enabled
Last run       = 12:44:48,    938 sec(s) ago
Mode           = AC
Power source   = AC

Error: conflicting power-profiles-daemon.service is enabled, power saving will not apply on boot.
>>> Invoke 'systemctl mask power-profiles-daemon.service' to correct this!

+++ Processor
CPU model      = 11th Gen Intel(R) Core(TM) i5-11300H @ 3.10GHz

/sys/devices/system/cpu/cpu0/cpufreq/scaling_driver    = intel_pstate
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor  = powersave
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors = performance powersave
/sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq  =   400000 [kHz]
/sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq  =  4400000 [kHz]
/sys/devices/system/cpu/cpu0/cpufreq/energy_performance_preference = balance_performance [HWP.EPP]
/sys/devices/system/cpu/cpu0/cpufreq/energy_performance_available_preferences = default performance balance_performance balance_power power 

/sys/devices/system/cpu/cpu1..cpu7: omitted for clarity, use -v to show all

/sys/devices/system/cpu/intel_pstate/status            = active
/sys/devices/system/cpu/intel_pstate/min_perf_pct      =   9 [%]
/sys/devices/system/cpu/intel_pstate/max_perf_pct      = 100 [%]
/sys/devices/system/cpu/intel_pstate/no_turbo          =   0
/sys/devices/system/cpu/intel_pstate/hwp_dynamic_boost =   0
/sys/devices/system/cpu/intel_pstate/turbo_pct         =  33 [%]
/sys/devices/system/cpu/intel_pstate/num_pstates       =  41

/sys/module/workqueue/parameters/power_efficient       = Y
/proc/sys/kernel/nmi_watchdog                          = 0

+++ Platform Profile
/sys/firmware/acpi/platform_profile                    = (not available)
/sys/firmware/acpi/platform_profile_choices            = (not available)

+++ Temperatures
CPU temp               =    38 [°C]
Fan speed              = (not available)

+++ File System
/proc/sys/vm/laptop_mode               =     0
/proc/sys/vm/dirty_writeback_centisecs =  1500
/proc/sys/vm/dirty_expire_centisecs    =  1500
/proc/sys/vm/dirty_ratio               =    20
/proc/sys/vm/dirty_background_ratio    =    10

+++ Disks
Devices = nvme0n1 sda

  Type       = NVMe
  Disk ID    = nvme-SAMSUNG_MZALQ256HBJD-00BL2_S65FNX0RC16249
  Model      = SAMSUNG MZALQ256HBJD-00BL2              
  Firmware   = 5L2QFXM7
  Temp       = 31 °C
  Scheduler  = [none] mq-deadline kyber bfq (multi queue)

  Runtime PM:
    /sys/block/nvme0n1/device/power/control = on, autosuspend_delay_ms = (not available)

  SMART info:
    Critical Warning:                   0x00
    Temperature:                        31 Celsius
    Available Spare:                    100%
    Available Spare Threshold:          10%
    Percentage Used:                    0%
    Data Units Written:                 938,711 [480 GB]
    Power Cycles:                       58
    Power On Hours:                     19
    Unsafe Shutdowns:                   12
    Media and Data Integrity Errors:    0

  Type       = SATA
  Disk ID    = ata-ST1000LM035-1RK172_WKPSVLY5
  Model      = ST1000LM035-1RK172                      
  Firmware   = LFM4    
  APM Level  = 254
  Status     = active/idle
  Host       = host0
  Scheduler  = [mq-deadline] kyber bfq none (multi queue)

  Runtime PM:
    /sys/block/sda/device/power/control = on, autosuspend_delay_ms = 15000

  SMART info:
      4 Start_Stop_Count          =      401 
      5 Reallocated_Sector_Ct     =        0 
      9 Power_On_Hours            =       98 [h]
     12 Power_Cycle_Count         =       63 
    190 Airflow_Temperature_Cel   =       39 [°C]
    191 G-Sense_Error_Rate        =        0 
    193 Load_Cycle_Count          =     1677 
    194 Temperature_Celsius       =       39 (0 22 0 [°C]

+++ AHCI Link Power Management (ALPM) :: SATA Links
/sys/bus/pci/devices/0000:00:17.0/ata1/host0/scsi_host/host0/link_power_management_policy = med_power_with_dipm  -- sda

+++ AHCI Port Runtime Power Management :: SATA/ATA Ports
/sys/bus/pci/devices/0000:00:17.0/ata1/power/control     = on  -- sda

+++ Intel Graphics
/sys/class/drm/card0/device/driver           = i915

/sys/class/drm/card0/power/rc6_enable        =  1 (enabled)
/sys/kernel/debug/dri/0/i915_fbc_status      = FBC enabled
/sys/module/i915/parameters/enable_psr       = -1 (use per-chip default)

/sys/class/drm/card0/gt_min_freq_mhz         =   100 [MHz]
/sys/class/drm/card0/gt_max_freq_mhz         =  1300 [MHz]
/sys/class/drm/card0/gt_boost_freq_mhz       =  1300 [MHz]
/sys/class/drm/card0/gt_RPn_freq_mhz         =   100 [MHz] (GPU min)
/sys/class/drm/card0/gt_RP0_freq_mhz         =  1300 [MHz] (GPU max)

+++ Wireless
bluetooth = off (software)
nfc       = none (no device)
wifi      = on
wwan      = none (no device)

hci0(btusb)                   : bluetooth, not connected
wlp0s20f3(iwlwifi)            : wifi, connected, power management = off

+++ Audio
/sys/module/snd_hda_intel/parameters/power_save            = 1
/sys/module/snd_hda_intel/parameters/power_save_controller = Y

+++ PCIe Active State Power Management
/sys/module/pcie_aspm/parameters/policy = [default] performance powersave powersupersave

+++ PCIe Runtime Power Management
Enable devices    = (disabled)
Disable devices   = (disabled)
Device denylist   = (disabled)
Driver denylist   = mei_me nouveau radeon

/sys/bus/pci/devices/0000:00:00.0/power/control = on   (0x060000, Host bridge, no driver)
/sys/bus/pci/devices/0000:00:02.0/power/control = on   (0x030000, VGA compatible controller, i915)
/sys/bus/pci/devices/0000:00:04.0/power/control = on   (0x118000, Signal processing controller, proc_thermal)
/sys/bus/pci/devices/0000:00:06.0/power/control = on   (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:08.0/power/control = on   (0x088000, System peripheral, no driver)
/sys/bus/pci/devices/0000:00:0a.0/power/control = on   (0x118000, Signal processing controller, intel-pmt)
/sys/bus/pci/devices/0000:00:14.0/power/control = on   (0x0c0330, USB controller, xhci_hcd)
/sys/bus/pci/devices/0000:00:14.2/power/control = on   (0x050000, RAM memory, no driver)
/sys/bus/pci/devices/0000:00:14.3/power/control = on   (0x028000, Network controller, iwlwifi)
/sys/bus/pci/devices/0000:00:15.0/power/control = on   (0x0c8000, Serial bus controller, intel-lpss)
/sys/bus/pci/devices/0000:00:16.0/power/control = auto (0x078000, Communication controller, mei_me)
/sys/bus/pci/devices/0000:00:17.0/power/control = on   (0x010601, SATA controller, ahci)
/sys/bus/pci/devices/0000:00:1c.0/power/control = on   (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:1d.0/power/control = on   (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:1f.0/power/control = on   (0x060100, ISA bridge, no driver)
/sys/bus/pci/devices/0000:00:1f.3/power/control = on   (0x040100, Multimedia audio controller, sof-audio-pci-intel-tgl)
/sys/bus/pci/devices/0000:00:1f.4/power/control = on   (0x0c0500, SMBus, i801_smbus)
/sys/bus/pci/devices/0000:00:1f.5/power/control = on   (0x0c8000, Serial bus controller, intel-spi)
/sys/bus/pci/devices/0000:01:00.0/power/control = on   (0x010802, Non-Volatile memory controller, nvme)
/sys/bus/pci/devices/0000:02:00.0/power/control = on   (0x030200, 3D controller, nvidia)
/sys/bus/pci/devices/0000:03:00.0/power/control = on   (0x020000, Ethernet controller, r8169)

+++ USB
Autosuspend       = enabled
Device allowlist  = (not configured)
Device denylist   = (not configured)
Exclude audio     = enabled
Exclude bluetooth = disabled
Exclude phones    = disabled
Exclude printers  = enabled
Exclude WWAN      = disabled

Bus 002 Device 001 ID 1d6b:0003 control = auto, autosuspend_delay_ms =    0 -- Linux Foundation 3.0 root hub (hub)
Bus 001 Device 006 ID 048d:c966 control = on,   autosuspend_delay_ms = 2000 -- Integrated Technology Express, Inc. ITE Device(8176) (usbhid)
Bus 001 Device 005 ID 048d:c963 control = on,   autosuspend_delay_ms = 2000 -- Integrated Technology Express, Inc. ITE Device(8295) (usbhid)
Bus 001 Device 004 ID 5986:212b control = auto, autosuspend_delay_ms = 2000 -- Acer, Inc Integrated Camera (uvcvideo)
Bus 001 Device 003 ID 0e6a:02c0 control = on,   autosuspend_delay_ms = 2000 -- Megawin Technology Co., Ltd Defender Gaming Keyboard (usbhid)
Bus 001 Device 007 ID 8087:0026 control = auto, autosuspend_delay_ms = 2000 -- Intel Corp. AX201 Bluetooth (btusb)
Bus 001 Device 002 ID 046d:c53f control = on,   autosuspend_delay_ms = 2000 -- Logitech, Inc. USB Receiver (usbhid)
Bus 001 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =    0 -- Linux Foundation 2.0 root hub (hub)

+++ Battery Care
Plugin: lenovo
Supported features: charge threshold
Driver usage:
* vendor (ideapad_laptop) = active (charge threshold)
Parameter value range:
* STOP_CHARGE_THRESH_BAT0: 0(off), 1(on) -- battery conservation mode

/sys/bus/platform/drivers/ideapad_acpi/VPC2004:00/conservation_mode = 0 (100%)

+++ Battery Status: BAT1
/sys/class/power_supply/BAT1/manufacturer                   = SMP
/sys/class/power_supply/BAT1/model_name                     = L20M3PC2
/sys/class/power_supply/BAT1/cycle_count                    =      0 (or not supported)
/sys/class/power_supply/BAT1/energy_full_design             =  45000 [mWh]
/sys/class/power_supply/BAT1/energy_full                    =  45420 [mWh]
/sys/class/power_supply/BAT1/energy_now                     =  43270 [mWh]
/sys/class/power_supply/BAT1/power_now                      =  20139 [mW]
/sys/class/power_supply/BAT1/status                         = Charging

Charge                                                      =   95.3 [%]
Capacity                                                    =  100.9 [%]

@nanoone did you solve your issue? I’m having exactly the same problem, specially after pausing and playing after some time, it’s driving me crazy

I had the same problem with continuing after a pause.

This helped me

Of course using ALSA directly isn’t that comfortable. Since my system still uses pulse, I might try to switch to PipeWire, but I don’t know if that helps. The screensaver option did not helped on my system.


Thanks everyone
I solved the issue with the help of a nice person name outlaw-amir on Reddit
The fix is to install the flatpak version of mpv
That totally fixed the problem
But the question still remains: what’s wrong with the mpv in official repository?

Yes the solution is to install the flatpak version

I don’t think it is a mpv problem. It calls ffmpeg. Therefore ffmpeg must be newer on your system than the flatpak ffmpeg.

So downgrading ffmpeg could maybe solve it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.