MPD Not working Correctly.[Error-'MPD error: No database']

After I’m running “mpc update” command showing “MPD error: No database” error message.

The output of systemctl status mpd, which is running:

Apr 23 06:42:10 nimendra systemd[1]: Starting Music Player Daemon...
Apr 23 06:42:21 nimendra mpd[636]: Ignoring the 'pid_file' setting in systemd mode
Apr 23 06:42:21 nimendra mpd[636]: decoder: Decoder plugin 'wildmidi' is unavailable: configurati>
Apr 23 06:42:21 nimendra mpd[636]: config: Found database setting without music_directory - disab>
Apr 23 06:42:21 nimendra mpd[636]: output: No 'audio_output' defined in config file
Apr 23 06:42:22 nimendra mpd[636]: output: Successfully detected a alsa audio device
Apr 23 06:42:22 nimendra mpd[636]: zeroconf: No global port, disabling zeroconf
Apr 23 06:42:22 nimendra systemd[1]: Started Music Player Daemon.

My mpd.conf

db_file                         "~/.config/mpd/database"

log_file                        "syslog"

music_directory                 "/home/nimendra/Music"

playlist_directory              "~/.config/mpd/playlists"
pid_file                       "~/.config/share/mpd/pid"
state_file                      "~/.config/share/mpd/state"
sticker_file                    "~/.config/share/mpd/sticker.sql"

auto_update                     "yes"
auto_update_depth               "0"

bind_to_address                     ""
#bind_to_address		"~/.config/mpd/socket"
port                            "6600"

follow_inside_symlinks          "yes"

restore_paused                  "yes"

audio_output {
        type            "pulse"
        name            "pulse audio"

I found the same issue here. But solution not explained.

1 Like

Same problem, with manjaro ARM

  Kernel: 5.18.2-1-MANJARO-ARM-RPI aarch64 bits: 64 compiler: gcc v: 12.1.0
    parameters: coherent_pool=1M 8250.nr_uarts=0
    snd_bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1
    video=HDMI-A-1:3840x2160M@30 smsc95xx.macaddr=DC:A6:32:14:8F:C1
    vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000
    root=PARTUUID=1e7027b0-02 rw rootwait console=ttyS0,115200 console=tty3
    selinux=0 quiet splash plymouth.ignore-serial-consoles
    smsc95xx.turbo_mode=N dwc_otg.lpm_enable=0 kgdboc=ttyS0,115200
    usbhid.mousepoll=8 audit=0
  Console: pty pts/0 Distro: Manjaro ARM base: Arch Linux
  Type: ARM System: Raspberry Pi 4 Model B Rev 1.1 details: BCM2835
    rev: b03111 serial: <filter>
  Info: model: N/A variant: cortex-a72 bits: 64 type: MCP arch: ARMv8
    family: 8 model-id: 0 stepping: 3
  Topology: cpus: 1x cores: 4 smt: N/A cache: L1: 320 KiB
    desc: d-4x32 KiB; i-4x48 KiB L2: 1024 KiB desc: 1x1024 KiB
  Speed (MHz): avg: 600 min/max: 600/1500 scaling: driver: cpufreq-dt
    governor: schedutil cores: 1: 600 2: 600 3: 600 4: 600 bogomips: 432
  Features: Use -f option to see features
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 mitigation: __user pointer sanitization
  Type: spectre_v2 status: Vulnerable
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: bcm2711-hdmi0 driver: vc4_hdmi v: N/A bus-ID: N/A
    chip-ID: brcm:fef00700 class-ID: hdmi
  Device-2: bcm2711-hdmi1 driver: vc4_hdmi v: N/A bus-ID: N/A
    chip-ID: brcm:fef05700 class-ID: hdmi
  Device-3: bcm2711-vc5 driver: vc4_drm v: N/A bus-ID: N/A chip-ID: brcm:gpu
    class-ID: gpu
  Display: server: No display server data found. Headless machine?
    tty: 211x47
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: bcm2711-hdmi0 driver: vc4_hdmi bus-ID: N/A chip-ID: brcm:fef00700
    class-ID: hdmi
  Device-2: bcm2711-hdmi1 driver: vc4_hdmi bus-ID: N/A
    chip-ID: brcm:fef05700 class-ID: hdmi
  Device-3: bcm2835-audio driver: bcm2835_audio bus-ID: N/A
    chip-ID: brcm:bcm2835_audio class-ID: bcm2835_audio
  Sound Server-1: ALSA v: k5.18.2-1-MANJARO-ARM-RPI running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.0 running: no
  Sound Server-4: PipeWire v: 0.3.52 running: no
  Device-1: bcm2835-mmc driver: mmc_bcm2835 v: N/A port: N/A bus-ID: N/A
    chip-ID: brcm:fe300000 class-ID: mmcnr
  IF: wlan0 state: down mac: <filter>
  Device-2: bcm2711-genet-v5 driver: bcmgenet v: N/A port: N/A bus-ID: N/A
    chip-ID: brcm:fd580000 class-ID: ethernet
  IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: pl011 driver: uart_pl011 bus-ID: N/A chip-ID: arm:fe201000
    class-ID: serial
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: not found
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 946.35 GiB used: 369.8 GiB (39.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/mmcblk0 maj-min: 179:0 vendor: SanDisk model: SC16G
    size: 14.84 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> scheme: MBR
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Toshiba model: MQ01UBD100
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B type: HDD
    rpm: 5400 serial: <filter> scheme: MBR
  ID-1: / raw-size: 14.6 GiB size: 14.34 GiB (98.25%) used: 4.37 GiB (30.5%)
    fs: ext4 dev: /dev/mmcblk0p2 maj-min: 179:2
  ID-2: /boot raw-size: 213.6 MiB size: 213.4 MiB (99.89%)
    used: 54.4 MiB (25.5%) fs: vfat dev: /dev/mmcblk0p1 maj-min: 179:1
  Kernel: swappiness: 60 (default) cache-pressure: 80 (default 100)
  ID-1: swap-1 type: zram size: 2.71 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 60.4 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 157 Uptime: 0m Memory: 1.88 GiB used: 230.6 MiB (12.0%)
  gpu: 76 MiB Init: systemd v: 251 tool: systemctl Compilers: gcc: 12.1.0
  Packages: pacman: 483 lib: 141 Shell: Bash v: 5.1.16
  running-in: pty pts/0 (SSH) inxi: 3.3.11

1 Like

Some progress, Finally mpd working (Music Player Daemon 0.23.7).
no changes on /usr/lib/systemd/system/mpd.service.d/00-arch.conf

in my case run mpd service only in user mode:
clean or comment with # all the /etc/mpd.conf file

disable system wide mpd & mpd.socket services.

sudo systemctl disable mpd
sudo systemctl disable mpd.socket

add mpd to the groups: users, network and audio (i dont know if this is mandatory, but i did and work)

enable all services in user space:

systemctl --user enable mpd
systemctl --user enable mpd.socket

Finally create the configuration file and files for database, etc in user directory (pi in my case)


music_directory         "~/Media/Music"
playlist_directory              "~/.config/mpd/playlists"
db_file                 "~/.config/mpd/database"
log_file                        "~/.config/mpd/log"
pid_file                        "~/.config/mpd/pid"
state_file                      "~/.config/mpd/state"
sticker_file                    "~/.config/mpd/sticker.sql"

bind_to_address        "localhost"
port                            "6600"
auto_update     "yes"

audio_output {
        type            "alsa"
        name            "Raspotify"
        mixer_type      "software"

create the files:
touch ~/.config/mpd/database
touch ~/.config/mpd/state
etc (playlists is a directory no a file)

in my case works flawlessly on RPI4 w/Kernel: 5.18.2-1-MANJARO-ARM-RPI aarch64 bits.

Saludos :argentina: