Mouse stops working after a random amount of time

I installed manjaro a couple days ago and every time I turn on my computer my mouse will stop working after a random amount of time. My mouse is a logitech g pro. It can work wired or wireless. It doesn’t matter which I’m using but if I disconnect the mouse or the receiver at any point it wont work when I plug it back in either. Nothing I have found fixes it except restarting my computer. I have tried to find solutions online but most of them don’t seem to fit the issue I’m having. I also have manjaro on my laptop and this mouse works perfectly on it.

I have tried installing the xf86-input-synaptics drivers but it hasn’t seemed to make a difference and I reinstalled the os a few times while I was messing with some other stuff and the issue persisted every time. I also have tried to disable usb auto suspend, but I’m not sure if I did it correctly.

I would appreciate any help troubleshooting since I am new to Linux and I’m not really sure how to figure out whats wrong with it.


Look into tlp settings for the USB port you connect the mouse, and disable power saving. Maybe install tlpui so you have a GTK+ interface for it.


This fixed the mouse not working after unplugging it and plugging it back in but it still stops working after using it for a while. Still the only fix I have found is to restart the computer.

Something that might help is this:

Try a different kernel. Have a look at your settings, find kernel & see what is running & what is available.

Different hardware different issues???

I have 5.10.56-1 right now. I previously had KDE plasma and I upgraded the kernel to 5.13.8-1 when I was running that and I still had the issue but I guess I’ll try it again.

I tried another kernel and have had the same issue multiple times since upgrading.

I tried turning tlp off completely and it still happens.