Mouse sticking to bottom of dual screens that are vertical

Hey everyone, long time lurker first time poster here. I think I’ve actually found something that I have not been able to find a solution for.

So I have my dual monitors setup on top of each other and use a touch pad on my main PC and have run into this problem. Well annoyance really I think this is actually working as intended but when you go to move your cursor from the top screen to the bottom and vice-versa the cursor will “stick” to the border of the screen until the quick app bar appears. This only happens if its not in view so its a bit annoying when i’m working on something and want to move my cursor to another screen. So I was wondering if anyone knew if this could be turned off? I’m not sure where to go next, tried to search for this and honestly not sure what to search for haha.

So thought I would throw the question out there and see if anyone else has ran into this.

Hey might have found a solution for this. In dconf if you set org.gnome.shell.extensions.dash-to-dock autohide false it stops the dock from appearing when you mouse over it. Since I use gestures with my touch pad to bring this up this isn’t an issue with me but thought id throw it out there if anyone else needs an idea to resolve this.