Mouse shrinks from OS size once inside Brave browser

When my mouse cursor is move inside a browser, it shrinks to about 25%.
Even though I said Brave, it does so in Vivaldi & Firefox.
I fail to see a setting or way to modify the mouse for the browsers.
Gotta be something simple I’m missing.
It happens on other systems, so I know it isn’t specific to this one.
Thanks in advance.
Edit: Desktop is XFCE

While you didnt provide this inormation …
I am going to guess you are on KDE (QT desktop)… and all these browsers are GTK.
Skipping all other possible problems …
You probably just need to restart plasma and/or log out & in and/or reboot.

Should have put that. Will edit the first post for anyone else that may see it.

Well … I guess then its possible you are using something that is technically working for xfce and gtk2, but not gtk3 (all modern gtk things like gnome and browsers).
So … a restart didnt fix?
What cursor theme are you using, and how did you install/apply it ?

Using the Breeze theme from the included settings.
Cursor size set to 16.

I tried a DDG search and only found one other reference to this problem.
It was on Mint and referenced a line in .Xresourses
but I don’t see any such file in Manjaro.

I noticed the cursor shrinks inside other applications also, but just never noticed it before
since they were small in text also. For some reason I just didn’t notice it until I tried to solve this one.
For example Htop. If I place the cursor over the title bar, it remains large. Once I move down to
the data area, it shrinks down to the small size.

I reset the default theme on the cursor, but had the same results.
In Money Manager, the left panel shows the cursor large, but the right panel cursor small.

Partial resolution. After you suggesting the settings, I went back into the setting and began looking through them again.
Settings>Settings Editor>xsettings>CursorThemeSize
I tried different numbers. When I set it to 48, it matched the cursor I’d chosen before.
All applications I’ve tried except one show the large cursor now.
Inside MoneyManagerex, where the left panel showed the large cursor previously, it shows the small cursor anywhere within the app now.

If no one can suggest another resolution soon to cover the whole system, I’ll come back and mark it solved.

Thank you @cscs for your replies.

Edit: After changing the value, most apps show the cursor the correct size. After a restart the other apps show it correctly also. I set the value to 36 so the cursor and the text cursor both match the size of most items in a browser page.

Ah ok. That could make sense.
If you look into the theme folder
(~/.local/share/icons/THEME or /usr/share/icons/THEME)
You might find it only supports certain sizes.

I forgot that the newer cursor themes dont have nice folders like that once compiled.
But I can see that breeze seems to only support 24, 36, 48 px .

( 24px = 1x, 36px = 1.5x, 48px = 2x )

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.