Mouse giving output on button press AND release in Firefox only with XFCE

I will try to explain this the best as I can;

When using the right click in Firefox, it just opens the context menu. That's default behaviour.

When I do this, pressing right click opens the menu, and releasing right click gives another output where my mouse is (usually hovering on the "back" button inside the context menu or in the "Open link in a new tab" button).

So what happens is, in a single click I open the context menu AND "click" in one of its options at the same time, resulting in me going back a page by accident. I have used a lot of distros and never had this happen before; only in XFCE (which I've used in the past and this problem was present as well)

anyone?

it's not XFCE specific, I can recreate the same with KDE if I purposely hold the right button as you describe until something is highlighted and then release. However, what I typically do is right click rather than holding the button down and then select what I want so I've never considered this an issue but clearly it is for you.

My problem is that I don't need to hold the button down for this behaviour to happen, just clicking already does this and its so annoying

you may have a dodgy mouse then

Nope. No other application does this, and I have windows as dual boot and this does not happen there.

go to firefox page 'about:support'

click on 'Refresh Firefox' to clear any old user configuration that may be causing problem

Isnt it normal to use Left click to select? Or is that just personal preference?

If I understand correctly the issue you're having is because for some reason your mouse cursor appears on top of the right-click context menu. Normally it should appear above the context menu, without interfering with the buttons/actions of the menu.

If this is true, something that may work is to add margins to the context menu so that the cursor does not hover over it when you right-click.
I don't know if this is going to work for you since I can't reproduce your issue, but it's worth a try.

  1. Close Firefox and create a new folder called “chrome” in your Firefox profile directory (to find the profile directory select in the Menu Bar of Firefox Help > Troubleshooting Information > under Profile Directory click on Open Directory and then close Firefox).

  2. In the new “chrome” folder create a new file called “userChrome.css”.

  3. Open the “userChrome.css” file and copy/paste the following CSS rule in it:

    #contentAreaContextMenu {
        margin: 25px 0 0 15px;
    }
  1. Save the file, open Firefox and check the right-click menu.

This will add a top margin of 25px and a left margin of 15px to the context menu.

If the cursor appears still on top of the context menu, increase the values for the top (25px) and the left (15px) margin.

If this doesn't help at all simply delete the "chrome" folder you created in your Firefox profile directory.

I was having the same problem, and I resolved it by re-enabling the title bar. Is yours disabled?