Mounting smb share using fstab, getting "home" permission denied error


I have a linux machine/server with a smb file share setup in my home network, works great. However, I’m trying to automount that share in my manjaro kde plasma machine. I can access the share just fine through dolphin with no issues. BUT, when I try including an entry with the fstab to automount that share, it gives me the permission denied error with the “home” folder. I’ve tried several permutations but nothing has worked so far.

So, I have a folder created in my specific home folder called skydrive (full path would be /home/ray/skydrive). And I’m trying to mount my smb share on another machine to that folder on boot, but keep getting the “home” permission denied error.

Here is my fstab entry:

//10.x.x.xx/skydrive /home/ray/skydrive cifs username=ray,password=mypass,rw,uid=ray,gid=ray,vers=3.0 0 0
  • There are two forward slashes before ip, I just cant include because forum flags as links

  • my samba server has the share created with the access creds u=ray p=mypass also, its always been that way.

  • I have the latest fully updated manjaro kde plasma

1 Like

Have you tried with Smb4K? It’s practically a “must-have” for KDE if you plan on using SMB shares regularly.

You can manage multiple shares, choose whether or not to save the password/credentials, choose the location to mount, auto-mount and auto-unmount options, as well as choose from presets or use your own custom permissions.

smb4k is available from the official repositories and is officially part of KDE’s ecosystem.

1 Like

Remember it is network share so remember that client permissions on mountpoint may prevent you from writing to the share.

Also you need to ensure the network is ready - setting in mount options

:+1: Welcome to Manjaro! :+1:

Have you tried following the FHS standard and mounting the external media to… well… /media! :grin:

sudo mkdir /media/skydrive

and change your fstab line to:

//10.x.x.xx/skydrive /media/skydrive cifs username=ray,password=mypass,noauto,x-systemd.automount,x-systemd.device-timeout=10,rw

And if that wouldn’t solve your problem, use this one:

//10.x.x.xx/skydrive /media/skydrive cifs username=ray,password=mypass,noauto,x-systemd.automount,x-systemd.device-timeout=10,rw,file_mode=0755,dir_mode=0755


1 Like

Well, I went to try what yo suggested, but then discovered I didn’t have a media folder in root. That might explain why I didn’t try that before. I didn’t see a media folder to think about trying to mount it there.

Can you post an inxi --admin --verbosity=7 --filter --no-host --width because that means something else is terribly wrong!!!


Sure, the output is below. However, I created the media folder manually and then created my skydrive folder within that. I just randomly tried the last entry that you specified in my fstab file, and it seemed to work on reboot. However, I’m not sure it was actually related to the folder path and permissions anymore. The magic might have been in the rest of the parameters in the fstab entry that you specified. I’m not sure at this point, I haven’t played with it any more. However, I still have no idea why I didn’t have a media folder? Also, within Dolphin, it mounts the share and names it using the file path, so, in this instance, it appears at “media/skydrive”. Is there a way to give it a different label more user friendly label, such as “skydrive”?

  Kernel: 5.14.0-0-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64 
  root=UUID=9047fa2e-f16d-4513-9a10-2e9feb56bb85 rw quiet apparmor=1 
  security=apparmor resume=UUID=84e2a637-07d6-4692-ae83-653710380f52 
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop System: Hewlett-Packard product: HP Compaq Pro 6305 SFF v: N/A 
  serial: <filter> Chassis: type: 4 serial: <filter> 
  Mobo: Hewlett-Packard model: 1850 serial: <filter> UEFI: Hewlett-Packard 
  v: K06 v02.57 date: 08/16/2013 
  Message: No system battery data found. Is one present? 
  RAM: total: 14.85 GiB used: 1.17 GiB (7.8%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: AMD A8-5500B APU with Radeon HD Graphics bits: 64 
  type: MCP arch: Piledriver family: 15 (21) model-id: 10 (16) stepping: 1 
  microcode: 6001119 cache: L2: 2 MiB bogomips: 25562 
  Speed: 1402 MHz min/max: 1400/3200 MHz boost: enabled Core speeds (MHz): 
  1: 1402 2: 1919 3: 1397 4: 1397 
  Flags: 3dnowprefetch abm aes aperfmperf apic arat avx bmi1 clflush cmov 
  cmp_legacy constant_tsc cpb cpuid cr8_legacy cx16 cx8 de decodeassists 
  extapic extd_apicid f16c flushbyasid fma fma4 fpu fxsr fxsr_opt ht hw_pstate 
  ibs lahf_lm lbrv lm lwp mca mce misalignsse mmx mmxext monitor msr mtrr 
  nodeid_msr nonstop_tsc nopl npt nrip_save nx osvw pae pat pausefilter 
  pclmulqdq pdpe1gb perfctr_core perfctr_nb pfthreshold pge pni popcnt pse 
  pse36 rdtscp rep_good sep skinit ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 svm 
  svm_lock syscall tbm tce topoext tsc tsc_scale vmcb_clean vme vmmcall wdt 
  xop xsave 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Trinity [Radeon HD 7560D] vendor: Hewlett-Packard 
  driver: radeon v: kernel bus-ID: 00:01.0 chip-ID: 1002:9904 class-ID: 0300 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: ati,radeon unloaded: modesetting alternate: fbdev,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: DisplayPort-0 res: 1920x1080 hz: 60 dpi: 69 
  size: 708x398mm (27.9x15.7") diag: 812mm (32") 
  OpenGL: renderer: AMD ARUBA (DRM 2.50.0 / 5.14.0-0-MANJARO LLVM 12.0.1) 
  v: 4.3 Mesa 21.2.1 compat-v: 3.1 direct render: Yes 
  Device-1: AMD Trinity HDMI Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus-ID: 00:01.1 chip-ID: 1002:9902 
  class-ID: 0403 
  Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel 
  v: kernel bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403 
  Sound Server-1: ALSA v: k5.14.0-0-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.34 running: yes 
  Device-1: Broadcom NetXtreme BCM5761 Gigabit Ethernet PCIe 
  vendor: Hewlett-Packard driver: tg3 v: kernel port: f100 bus-ID: 03:00.0 
  chip-ID: 14e4:1681 class-ID: 0200 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB 
  driver: btusb v: 0.8 bus-ID: 8-1:2 chip-ID: 0a12:0001 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 689.33 GiB used: 17.6 GiB (2.6%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500DM002-1BD142 
  size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 7200 serial: <filter> rev: HP73 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37240G 
  size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 0100 scheme: GPT 
  Optical-1: /dev/sr0 vendor: hp model: DVD-RAM GHA3N rev: RH07 
  dev-links: cdrom 
  Features: speed: 40 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw-size: 206.87 GiB size: 202.62 GiB (97.95%) used: 17.6 GiB (8.7%) 
  fs: ext4 dev: /dev/sdb2 maj-min: 8:18 label: N/A 
  uuid: 9047fa2e-f16d-4513-9a10-2e9feb56bb85 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17 label: N/A 
  uuid: 3DDF-20B2 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 16.41 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sdb3 maj-min: 8:19 label: N/A 
  uuid: 84e2a637-07d6-4692-ae83-653710380f52 
  ID-1: /dev/sda1 maj-min: 8:1 size: 529 MiB fs: ntfs label: Recovery 
  uuid: 628419088418E079 
  ID-2: /dev/sda2 maj-min: 8:2 size: 100 MiB fs: vfat label: N/A 
  uuid: 281A-D10A 
  ID-3: /dev/sda3 maj-min: 8:3 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-4: /dev/sda4 maj-min: 8:4 size: 465.13 GiB fs: ntfs label: N/A 
  uuid: 1ADA1D9ADA1D736D 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 5 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 5 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 5 rev: 1.1 speed: 12 Mb/s 
  chip-ID: 1d6b:0001 class-ID: 0900 
  Device-1: 3-2:2 info: HP HP Business Slim Keyboard type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 1.5 Mb/s 
  power: 100mA chip-ID: 03f0:2f4a class-ID: 0300 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 5 rev: 1.1 speed: 12 Mb/s 
  chip-ID: 1d6b:0001 class-ID: 0900 
  Hub-5: 5-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s 
  chip-ID: 1d6b:0001 class-ID: 0900 
  Hub-6: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 6-1:2 info: Primax HP Optical Mouse type: Mouse 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s 
  power: 100mA chip-ID: 0461:4d0f class-ID: 0301 
  Hub-7: 7-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-8: 8-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 8-1:2 info: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) 
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 0a12:0001 class-ID: e001 
  Device-2: 8-2:3 info: Shenzhen Riitek wireless mini keyboard with touchpad 
  type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 1.1 
  speed: 12 Mb/s power: 100mA chip-ID: 1997:2433 class-ID: 0301 
  Hub-9: 9-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 4.2 C mobo: N/A gpu: radeon temp: 3.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 187 Uptime: 7h 53m wakeups: 0 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1374 lib: 414 
  flatpak: 0 Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

At you to create folder, for example: /mnt/skydrive

yes, /media/ not exists and shouldn’t exist, best is to create directory in /mnt/ or /run/media/ but you can also use a directory in home. or create symbolic links in home to directory /mnt/xxxx/

1 Like

I have to disagree with @papajoke on this one. I think it is a good practice to use /mnt for everything you mount manually in a terminal e.g. when chrooting and /media/xxx for permanent mounts of data and network resources in fstab. /run/media is used by system to mount things you access with GUI tools like when inserting a flash drive or clicking a partition in a file manager, so it should not be used for your manual mounts since they could have the same name as the inserted flash drive.

1 Like

for me /media is for removable media not for mount network : man
same with redhat :

There are two places where other file systems are commonly mounted: the /media/ directory for removable media, and the /mnt/ directory for temporarily mounted file systems.

Question : network is removable media ? :face_with_raised_eyebrow:

yes /run/media is not for fstab and udisk can also use /media

if he want, user can mount also in home :wink:

Yeah, /media is not the best name for custom mounts anyway, it also is used for automounts on some distros as Ubuntu if I remember correctly. However, on Manjaro it’s quite safe to use it. Nothing forbids setting another directory as well.

It’s more of removable than the opposite. Imagine plugging your cable off :wink:
And changing Wi-Fi network works kind of the same.

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

Screenshot, please? Because you can create a “Place” for it and then that should just work.

@papajoke @openminded

From the FSH:

/media : Mount point for removable media


This directory contains subdirectories which are used as mount points for removable media such as floppy disks, cdroms and zip disks.


Historically there have been a number of other different places used to mount removable media such as /cdrom, /mnt or /mnt/cdrom. Placing the mount points for all removable media directly in the root directory would potentially result in a large number of extra directories in /. Although the use of subdirectories in /mnt as a mount point has recently been common, it conflicts with a much older tradition of using /mnt directly as a temporary mount point.

/mnt : Mount point for a temporarily mounted filesystem


This directory is provided so that the system administrator may temporarily mount a filesystem as needed. The content of this directory is a local issue and should not affect the manner in which any program is run.
This directory must not be used by installation programs: a suitable temporary directory not in use by the system must be used instead.

So you’re both right and it depends on your interpretation: My interpretation is: removeable media go into /media because I can take the HDD out of the router and plug it in locally and it’ll get mounted in the exact same spot (which is the case for OP as well)


YES, thank you, and all and the rest for your time and help! It’s solved my issue sufficiently!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.