'mount -t cifs' doesn't work...

Hi guys,

I'm trying to mount a Windows share with 'mount - cifs' but I get 'command not found'. cifs-utils are installed and I am able to connect to this share with Dolphin.

Can't find out what is wrong. Please help...

terminal output is below...
p.s. obviously I use correct credentials....


[dima@dima-pc ~]$ sudo mount -t cifs //192.168.1.39/Music /mnt/BBMusic -o user=username,password=pass
[3] 1949
bash: 9: command not found

Is it maybe something in your password that is being parsed oddly on the command line?

To test, exclude the password option and it should ask for your password interactively.

2 Likes

Thank you very much. It worked!

It seems the problem is in & symbol. Have to change the password...

Actually no: you just have to properly quote or escape it to prevent bash interpreting:

[dima@dima-pc ~]$ sudo mount -t cifs //192.168.1.39/Music /mnt/BBMusic -o 'user=username,password=pass'

Note the single quotes around that option string.

1 Like

Thank you very much!

You can also store your username and password in a file that you can later reference by the credentials parameter. I’ve previously found that this can contain characters that can’t be parsed without the use of quotes when trying to execute mount.cifs via your shell.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by