Mount.nfs: remote share not in 'host:dir' format - how to resolve?

helllo good people, trying to get my NFS mount done correct (still)
so, I had different issues in th apst but I moved on (a bit, I hope) and now I am stuck with below error message.
NOTE: I am aware of the Arch wiki article on NFS mounting - what you see below is MY interpretation and understanding of its content. If it is off, please elaborate - willing to learn :wink:

1st attempt (“L***” is the server name):

sudo mount -t nfs ntfvers=4 -o L***:/srv/nfs/volume1/NAS_MUCKE /home/loki/NAS/Musik
mount.nfs: remote share not in 'host:dir' format

2nd attempt: (this time with IP instead of server name)

sudo mount -t nfs ntfvers=4 -o /home/loki/NAS/Musik                                                          
mount.nfs: remote share not in 'host:dir' format

and I think you might need the fstab file as well:
L***:/volume1/NAS_MUCKE /home/loki/NAS/Musik nfs _netdev,rw,nofail 0 0

as always: any help is much appreciated.

Hi @Satansbraten,

While I don’t use network shares at the moment, I believe you’ll be able to find help here: [root tip] Use systemd to mount ANY device and here: [root tip] systemd mount unit samples.

Hope this helps!

The -o is in the wrong place. It should be

-t nfs -o ntfvers=4

The -o sets the options(a comma separated list), after that the ‘host:dir’ . The -o ntfvers=4 is optional.

switching the -o results in another message
mount.nfs: an incorrect mount option was specified

I experimented and when I moved, I thought I was one step further…

The Arch wiki suggest it is just vers=4 . Also make sure your nfs server uses version 4 for the shares.