Mount harddrive without partition

I want to get data from an old hardrive and move it to my nas. The problem is i cant read the hardrive any more. Its either exfat or fat32. It was originally created on windows. The problem is i cant mount it because there is no partition on the hardrive. I couldnt mount the hardrive on windows and macos, but i still could over my arch distro. Sadly i reinstalled my arch and now it wont mount anymore. Im certain the data is still there. Does anyone have an idea how to mount it without a partition

Disk /dev/sdb: 465,76 GiB, 500107861504 bytes, 976773167 sectors
Disk model: Desktop         
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 33553920 bytes
Disklabel type: dos
Disk identifier: 0x7d4c57eb

Welcome to the forum! :vulcan_salute:

If you are absolutely certain that there is a filesystem on that drive without a partition, then try this… :point_down:

sudo mount -t auto /dev/sdb /mnt

then i get this error: mnt: wrong fs type, bad option, bad superblock on /dev/sdb, missing codepage or helper program, or other error


[ 1813.411468] nvme 0000:10:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0013 address=0x0 flags=0x0020]
[ 1813.411481] nvme 0000:10:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0013 address=0x600 flags=0x0020]
[ 1828.602937] EXT4-fs (sdb): VFS: Can't find ext4 filesystem
[ 1828.603224] EXT4-fs (sdb): VFS: Can't find ext4 filesystem
[ 1828.603466] EXT4-fs (sdb): VFS: Can't find ext4 filesystem
[ 1828.603732] FAT-fs (sdb): bogus number of reserved sectors
[ 1828.603734] FAT-fs (sdb): Can't find a valid FAT filesystem
[ 1828.603960] ntfs3: sdb: Primary boot signature is not NTFS.
[ 1828.604153] ntfs3: sdb: Alternative boot signature is not NTFS.
[ 1828.605422] XFS (sdb): Invalid superblock magic number
[ 1828.607550] exFAT-fs (sdb): Invalid boot checksum (boot checksum : 0x6c5a9a1f, checksum : 0xce5a9a2c)
[ 1828.607553] exFAT-fs (sdb): invalid boot region
[ 1828.607554] exFAT-fs (sdb): failed to recognize exfat type

In that case, there is no filesystem in that drive, and then I’m afraid whatever data was on there is gone.

It is highly uncommon to put a filesystem on a hard drive without partitioning it first. It can be done, but only if you know what you’re doing, and the drive wouldn’t be bootable.

What does… :point_down:

lsblk -f /dev/sdb

… say?

Pretty sure, I say pretty, like 99% sure, that if there is no partition the data is corrupted or even worse, gone.

Someone in another thread about data recovery recommended TestDisk to recover data.
This seems like something you might want to try.
Otherwise, there is always the trick of removing and recreating a partition, but that assumes you know exactly where the partition was before.

I would start with testdisk


the thing is i could mount it on a different system a week ago while it didnt work on other systems. I try testdisk

That is your best bet.

Witch is VERY strange, a partitionless btrfs, sure, but can you really do that with fat32/exfat?!?

testdisk gave me this:

Disk /dev/sdb - 500 GB / 465 GiB - CHS 60801 255 63
     Partition                  Start        End    Size in sectors
   P exFAT                    0   0  1 60801  80 62  976773167

Boot sector

Backup boot record

Sectors are not identical.

thank you. testdisk actually fixed it.

It finds a partition at least, it seems to start at 0, witch I think is very odd. Fat32/exFat usually starts one block in IIRC (512).

But run a recovery.
I have never used the program, but read up on it when it got recommended in another thread and seemed great.

I see you already fixed it. GOOD JOB! :slight_smile:

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.