Mount Dropbox

Hey Guys,

What's the easiest plugin out there to mount (not sync!) my dropbox to Manjaro KDE?

TIA.

You already received your answer on r/ManjaroLinux: rclone in the community repo or dbxfs in the AUR.

1 Like

Thanks guys, got DBXFS working in my Manjaro KDE laptop.

Few follow-up questions:

  1. How do I auto-mount DBXFS on boot? When I restarted, I was no longer able to navigate to my dropbox folder in Dolphin unfortunately.

  2. How do I move a folder from "places" section to "remote" section? I want to move my dropbox folder to the remote section to be next to my Google Drive:
    https://i.imgur.com/BPD3e8z.png

Please let me know if anyone can offer me some assistance, it would be greatly appreciated. TIA.

  1. Add dbxfs to startup programs. Not sure how to do that on KDE.
  2. Dunno, don't use KDE.

Anyone else with some input on the KDE front would be greatly appreciated. TIA.

Use Linux standards (autostart methods). In KDE System Settings, look for Autostart.
Use Devs instructions for commands

Usage

Use dbxfs like you would use the mount command:

$ dbxfs <mount_point>

To unmount your Dropbox folder on Linux systems, you can use fusermount -u <mount_point> , on all other systems use umount .
You can see the full list of command line options by passing -h to the dbxfs command.

... and I want a cup of coffee with a layer of milk in the middle of the cup height, instead of mixed or on the top. Do you have any suggestion?


Beware of the xyproblems. Try to focus on what you need and why, instead of what you think you need.

Have fun! :slightly_smiling_face:

1 Like

Hello,

I tried creating a script with the dbxfs command (super simple):

[aahmad@aahmad-pc Scripts]$ cat dropbox.sh  
#!/usr/bin/env bash
/usr/bin/dbxfs ~/mydropbox
exit 0
[aahmad@aahmad-pc Scripts]$

When I add it to the entree in the "autostart" applications, the script does not work or run. Any assistance would be greatly appreciated.

Have you tried just adding the command to the Autostart exec value?
dbxfs ~/mydropbox should be enough.
This is actually a .desktop file in ~/.config/autostart/*.desktop, when using Plasma Autostart in SystemSettings.

Does this command run successfully in terminal?

Maybe you have to investigate on the utility, using -v (verbose), to see details in journal?

I was actually thinking about adding desktop files to the AUR package. Once the mount is created, just running dbxfs is enough to mount it again.

EDIT: I forgot unmounting does require specifying the mount location.

1 Like

@AgentS,

Tried creating a command in Autostart as you suggested, nothing happened:

[aahmad@aahmad-pc autostart]$ pwd
/home/aahmad/.config/autostart
[aahmad@aahmad-pc autostart]$ cat dropbox.desktop  
Exec=/usr/bin/dbxfs ~/mydropbox
[aahmad@aahmad-pc autostart]$

Am I doing something incorrectly?

Bumping thread back up, can anyone offer some assistance with the .desktop entree?

TIA.

I'll reply to you here instead of PM so others can benefit.

You're missing required keys, see Desktop Entry Specification.

EDIT: Also, you can't use symbols like ~ without using using quotes.

If an argument contains a reserved character the argument must be quoted.

Quoting must be done by enclosing the argument between double quotes and escaping the double quote character, backtick character ("`"), dollar sign ("$") and backslash character ("") by preceding it with an additional backslash character. Implementations must undo quoting before expanding field codes and before passing the argument to the executable program.

Either use:

Exec=dbxfs /home/<username>/dropbox

or

Exec=sh -c "dbxfs ~/dropbox"
2 Likes

Thanks man! Well I thought I had everything right, but it's still not autostarting correctly. Here is my .desktop entre:

[aahmad@aahmad-pc autostart]$ cat dropbox.desktop
[Desktop Entry]
Type=Application
Terminal=false
Name=Dropbox
Exec=/usr/bin/dbxfs /home/aahmad/mydropbox/
Comment=mount dropbox.
[aahmad@aahmad-pc autostart]$

If I run my "exec" line in just a normal terminal window, it mounts my dropbox folder as expected. I made sure I hit all the required flags in my .desktop entree, so I am not sure what is the issue at this point.

TIA.

Have you tried the suggested entry?

That should work fine, it does on my end. Did you put it in ~/.local/share/applications?

[aahmad@aahmad-pc autostart]$ cat dropbox.desktop
[Desktop Entry]
Type=Application
Terminal=false
Name=Dropbox
Exec=sh -c "/usr/bin/dbxfs /home/aahmad/mydropbox/"
Comment=mount dropbox.
[aahmad@aahmad-pc autostart]$ pwd
/home/aahmad/.config/autostart
[aahmad@aahmad-pc autostart]$ 

Still not working unfortunately!

The location I put the file is in the following:

[aahmad@aahmad-pc autostart]$ pwd
/home/aahmad/.config/autostart

Please let me know if I can provide any additional information. TIA!

If you put in in ~/.local/share/applications, does it appear in the menu?

You had it right the first time. See my post above again. You don't need to use sh -c if you're using the full path.

Thanks @Yochanan, I thought the "autostart" directory was the one I linked:
/home/aahmad/.config/autostart

Are you saying the path you linked is the correct one for AutoStarts? Either way, I'll drop it in shortly and give it the ol' college try:
~/.local/share/applications

Thanks!

Yes, ~/.config/autostart is correct for startup applications. I was suggesting placing it in ~/.local/share/applications to see if the desktop file was functional.

Forum kindly sponsored by