Motherboard Audio OUT (Speakers) Doesn't Work ONLY when Case Audio OUT is plugged in (headset)

I have a strange issue. My speakers are plugged into the rear (motherboard) audio out (yes I’ve checked, it’s in green), and my headset is plugged into the front case audio out. The speakers work when the headset isn’t plugged in, and the headset works when speakers are plugged in, but when they are both in, speakers doesn’t work in Audio panel (selecting Line Out when mic plugged into front of case).

Ditto for the mic

Headset mic works when rear mic isn’t plugged in

Also, SOMETIMES the front mic will work for some reason when rear mic is plugged in

^Like if I switched it intentionally in the audio panel

Additionally pulseaudio -k restarts normally, bu still has the same issue.

Speakers work normally when tested. After plugging in headset, they no longer work. Audio panel -> manually set to speakers does nothing aside for mute all sound. Speaker volume is not muted in pavucontrol and audio panel.

Not sure where to go from here :slight_smile:

How can I restore proper working order of both my speakers and motherboard audio so that I can choose which one I want instead of having to manually unplug the headset to get the speaker to work?

Your description suggests you have Auto-Mute Mode enabled in ALSA
Laptop users may want this setting enabled so built-in speakers are muted when headphones are plugged in.
But on a desktop system, a user may not want audio to speakers muted if headphones are plugged in

1 Like

I did this, but when I disabled auto mute, both the speakers and the headset play the audio.

I set the audio panel to use 'line out" only, and this restored the speaker-only playback, but whenever I switch to 'headset" in the audio panel, both the speaker and headset play.

Did I do something wrong?

Disabling Auto-Mute Mode allows speakers to be unmuted when headphones are plugged in
The user has full control of both audio devices

OP appeared to be a request to use speakers all of the time and not headphones
So my response suggested muting Headphones in ALSA
(most onboard audio codecs are like your system and have only one analog audio subdevice shared between speakers and headphones, but a few have have 2 subdevices)

KDE audio controls relate to Pulseaudio and cannot control ALSA audio devices

see this post from old forum for how ALSA commands can be used to change the mute state of speakers/headphones
Unable to switch audiosource with headphones plugged in - Newbie Corner - Manjaro Linux Forum

or you can install qastools and use qasmixer to control ALSA instead of alsamixer

So is Pulseaudio the program that is malfunctioning?

I mean, if I switch to rear audio out, the speakers should work right? Currently. nothing happens.

Clearly something is wrong with the setup. :slight_smile:

Pulseaudio is overdue for an update, so there may be some old settings for user preferences in ~/.config/pulse/ folder that do not work with updated KDE packages

suggest you create a backup folder & move the 4 Pulseaudio database files & the Pulseaudio cookie in ~/.config/pulse/ to backup folder

mkdir ~/.config/pulse/old/ && mv -t ~/.config/pulse/old/ ~/.config/pulse/*.tdb && mv -t ~/.config/pulse/old/ ~/.config/pulse/cookie

then reboot system so that Pulseaudio will create new files for databases and cookie

delete backup folder rm -r ~/config/pulse/old/ if Pulseaudio is functioning OK after reboot

I tried it and pulse was reset (I has to ask it to not use the USB webcam audio again on restart), but other than that, there is still the same issue.

Trying to use line out from the audio panel leads to no sound still, but if I unplug the headest from the front, the speakers work without me having to change a thing. :slight_smile: