Monitors issues with Nvidia drivers on a laptop


I am new to this community, I have joined because of an issue, I tried searching for solutions (here and on the Ubuntu forum) but nothing that I have tried worked. I am a new Linux user, been enjoying it for the past few months, used to be a Windows user (I am single booting Manjaro).

I am using an Acer Nitro 5 laptop, with an i7 8750H, Nvidia GTX 1050Ti and 24GB RAM with an HDD. Alongside I have an external monitor connected through HDMI.

I had a few updates yesterday and after the restart there was no graphical interface, I could only see “/dev/sda2: clean xxxxx/xxxxx files…”. I got to the tty and tried switching drivers with mhwd because I remember there was an error regarding a video driver while updating (my mistake ignoring it). Anyway, I spent 6 hours to fix it and failed, so I decided to reinstall Manjaro again.

When the fresh installation booted everything seemed fine, I opted for the proprietary drivers as I am also playing games in my spare time. I installed CSGO to test, because when I first got Manjaro a few months ago the dedicated GPU was not working and had to do some tweaks which I don’t remember unfortunately (I am still a newbie). Sadly, the frames were extremely low, around 15 fps which is not normal as I was having around 250-350 fps before having Manjaro reinstalled. I checked the drivers and the video-hybrid-intel-nvidia-prime one was on, so I switched to video-nvidia and restarted. After this restart the laptop screen is not showing the graphical interface, it displays only “/dev/sda2: clean xxxxx/xxxxx files…”, the secondary monitor is working and when trying a game I do get the expected performance which means the dedicated GPU is actually working.

The problem is, how do I get to keep the dedicated GPU running and also have both screens working simultaneously? I tried optimus, it gave no errors but it didn’t do anything. In the past I remember doing some tweaks, which didn’t require optimus and made my laptop run solely on the Nvidia GPU.

OK, what is happening is that the HDMI port is being driven by the nVidia card and the internal display is being driven by the Intel and there is no direct electronic wiring from the nVidia to the internal display!

Unfortunately, this is happening more and more nowadays as manufacturers are driving down costs, so the only way to solve this is to use the hybrid driver and then the Intel is just used as a frame-buffer for the nVidia which will do the heavy lifting.

So switch to TTY2 and revert your changes and go back to the hybrid driver.
(If you wouldn’t know how to do that, shout out!)



Hello Fabby,

Thank you very much for the response. So I did as you suggested and indeed both of the screens are working now. The problem is that the dGPU does not start in games. I tried CSGO and I had 30-40 fps. I found a launch option that I have added to the game “prime-run %command%” and with this is went to 350 fps with the same settings, which clearly means that the dGPU is working. So as a workaround I can keep using the hybrid driver and specify this option on apps that I need, is it possible to use it on other games and applications outside of Steam?

Yes, that’s by design and the correct way to do it! :+1: Therefore, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.