Monitor refresh rates out of sync

—Hello everyone. I just started using Manjaro, and I am encountering some issues with my monitor refresh rate not syncing between NVIDIA X Server Settings and Display settings.


As you can see the monitor refresh rate in NVIDIA Settings is 59.95 and The display setting is 60. This is causing issues with me not being able to login on the first attempt. I will enter my password and all that shows is the mouse and the background. If I press Ctrl+Alt+Del the screen will go blank then I can press a key to enter my password again.
From what I can tell is this is because the refresh rates are out of sync. I have tried changing the refresh rates in both NVIDIA Settings and Display to no avail.
Sorry for posting a photo rather than text. I’m still unfamiliar with running terminal to get the info anyone needs. If anyone needs more data please let me know what commands I need to use to get it.

Thanks in advance.


read up as soon as you can, people helping you will appreciate it.

for now can you post
inxi -Fxxxz
mhwd -li
dmesg | tail

[sean@sean-pc ~]$ inxi -Fxxxz
System:    Host: sean-pc Kernel: 4.19.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN 
           tk: Gtk 3.24.1 info: xfce4-panel wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: Z170-AR v: Rev 1.xx serial: <filter> UEFI: American Megatrends v: 3801 
           date: 03/14/2018 
CPU:       Topology: Quad Core model: Intel Core i7-6700 bits: 64 type: MT MCP arch: Skylake-S rev: 3 L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 54544 
           Speed: 800 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: Micro-Star MSI driver: nvidia v: 410.73 bus ID: 01:00.0 
           chip ID: 10de:1b80 
           Display: x11 server: X.Org 1.20.3 driver: nvidia resolution: 2560x1440~60Hz 
           OpenGL: renderer: GeForce GTX 1080/PCIe/SSE2 v: 4.6.0 NVIDIA 410.73 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-H HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a170 
           Device-2: NVIDIA GP104 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:10f0 
           Sound Server: ALSA v: k4.19.2-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6 
           chip ID: 8086:15b8 
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 40.31 GiB (4.3%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 1TB size: 931.51 GiB speed: 6.0 Gb/s serial: <filter> rev: 2B6Q 
           scheme: GPT 
Partition: ID-1: / size: 898.70 GiB used: 40.31 GiB (4.5%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 17.16 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 34.0 C mobo: N/A gpu: nvidia temp: 50 C 
           Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 53% 
Info:      Processes: 206 Uptime: 1h 43m Memory: 15.60 GiB used: 886.8 MiB (5.5%) Init: systemd v: 239 Compilers: gcc: 8.2.1 
           Shell: bash v: 4.4.23 running in: xfce4-terminal inxi: 3.0.27 

[sean@sean-pc ~]$ mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
          video-nvidia            2018.08.09               false            PCI


Warning: No installed USB configs!

[sean@sean-pc ~]$ dmesg | tail
[ 5993.656973] [UFW BLOCK] IN=enp0s31f6 OUT= MAC=01:00:5e:00:00:01:28:56:5a:e7:00:b9:08:00 SRC=192.168.0.1 DST=224.0.0.1 LEN=28 TOS=0x00 PREC=0x00 TTL=1 ID=0 PROTO=2 
[ 5993.657721] [UFW BLOCK] IN=enp0s31f6 OUT= MAC=01:00:5e:00:00:01:28:56:5a:e7:00:b9:08:00 SRC=192.168.0.1 DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0x00 TTL=1 ID=0 PROTO=2 
[ 6050.957563] [UFW BLOCK] IN=enp0s31f6 OUT= MAC=01:00:5e:00:00:fb:50:bc:96:97:2f:0c:08:00 SRC=192.168.0.2 DST=224.0.0.251 LEN=32 TOS=0x00 PREC=0x00 TTL=1 ID=36181 PROTO=2 
[ 6105.321320] [UFW BLOCK] IN=enp0s31f6 OUT= MAC=01:00:5e:00:00:fb:50:bc:96:97:2f:0c:08:00 SRC=192.168.0.2 DST=224.0.0.251 LEN=32 TOS=0x00 PREC=0x00 TTL=1 ID=32582 PROTO=2 
[ 6119.659100] [UFW BLOCK] IN=enp0s31f6 OUT= MAC=01:00:5e:00:00:01:28:56:5a:e7:00:b9:08:00 SRC=192.168.0.1 DST=224.0.0.1 LEN=28 TOS=0x00 PREC=0x00 TTL=1 ID=0 PROTO=2 
[ 6119.659873] [UFW BLOCK] IN=enp0s31f6 OUT= MAC=01:00:5e:00:00:01:28:56:5a:e7:00:b9:08:00 SRC=192.168.0.1 DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0x00 TTL=1 ID=0 PROTO=2 
[ 6199.967436] [UFW BLOCK] IN=enp0s31f6 OUT= MAC= SRC=fe80:0000:0000:0000:222a:87fb:8bc1:90fd DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=84 TC=0 HOPLIMIT=1 FLOWLBL=78264 PROTO=UDP SPT=27036 DPT=27036 LEN=44 
[ 6245.652837] [UFW BLOCK] IN=enp0s31f6 OUT= MAC=01:00:5e:00:00:01:28:56:5a:e7:00:b9:08:00 SRC=192.168.0.1 DST=224.0.0.1 LEN=28 TOS=0x00 PREC=0x00 TTL=1 ID=0 PROTO=2 
[ 6245.653537] [UFW BLOCK] IN=enp0s31f6 OUT= MAC=01:00:5e:00:00:01:28:56:5a:e7:00:b9:08:00 SRC=192.168.0.1 DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0x00 TTL=1 ID=0 PROTO=2 
[ 6263.634158] [UFW BLOCK] IN=enp0s31f6 OUT= MAC=01:00:5e:00:00:fb:50:bc:96:97:2f:0c:08:00 SRC=192.168.0.2 DST=224.0.0.251 LEN=32 TOS=0x00 PREC=0x00 TTL=1 ID=43904 PROTO=2

Everything is fine there, just a cosmetic issue, not a technical issue. You could manually set the refresh rate to X Server Display Configuration entry for the monitor in NVIDIA X Server Settings, then save it to /etc/X11/mhwd.d/nvidia.conf … there should be in the Section "Screen" where the Option "metamodes" is … probably like this: "DP-4: 2560x1440_60 +0+0" and all that comes after …

1 Like

From my understanding, that is “normal”, and goes back to the early times of PAL and NTSC
If you speak German, you can read this:

1 Like

If everything looks right on a technical level, why do I have login issues?

Could be that lightdm starts to early for some reason ? :thinking:

Do you have this line in Section "Screen" in /etc/X11/mhwd.d/nvidia.conf ?

Option "metamodes" "DP-4: 2560x1440_60 +0+0 { ForceCompositionPipeline = On }"

See if there is a difference with or without it … { ForceCompositionPipeline = On }

1 Like

Sounds like a good topic for a new thread.

Forum kindly sponsored by