Monitor only shows very low and improper resolution

When installing manjaro, both of my top monitors show their proper resolution and refresh rate but my bottom main monitor will only show 480p. This monitor is supposed to be in 1440p @ 144hz. My GPU is the RX 6900XT, a relatively new card that might cause this. I have installed manjaro before with this same monitor using my GTX 1080 and didn’t have any issues with this. Was hoping I can find out what I could do to fix this issue so I could fully transition to manjaro as my main OS.

Much thanks to any help. Here is the output of the inxi command.

  Kernel: 5.11.1-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.11-x86_64 
  root=UUID=74596f23-932f-41fa-9eb6-72d5cca2dd9d ro quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.21.1 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop System: ASUS product: N/A v: N/A serial: <filter> 
  Mobo: ASUSTeK model: ROG STRIX Z390-E GAMING v: Rev 1.xx serial: <filter> 
  UEFI: American Megatrends v: 1802 date: 12/01/2020 
Memory:
  RAM: total: 62.73 GiB used: 2.62 GiB (4.2%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Info: 8-Core model: Intel Core i7-9700K bits: 64 type: MCP arch: Kaby Lake 
  note: check family: 6 model-id: 9E (158) stepping: C (12) microcode: DE 
  L2 cache: 12 MiB bogomips: 57616 
  Speed: 800 MHz min/max: 800/4900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc 
  cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms 
  est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp 
  hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid 
  invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr 
  nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni 
  popcnt pse pse36 pts rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep 
  smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc 
  tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec 
  xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT disabled 
Graphics:
  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] driver: amdgpu 
  v: kernel bus ID: 03:00.0 chip ID: 1002:73bf class ID: 0300 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x1560 s-dpi: 96 s-size: 1016x412mm (40.0x16.2") 
  s-diag: 1096mm (43.2") 
  Monitor-1: DisplayPort-0 res: 1920x1080 dpi: 92 size: 531x299mm (20.9x11.8") 
  diag: 609mm (24") 
  Monitor-2: DisplayPort-1 res: 640x480 hz: 60 
  Monitor-3: HDMI-A-0 res: 1920x1080 dpi: 93 size: 527x296mm (20.7x11.7") 
  diag: 604mm (23.8") 
  OpenGL: 
  renderer: AMD SIENNA_CICHLID (DRM 3.40.0 5.11.1-1-MANJARO LLVM 11.1.0) 
  v: 4.6 Mesa 20.3.4 direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:a348 class ID: 0403 
  Device-2: AMD driver: snd_hda_intel v: kernel bus ID: 03:00.1 
  chip ID: 1002:ab28 class ID: 0403 
  Device-3: Logitech HD Pro Webcam C920 type: USB 
  driver: snd-usb-audio,uvcvideo bus ID: 1-9.2:11 chip ID: 046d:082d 
  class ID: 0102 serial: <filter> 
  Device-4: Focusrite-Novation Scarlett Solo (3rd Gen.) type: USB 
  driver: snd-usb-audio bus ID: 1-1:2 chip ID: 1235:8211 class ID: 0102 
  serial: <filter> 
  Device-5: Valve Valve VR Radio type: USB driver: cdc_acm,hid-generic,usbhid 
  bus ID: 1-10.3.3:19 chip ID: 28de:2102 class ID: 0102 serial: <filter> 
  Device-6: Valve Valve VR Radio & HMD Mic type: USB 
  driver: hid-generic,snd-usb-audio,usbhid 
  Sound Server: ALSA v: k5.11.1-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel 
  bus ID: 00:14.3 chip ID: 8086:a370 class ID: 0280 
  IF: wlo1 state: down mac: <filter> 
  Device-2: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel 
  port: efa0 bus ID: 00:1f.6 chip ID: 8086:15bc class ID: 0200 
  IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
Bluetooth:
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB 
  driver: btusb v: 0.8 bus ID: 1-14:16 chip ID: 8087:0aaa class ID: e001 
  Message: Required tool hciconfig not installed. Check --recommends 
RAID:
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: 4020 
  bus ID: 00:17.0 chip ID: 8086.2822 rev: 10 
Drives:
  Local Storage: total: 2.83 TiB used: 8.93 GiB (0.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Intel model: SSDSC2BP240G4 
  size: 223.57 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 0410 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 840 EVO 250GB 
  size: 232.89 GiB block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: SSD serial: <filter> rev: BB0Q scheme: GPT 
  ID-3: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 860 EVO 500GB 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 3B6Q scheme: GPT 
  ID-4: /dev/sdd maj-min: 8:48 vendor: Seagate model: ST2000DM008-2FR102 
  size: 1.82 TiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: 0001 scheme: GPT 
  ID-5: /dev/sde maj-min: 8:64 type: USB vendor: SanDisk model: Ultra USB 3.0 
  size: 114.56 GiB block size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 1.00 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Message: No Optical or Floppy data was found. 
Partition:
  ID-1: / raw size: 223.27 GiB size: 218.77 GiB (97.98%) used: 8.93 GiB (4.1%) 
  fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: 74596f23-932f-41fa-9eb6-72d5cca2dd9d 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 0045-89F8 
Swap:
  Alert: No Swap data was found. 
Unmounted:
  ID-1: /dev/sdb1 maj-min: 8:17 size: 232.88 GiB fs: ntfs label: SSD 1 
  uuid: 38EEEF26EEEEDB60 
  ID-2: /dev/sdc1 maj-min: 8:33 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-3: /dev/sdc2 maj-min: 8:34 size: 465.75 GiB fs: ntfs label: SSD 2 
  uuid: AEB2BC1EB2BBE8CB 
  ID-4: /dev/sdd1 maj-min: 8:49 size: 1024 KiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-5: /dev/sdd2 maj-min: 8:50 size: 15 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-6: /dev/sdd3 maj-min: 8:51 size: 1.53 TiB fs: ntfs label: Storage 
  uuid: 4C0E96FD0E96DEF0 
  ID-7: /dev/sdd4 maj-min: 8:52 size: 3.91 GiB fs: swap label: N/A 
  uuid: 92a84f44-0a0d-4252-ab06-0e7310f7123e 
  ID-8: /dev/sdd5 maj-min: 8:53 size: 512 MiB fs: ext4 label: N/A 
  uuid: de7db975-2e56-45ac-8e2c-b81ba5ee9cc1 
  ID-9: /dev/sde1 maj-min: 8:65 size: 3 GiB fs: iso9660 
  label: MANJARO_KDE_2021 uuid: 2021-01-03-09-07-36-00 
  ID-10: /dev/sde2 maj-min: 8:66 size: 4 MiB fs: vfat label: MISO_EFI 
  uuid: 7B2D-7571 
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Device-1: 1-1:2 info: Focusrite-Novation Scarlett Solo (3rd Gen.) 
  type: Audio driver: snd-usb-audio interfaces: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1235:8211 class ID: 0102 serial: <filter> 
  Device-2: 1-2:3 info: Cyber Power System CP1500 AVR UPS type: HID 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  chip ID: 0764:0501 class ID: 0300 serial: <filter> 
  Hub-2: 1-6:4 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 05e3:0610 class ID: 0900 
  Device-1: 1-6.3:6 info: SINOWEALTH Wired Gaming Mouse type: Mouse,Keyboard 
  driver: glorious,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s 
  chip ID: 258a:0033 class ID: 0301 
  Device-2: 1-6.4:9 info: ASUSTek AURA MOTHERBOARD type: HID 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  chip ID: 0b05:18a3 class ID: 0300 serial: <filter> 
  Hub-3: 1-8:5 info: Genesys Logic Hub ports: 4 rev: 2.1 speed: 480 Mb/s 
  chip ID: 05e3:0610 class ID: 0900 
  Device-1: 1-8.1:8 info: Valve Watchman Dongle type: HID 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  chip ID: 28de:2101 class ID: 0300 serial: <filter> 
  Device-2: 1-8.3:12 info: Valve Watchman Dongle type: HID 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  chip ID: 28de:2101 class ID: 0300 serial: <filter> 
  Device-3: 1-8.4:15 info: Valve Watchman Dongle type: HID 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  chip ID: 28de:2101 class ID: 0300 serial: <filter> 
  Hub-4: 1-9:7 info: Genesys Logic Hub ports: 3 rev: 2.1 speed: 480 Mb/s 
  chip ID: 05e3:0610 class ID: 0900 
  Device-1: 1-9.2:11 info: Logitech HD Pro Webcam C920 type: Video,Audio 
  driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 046d:082d class ID: 0102 serial: <filter> 
  Hub-5: 1-10:10 info: Valve ports: 3 rev: 2.0 speed: 480 Mb/s 
  chip ID: 28de:2613 class ID: 0900 
  Hub-6: 1-10.3:14 info: Microchip (formerly SMSC) Hub ports: 5 rev: 2.1 
  speed: 480 Mb/s chip ID: 0424:2744 class ID: 0900 
  Device-1: 1-10.3.1:17 info: Valve Index HMD type: HID 
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  chip ID: 28de:2300 class ID: 0300 serial: <filter> 
  Device-2: 1-10.3.2:18 info: Valve Valve VR Radio 
  type: HID,Abstract (modem),CDC-Data driver: cdc_acm,hid-generic,usbhid 
  interfaces: 3 rev: 2.0 speed: 12 Mb/s chip ID: 28de:2102 class ID: 0a00 
  serial: <filter> 
  Device-3: 1-10.3.3:19 info: Valve Valve VR Radio & HMD Mic type: HID,Audio 
  driver: hid-generic,snd-usb-audio,usbhid interfaces: 3 rev: 2.0 
  speed: 12 Mb/s chip ID: 28de:2102 class ID: 0102 serial: <filter> 
  Device-4: 1-10.3.5:20 info: Microchip (formerly SMSC) Hub Controller 
  type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 480 Mb/s 
  chip ID: 0424:2740 class ID: 0000 
  Device-5: 1-13:13 info: qmkbuilder KBD75 type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 3 rev: 1.1 speed: 12 Mb/s 
  chip ID: 4b42:6061 class ID: 0300 
  Device-6: 1-14:16 info: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) 
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  chip ID: 8087:0aaa class ID: e001 
  Hub-7: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.1 
  speed: 10 Gb/s chip ID: 1d6b:0003 class ID: 0900 
  Device-1: 2-7:2 info: SanDisk Ultra USB 3.0 type: Mass Storage 
  driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s chip ID: 0781:5595 
  class ID: 0806 serial: <filter> 
  Hub-8: 2-8:3 info: Genesys Logic USB3.1 Hub ports: 4 rev: 3.2 speed: 5 Gb/s 
  chip ID: 05e3:0626 class ID: 0900 
  Hub-9: 2-9:4 info: Genesys Logic Hub ports: 3 rev: 3.0 speed: 5 Gb/s 
  chip ID: 05e3:0612 class ID: 0900 
  Hub-10: 2-10:5 info: Microchip (formerly SMSC) Hub ports: 4 rev: 3.2 
  speed: 5 Gb/s chip ID: 0424:5744 class ID: 0900 
  Hub-11: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Device-1: 3-1:2 info: VIA Labs USB 2.0 BILLBOARD type: Billboard driver: N/A 
  interfaces: 1 rev: 2.0 speed: 12 Mb/s chip ID: 2109:0103 class ID: 1100 
  serial: <filter> 
  Device-2: 3-2:3 info: Cooler Master ARES type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  chip ID: 2516:014d class ID: 0300 
  Hub-12: 4-0:1 info: Full speed (or root) Hub ports: 1 rev: 3.1 
  speed: 10 Gb/s chip ID: 1d6b:0003 class ID: 0900 
Sensors:
  System Temperatures: cpu: 27.8 C mobo: N/A gpu: amdgpu temp: 52.0 C 
  mem: 56.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
Info:
  Processes: 244 Uptime: 10m wakeups: 0 Init: systemd v: 247 Compilers: 
  gcc: N/A Packages: pacman: 1229 lib: 377 flatpak: 0 Shell: Bash v: 5.1.0 
  running in: konsole inxi: 3.3.01 ```

Have you tried different kernels?

Yes. I tried 5.11 and it didn’t change anything

5.11 is the one you use right now (seen in the inxi), so that is not a different one.

I was on 5.9 and then tried using 5.11 before making this post

With this being a very new gpu, one of the first things that I was thinking of was that maybe the latest kernel would treat me better, but it treats me the same.