Monitor does not turn back on after energy saving

Hi fellow Manjarees,

I know there are some rare occasions of users being troubled with machines not responding after a suspended session.

The bug I encounter on Manjaro running KDE latest, is different … and worse: Every time, the display turns off for energy saving (not sleep or hibernation of the system), it does not turn back on again. Once I give an input (mouse movement or key press), the monitor does actually wake up and gets a signal (switches from red standby LED back to blue power LED), but the screen just stays black.
I can, however, switch to a terminal via ctrl+alt+F2 and manually reboot the system.

This bug is severe, for it renders the whole system useless. All open work is lost, once I turn my back on the computer for a couple of minutes. Disabling energy saving is also not an alternative, obviously, just a temporary workaround.

For a beginning, this is my configuration

$ inxi -mFxxxzzz
Kernel: 6.0.8-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Type: Desktop System: Micro-Star product: MS-7C84 v: 1.0
serial: <superuser required>
Mobo: Micro-Star model: MAG X570 TOMAHAWK WIFI (MS-7C84) v: 1.0
serial: <superuser required> UEFI: American Megatrends v: 1.51
date: 11/16/2020
Device-1: hidpp_battery_0 model: Logitech MX Keys Wireless Keyboard
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
RAM: total: 31.27 GiB used: 3.28 GiB (10.5%)
RAM Report: permissions: Unable to run dmidecode. Root privileges
Info: 6-core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP smt: enabled
arch: Zen 2 rev: 0 cache: L1: 384 KiB L2: 3 MiB L3: 32 MiB
Speed (MHz): avg: 2421 high: 3600 min/max: 2200/4208 boost: enabled cores:
1: 2200 2: 3600 3: 2200 4: 2200 5: 2200 6: 2200 7: 3600 8: 2200 9: 2055
10: 2200 11: 2200 12: 2200 bogomips: 86441
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Device-1: NVIDIA GA104 [GeForce RTX 3070] vendor: ZOTAC driver: nvidia
v: 520.56.06 arch: Ampere pcie: speed: 16 GT/s lanes: 16 bus-ID: 2d:00.0
chip-ID: 10de:2484 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1600 s-dpi: 109 s-size: 894x372mm (35.20x14.65")
s-diag: 968mm (38.12")
Monitor-1: DP-4 pos: primary res: 3840x1600 dpi: 111
size: 880x370mm (34.65x14.57") diag: 955mm (37.58") modes: N/A
Monitor-2: HDMI-0 size-res: N/A modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 520.56.06 renderer: NVIDIA GeForce RTX
3070/PCIe/SSE2 direct render: Yes
Device-1: Creative Labs Sound Core3D [Sound Blaster Recon3D / Z-Series]
driver: snd_hda_intel v: kernel pcie: speed: 2.5 GT/s lanes: 1
bus-ID: 25:00.0 chip-ID: 1102:0012 class-ID: 0403
Device-2: NVIDIA GA104 High Definition Audio vendor: ZOTAC
driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
bus-ID: 2d:00.1 chip-ID: 10de:228b class-ID: 0403
Sound API: ALSA v: k6.0.8-1-MANJARO running: yes
Sound Server-1: JACK v: 1.9.21 running: no
Sound Server-2: PulseAudio v: 16.1 running: yes
Sound Server-3: PipeWire v: 0.3.59 running: yes
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: speed: 5 GT/s
lanes: 1 bus-ID: 28:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:3
chip-ID: 8087:0029 class-ID: e001
Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Local Storage: total: 2.96 TiB used: 556.18 GiB (18.4%)
ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB
size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 2B2QEXM7 temp: 26.9 C scheme: GPT
ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO Plus 250GB
size: 232.89 GiB speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 2B2QEXM7 temp: 41.9 C scheme: GPT
ID-3: /dev/sda vendor: Samsung model: SSD 870 QVO 2TB size: 1.82 TiB
speed: 6.0 Gb/s type: SSD serial: <filter> rev: 2B6Q scheme: GPT
ID-1: / size: 227.88 GiB used: 78.37 GiB (34.4%) fs: ext4
dev: /dev/nvme1n1p2
ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
dev: /dev/nvme1n1p1
Alert: No swap data was found.
System Temperatures: cpu: 47.4 C mobo: N/A gpu: nvidia temp: 49 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Processes: 303 Uptime: 24m wakeups: 6 Init: systemd v: 251
default: graphical Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1595
pm: pacman pkgs: 1572 pm: flatpak pkgs: 15 pm: snap pkgs: 8 Shell: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.23

Any ideas, where to start bugfixing?

use formatting for the inxi output, its unreadable…
did you tried with different kernels?
did the same happens on the live usb?

1 Like

Sorry, formatting is fixed, my bad.
I can (will this weekend) try other kernels, but I would also like to find a solution (or at least pinpoint the error). Otherwise, it can never be fixed and reverting back to older kernels can only be a temporary fix. This is a running release after all and my hardware is pretty fresh. :wink:

I experienced the same issue today, for first time and I haven’t done any updates since Nov 20th.

create a new test user from system settings, log out, log in with it and test if it has the same issue…
check also if your monitor has some power saving/sleep settings…
also switch to the 5.15 kernel and test with it…
if it still happens provdide logs:
journalctl -b-1 -p4 --no-pager

So, yeah. Everything went great… till the system bricked.

First test: Starting with Linux 5.15. LTS > Fail. Same problem.
Second test: Using a live boot USB > WORKS! So, the problem might be somewhere in the user profile.
Third test: Creating a new user via settings GUI. Disabling autologin via GUI. Reboot.


After boot, black screen with a large cursor.

That is why Linux is unfortunately, still not ready for normal users as everyday driver and even I am very … hindered and aggrevated :slight_smile: Ain’t nobody got time for this.

Well. My data is backed up and on a different partition. So i will wipe my system, make a fresh install and report back, wether the bug reoccurs. Would have been neat to find out, what made it happen in the first place.
Thanks for your help anyway @brahma

Wow. What a dirtshow. After a fresh install, everything works. At first. Then I update the system, and after that, the display stays black. What is happening?

I have a two monitor setup. A main screen on my desk, and a setting in the living room for watching movies. For unknown reason, my main screen is disabled. It is still listed in the system settings > display configuration, but clicking and applying “enable” does nothing and on the next restart, it is disabled again.

$ journalctl -b-1 -p4 --no-pager
says: – No entries —

But actually, I almost had it now. I’ve had nothing but trouble with Linux in the last years, no matter which distro or kernel or Desktop Environment. If I can’t fix this in the next 24 hours, it is back to windows. I am loosing valuable time here, that I don’t have. :frowning:

Ok. So I narrowed it down to the kscreen daemon messing up. It seems to be plagued since ages, when it comes to dual monitor setups and just recently, another problem emerged:

I fixed it manually: In .local/share/kscreen there are three config files. In one of them I found (notice the changed values)

        "enabled": true,
        "id": "7938d2767368e7d0741d5b5df4548801",
        "metadata": {
            "fullname": "xrandr-Samsung Electric Company-SAMSUNG-16778753",
            "name": "HDMI-0"
        "mode": {
            "refresh": 60,
            "size": {
                "height": 1080,
                "width": 1920
        "overscan": 0,
        "pos": {
            "x": 3840,
            "y": 0
        "primary": false,
        "rgbrange": 0,
        "rotation": 1,
        "scale": 1,
        "vrrpolicy": 2
        "enabled": ~~false~~ **true**,
        "id": "66f3667408b1cffa2e742224b70eda61",
        "metadata": {
            "fullname": "xrandr-LG Electronics-38GN950-007NTNHGV535",
            "name": "DP-4"
        "mode": {
            "refresh": 119.98229217529297,
            "size": {
                "height": 1600,
                "width": 3840
        "overscan": 0,
        "pos": {
            "x": 0,
            "y": 0
        "primary": ~~false~~ **true**,
        "rgbrange": 0,
        "rotation": 1,
        "scale": 1,
        "vrrpolicy": 2

Now, everything works as expected, the energy saving bug is gone.

Addition: The bug in kscreen is not solved… It returned. Once the primary monitor is switched off once, kscreen keeps it stated at “enabled” : false forever.

I have reported the bug to KDE. Please join in and leave a comment there, when you face similar problems:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.