ModuleNotFoundError: No module named 'gi'

Hi there,

I recently switched to testing, to get the internal microphone on my T14 working.
All worked just fine for two weeks.

Since yesterday I get stuck in Activities Overview. No matter if on Wayland or on a Gnome on Xorg session.
I found this topic: Stuck in Activities view
This described my problem quite well.

But when I tried to open gnome-tweaks or gnome-layout-switcher to follow the proposed solutions there, i get the following terminal output:

me@myT14-Manj ~ [1]> gnome-layout-switcher    (base) 
Traceback (most recent call last):
  File "/usr/bin/gnome-layout-switcher", line 3, in <module>
import gi
ModuleNotFoundError: No module named 'gi'

I did some (superficial) online search and found that python-gi is part of python-goobject, which is installed on my system…

Any ideas how to continue from here?

EDIT: This is a Python env problem. I used the Firefox Gnome Extensions Add-On to deactivate all Gnome-Shell-Extensions and my Activity Overview started to work as expected again. My Problem now is, that my system wide standard Python env got changed to my anaconda installation. Still working on that.

Could be the case where you default python is not the system python that has access to all other system python libraries. Check order of pythons (which -a python or which -a python3 and make sure /usr/bin/python is the top one.

This is exactly the case, my anaconda environment took the first place for both.
I try to find out how to make /usr/bin/python my default again

My solution was to reinstall anaconda, as I could not find any Arch specific solutions online to do this.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.