$mod+Return combination doesn't run terminal

I’ve encountered weird problem.
$mod+Return combination doesn’t run terminal. One hour ago worked fine, but now it’s not. If I run rofi i can type terminal (which is urxvt) and it will launch. And inside terminal Return key works fine. Only change I did was clearing orphans from pamac by command below. Shortly after that $mod+Return stopped working. And $mod+d runs rofi or $mod+F2 runs web browser.

pamac remove -o

This is in ~/.i3/config:
bindsym $mod+Return exec terminal

Do you have any ideas how solve this problem? I’ve searched this problem on my own but without success.

Oh, there is one more thing. When I press this keys combination “working/busy” icon shows but nothing happens.

Well what did you remove that was an ‘orphan’ ?

less /var/log/pacman.log

(yes pamac prints to pacman log)

1 Like

Could “terminal” have been redefined somewhere? You could try adding a line to ~/.profile defining $TERMINAL as urxvt. Or you could probably just alter that line in the i3 config to exec urxvt. Of course, even if one of those works, it still wouldn’t clear up the mystery of what happened.

Its also worth noting that pamac uses the ‘cascade’ option for removal by default.
Which is a bit greedy.
But also compounded when using on ‘orphans’
There is an extra flag that is supposed to help mitigate this ‘–unnneeded’ or ‘-u’

So if you must blindly remove orphans … and if you must use pamac to do it …
Then you might make sure to include the u option

pamac remove -ou
1 Like

Well what did you remove that was an ‘orphan’ ?
less /var/log/pacman.log

Listed items explains why wifi icon or even mouse cursor changed too. It was first time when used information from some web site without checking what can do. Reinstalling should solve this ‘mystery’.

[2020-08-31T22:23:13+0200] [ALPM] running ‘texinfo-remove.hook’…
[2020-08-31T22:23:13+0200] [ALPM] transaction started
[2020-08-31T22:23:20+0200] [ALPM] removed xorg-fonts-misc (1.0.3-10)
[2020-08-31T22:23:21+0200] [ALPM] removed cmake (3.18.2-1)
[2020-08-31T22:23:21+0200] [ALPM] removed libuv (1.38.1-1)
[2020-08-31T22:23:21+0200] [ALPM] removed i3-help (20180110-1)
[2020-08-31T22:23:21+0200] [ALPM] removed rhash (1.4.0-1)
[2020-08-31T22:23:21+0200] [ALPM] removed picom (8-3)
[2020-08-31T22:23:22+0200] [ALPM] removed libconfig (1.7.2-3)
[2020-08-31T22:23:22+0200] [ALPM] removed urxvt-perls (2.3-1)
[2020-08-31T22:23:22+0200] [ALPM] removed xsel (
[2020-08-31T22:23:22+0200] [ALPM] removed xcursor-breeze (5.11.5-1)
[2020-08-31T22:23:22+0200] [ALPM] removed jsoncpp (1.9.3-1)
[2020-08-31T22:23:22+0200] [ALPM] removed manjaro-base-skel (20171029-3)
[2020-08-31T22:23:22+0200] [ALPM] removed xorg-font-utils (7.6-6)
[2020-08-31T22:23:22+0200] [ALPM] removed xorg-font-util (1.3.2-2)
[2020-08-31T22:23:22+0200] [ALPM] removed cracklib (2.9.7-2)
[2020-08-31T22:23:22+0200] [ALPM] removed python-pytoml (0.1.21-4)
[2020-08-31T22:23:23+0200] [ALPM] removed xorg-mkfontscale (1.2.1-2)
[2020-08-31T22:23:23+0200] [ALPM] removed i3exit (20200217-1)
[2020-08-31T22:23:23+0200] [ALPM] removed papirus-maia-icon-theme (20200201-1)
[2020-08-31T22:23:23+0200] [ALPM] removed i3-scrot (2-2)
[2020-08-31T22:23:23+0200] [ALPM] removed conky-i3 (20180507-1)
[2020-08-31T22:23:23+0200] [ALPM] removed i3-scripts (20200804-1)
[2020-08-31T22:23:23+0200] [ALPM] removed xorg-bdftopcf (1.1-2)
[2020-08-31T22:23:33+0200] [ALPM] removed papirus-icon-theme (20200801-1)
[2020-08-31T22:23:33+0200] [ALPM] removed gendesk (1.0.6-1)
[2020-08-31T22:23:33+0200] [ALPM] removed xorg-fonts-alias-misc (1.0.4-1)
[2020-08-31T22:23:33+0200] [ALPM] removed conky (1.11.5+2+g0d449029-2)
[2020-08-31T22:23:33+0200] [ALPM] removed libxnvctrl (450.66-1)
[2020-08-31T22:23:34+0200] [ALPM] removed wireless_tools (30.pre9-3)

1 Like

lesson learnt :+1: glad you work out why and now know how to fix

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.