Mkinitcpio 39 is buggy

I think due to the script change our kernelbase variable never gets populated when the template gets created. Will check that later and try to fix that for 39

1 Like

I found the issue. The logic on how the preset files get generated changed with 39:

--- script-38.1	2024-03-12 23:51:43.000000000 +0700
+++ script-39	2024-05-03 20:24:32.000000000 +0700
@@ -6,7 +6,34 @@ set -e
 args=()
 package=0
 
-process_preset() {
+install_preset() {
+    local pkgbase="$1" preset="$2"
+
+    if [[ ! -e "$preset" ]]; then
+        if [[ -e "$preset.pacsave" ]]; then
+            # move the pacsave to the template
+            mv -- "${preset}.pacsave" "$preset"
+        else
+            # create the preset from the template
+            sed "s|%PKGBASE%|${pkgbase}|g" /usr/share/mkinitcpio/hook.preset \
+                | install -Dm644 /dev/stdin "$preset"
+        fi
+    fi
+}
+
+generate_presets() {
+    local preset pkgbase pkgbase_path
+
+    # only make presets for kernels with a pkgbase
+    for pkgbase_path in /usr/lib/modules/*/pkgbase; do
+        if read -r pkgbase &>/dev/null <"$pkgbase_path"; then
+            preset="/etc/mkinitcpio.d/${pkgbase}.preset"
+            install_preset "$pkgbase" "$preset"
+        fi
+    done
+}
+
+remove_preset() {
     if [[ -n "$pkgbase" && -e "$preset" ]]; then
         if ! cmp "$preset" <(sed "s|%PKGBASE%|${pkgbase}|g" /usr/share/mkinitcpio/hook.preset) &>/dev/null; then
             if [[ ! -e "$preset.pacsave" ]]; then
@@ -98,17 +125,7 @@ install_kernel() {
     local pkgbase="$1"
     local kernel preset="/etc/mkinitcpio.d/${pkgbase}.preset"
 
-    if [[ ! -e "$preset" ]]; then
-        if [[ -e "$preset.pacsave" ]]; then
-            # move the pacsave to the template
-            mv -- "${preset}.pacsave" "$preset"
-        else
-            # create the preset from the template
-            sed "s|%PKGBASE%|${pkgbase}|g" /usr/share/mkinitcpio/hook.preset \
-                | install -Dm644 /dev/stdin "$preset"
-        fi
-    fi
-
+    install_preset "$pkgbase" "$preset"
     (
         # source the preset to get the kernel and image locations
         # shellcheck disable=SC1090
@@ -145,10 +162,17 @@ remove_kernel() {
         rm -f -- "${filelist[@]}"
     ) || return
     # remove the preset
-    process_preset "$pkgbase" "$preset"
+    remove_preset "$pkgbase" "$preset"
 }
 
 while read -r line; do
+    if [[ "${line%%-git}" == "mkinitcpio" && "$1" == "install" ]]; then
+        # generate presets for each kernel on package install
+        generate_presets
+        package=1
+        continue
+    fi
+
     if [[ "$line" != */vmlinuz ]]; then
         # triggers when it's a change to usr/lib/initcpio/*
         package=1
@@ -177,7 +201,7 @@ if (( package )) && compgen -G /etc/mkin
             for preset in /etc/mkinitcpio.d/*.preset; do
                 pkgbase=${preset##*/}
                 pkgbase=${pkgbase%.preset}
-                process_preset "$pkgbase" "$preset"
+                remove_preset "$pkgbase" "$preset"
             done
             shopt -u nullglob
             ;;

This got added:

@@ -145,10 +162,17 @@ remove_kernel() {
         rm -f -- "${filelist[@]}"
     ) || return
     # remove the preset
-    process_preset "$pkgbase" "$preset"
+    remove_preset "$pkgbase" "$preset"
 }
 
 while read -r line; do
+    if [[ "${line%%-git}" == "mkinitcpio" && "$1" == "install" ]]; then
+        # generate presets for each kernel on package install
+        generate_presets
+        package=1
+        continue
+    fi
+
     if [[ "$line" != */vmlinuz ]]; then
         # triggers when it's a change to usr/lib/initcpio/*
         package=1

Which is before we define KERNELBASE value. Hence the value is empty.

3 Likes

@scarwire and @pheiduck please check if it is fixed now: [pkg-upd] 39-6 (b78889ad) 路 Commits 路 Packages / Core / mkinitcpio 路 GitLab

Just built the package and installed it, and got the same result with missing version numbers:

(4/6) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux66.preset: 'default'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz- -g /boot/initramfs-.img
==> Starting build: '6.6.30-2-MANJARO'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [kms]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [plymouth]
  -> Running build hook: [encrypt]
  -> Running build hook: [openswap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: '/boot/initramfs-.img'
  -> Early uncompressed CPIO image generation successful
==> Initcpio image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux66.preset: 'fallback'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz- -g /boot/initramfs--fallback.img -S autodetect
==> Starting build: '6.6.30-2-MANJARO'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [kms]
==> WARNING: Possibly missing firmware for module: 'ast'
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'aic94xx'
==> WARNING: Possibly missing firmware for module: 'bfa'
==> WARNING: Possibly missing firmware for module: 'qed'
==> WARNING: Possibly missing firmware for module: 'qla1280'
==> WARNING: Possibly missing firmware for module: 'qla2xxx'
==> WARNING: Possibly missing firmware for module: 'wd719x'
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [plymouth]
  -> Running build hook: [encrypt]
  -> Running build hook: [openswap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: '/boot/initramfs--fallback.img'
  -> Early uncompressed CPIO image generation successful
==> Initcpio image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux68.preset: 'default'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz- -g /boot/initramfs-.img
==> Starting build: '6.6.30-2-MANJARO'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [kms]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [plymouth]
  -> Running build hook: [encrypt]
  -> Running build hook: [openswap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: '/boot/initramfs-.img'
  -> Early uncompressed CPIO image generation successful
==> Initcpio image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux68.preset: 'fallback'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz- -g /boot/initramfs-.img -S autodetect
==> Starting build: '6.6.30-2-MANJARO'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [kms]
==> WARNING: Possibly missing firmware for module: 'ast'
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'aic94xx'
==> WARNING: Possibly missing firmware for module: 'bfa'
==> WARNING: Possibly missing firmware for module: 'qed'
==> WARNING: Possibly missing firmware for module: 'qla1280'
==> WARNING: Possibly missing firmware for module: 'qla2xxx'
==> WARNING: Possibly missing firmware for module: 'wd719x'
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [plymouth]
  -> Running build hook: [encrypt]
  -> Running build hook: [openswap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: '/boot/initramfs-.img'
  -> Early uncompressed CPIO image generation successful
==> Initcpio image generation successful
> ls /boot/
efi/   initramfs--fallback.img  intel-ucode.img      linux68-x86_64.kver  vmlinuz-
grub/  initramfs-.img           linux66-x86_64.kver  memtest86+/

Or am I still missing something?

Also, this may not be helpful, but I just noticed that even when I explicitly run sudo mkinitcpio -p linux68, it鈥檚 still building the image for linux 6.6:

==> Starting build: '6.6.30-2-MANJARO'

i get a complete different error now:

==> Building image from preset: /etc/mkinitcpio.d/linux66.preset: 'default'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-6.6-x86_64 -g /boot/initramfs-6.6-x86_64.img
==> ERROR: '/lib/modules/6.6.30-2-MANJARO' is not a valid kernel module directory
==> Building image from preset: /etc/mkinitcpio.d/linux66.preset: 'fallback'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-6.6-x86_64 -g /boot/initramfs-6.6-x86_64-fallback.img -S autodetect
==> ERROR: '/lib/modules/6.6.30-2-MANJARO' is not a valid kernel module directory
==> Building image from preset: /etc/mkinitcpio.d/linux68.preset: 'default'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-6.8-x86_64 -g /boot/initramfs-6.8-x86_64.img
==> Starting build: '6.8.9-3-MANJARO'
  -> Running build hook: [plymouth]
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [microcode]
  -> Running build hook: [modconf]
  -> Running build hook: [kms]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: '/boot/initramfs-6.8-x86_64.img'
  -> Early uncompressed CPIO image generation successful
==> Initcpio image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux68.preset: 'fallback'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-6.8-x86_64 -g /boot/initramfs-6.8-x86_64-fallback.img -S autodetect
==> Starting build: '6.8.9-3-MANJARO'
  -> Running build hook: [plymouth]
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [microcode]
  -> Running build hook: [modconf]
  -> Running build hook: [kms]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: '/boot/initramfs-6.8-x86_64-fallback.img'
  -> Early uncompressed CPIO image generation successful
==> Initcpio image generation successful
Fehler: Befehl konnte nicht korrekt ausgef眉hrt werden

Solved by reinstall of linux66

Is solving the issue on my side good job @philm :+1:

$ ls | sort
amd-ucode.img
grub
initramfs-6.6-x86_64-fallback.img
initramfs-6.6-x86_64.img
initramfs-6.8-x86_64-fallback.img
initramfs-6.8-x86_64.img
intel-ucode.img
linux66-x86_64.kver
linux68-x86_64.kver
memtest86+
vmlinuz-6.6-x86_64
vmlinuz-6.8-x86_64

Reinstalling linux68 and linux66 hasn鈥檛 done anything for me, even after deleting linux66.preset and linux68.preset in /etc/mkinitcpio.d/.

Ensure you have mkinitcpio 39-6

Yes, I cloned the git commit sent by @philm and ran makepkg -si. Even after a reboot, mkinitcpio -P produces images without any version numbers.

@scarwire can you try the package from a repo and try that so we test the same build? I will try to install another kernel on my end and try more stuff. If you still have issues we can add some debug lines to the script.

Just installed 39-6 from the repo, deleted the preset files, and reinstalled linux66. Still no version number on the image that was generated. Also the newly generated preset file is clearly picking up an empty kernelbase variable:

# mkinitcpio preset file for the '' package

#ALL_config="/etc/mkinitcpio.conf"
ALL_kver="/boot/vmlinuz-"

PRESETS=('default' 'fallback')

#default_config="/etc/mkinitcpio.conf"
default_image="/boot/initramfs-.img"
#default_uki="/efi/EFI/Linux/manjaro-.efi"
#default_options="--splash /usr/share/systemd/bootctl/splash-manjaro.bmp"

#fallback_config="/etc/mkinitcpio.conf"
fallback_image="/boot/initramfs--fallback.img"
#fallback_uki="/efi/EFI/Linux/manjaro--fallback.efi"
fallback_options="-S autodetect"

If there鈥檚 any way you can help me get more verbose output that would be great!

Thanks again

How do you reinstalled the kernel? With pacman -Syu or mhwd-kernel?

But last will only work when you boot into a different kernel.

I鈥檝e tried both! No luck with either one.

Not sure if this is relevant but my vm is in bios mode. Maybe EFI behavior is different.

Yes but it鈥檚 not obsolete. If it will become this state I will switch to kernel-modules-hook

There are no ISO profiles that contain it. Where you鈥檙e seeing it is commented out. :wink:

Yes, it is. It caused more problems than it solved and is no longer developed.

You should鈥

:wink:

I seem to be able to replicate lacking of version number in the filename on an unstable gnome vm with EUFI. Output of the first time installation of linux69 & installation of linux61after removing the linux61 kernel (with a edited preset without fallback)

installing linux69 results
sudo mhwd-kernel --install linux69                       \ue0b2 \u2714 \ue0b2 8s \uf252 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 multilib is up to date
resolving dependencies...
looking for conflicting packages...

Packages (1) linux69-6.9.0rc7-1

Total Installed Size:  139,49 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                     [######################] 100%
(1/1) checking package integrity                   [######################] 100%
(1/1) loading package files                        [######################] 100%
(1/1) checking for file conflicts                  [######################] 100%
(1/1) checking available disk space                [######################] 100%
:: Processing package changes...
(1/1) installing linux69                           [######################] 100%
Optional dependencies for linux69
    wireless-regdb: to set the correct wireless channels of your country
    [installed]
:: Running post-transaction hooks...
(1/4) Arming ConditionNeedsUpdate...
(2/4) Updating module dependencies...
(3/4) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux69.preset: 'default'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz- -g /boot/initramfs-.img
==> Starting build: '6.9.0-rc7-1-MANJARO'
  -> Running build hook: [systemd]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [kms]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [sd-vconsole]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: '/boot/initramfs-.img'
  -> Early uncompressed CPIO image generation successful
==> Initcpio image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux69.preset: 'fallback'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz- -g /boot/initramfs--fallback.img -S autodetect
==> Starting build: '6.9.0-rc7-1-MANJARO'
  -> Running build hook: [systemd]
  -> Running build hook: [modconf]
  -> Running build hook: [kms]
==> WARNING: Possibly missing firmware for module: 'ast'
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'qed'
==> WARNING: Possibly missing firmware for module: 'qla2xxx'
==> WARNING: Possibly missing firmware for module: 'aic94xx'
==> WARNING: Possibly missing firmware for module: 'bfa'
==> WARNING: Possibly missing firmware for module: 'wd719x'
==> WARNING: Possibly missing firmware for module: 'qla1280'
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [sd-vconsole]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> WARNING: Possibly missing '/bin/sh' for script: /usr/bin/fsck.xfs
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: '/boot/initramfs--fallback.img'
  -> Early uncompressed CPIO image generation successful
==> Initcpio image generation successful
(4/4) Updating Grub-Bootmenu
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-
Found initrd image: /boot/amd-ucode.img /boot/initramfs-.img
Found initrd fallback image: /boot/initramfs--fallback.img
Found linux image: /boot/vmlinuz-6.8-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-6.8-x86_64.img
Found linux image: /boot/vmlinuz-6.1-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-6.1-x86_64.img
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Adding boot menu entry for UEFI Firmware Settings ...
done


ls /boot -l                                                    
total 181720
-rw-r--r-- 1 root root     81920  4 mei 00:15 amd-ucode.img
drwx------ 3 root root      4096  1 jan  1970 efi
drwxr-xr-x 6 root root      4096 12 mei 19:31 grub
-rw------- 1 root root  11298565 12 mei 19:30 initramfs-6.1-x86_64.img
-rw------- 1 root root  11175172 12 mei 19:30 initramfs-6.8-x86_64.img
-rw------- 1 root root 114389927 12 mei 19:31 initramfs--fallback.img
-rw------- 1 root root  11175195 12 mei 19:31 initramfs-.img
-rw-r--r-- 1 root root        21  3 mei 05:58 linux61-x86_64.kver
-rw-r--r-- 1 root root        20  9 mei 19:01 linux68-x86_64.kver
-rw-r--r-- 1 root root        23  6 mei 04:47 linux69-x86_64.kver
-rw-r--r-- 1 root root  13197824 12 mei 19:30 vmlinuz-
-rw-r--r-- 1 root root  11670016 12 mei 19:25 vmlinuz-6.1-x86_64
-rw-r--r-- 1 root root  13050368 12 mei 19:25 vmlinuz-6.8-x86_64
installing linux61 results
sudo mhwd-kernel --install linux61                         
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 multilib is up to date
resolving dependencies...
looking for conflicting packages...

Packages (1) linux61-6.1.90-1

Total Installed Size:  143,42 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                     [######################] 100%
(1/1) checking package integrity                   [######################] 100%
(1/1) loading package files                        [######################] 100%
(1/1) checking for file conflicts                  [######################] 100%
(1/1) checking available disk space                [######################] 100%
:: Processing package changes...
(1/1) installing linux61                           [######################] 100%
Optional dependencies for linux61
    wireless-regdb: to set the correct wireless channels of your country
    [installed]
:: Running post-transaction hooks...
(1/4) Arming ConditionNeedsUpdate...
(2/4) Updating module dependencies...
(3/4) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux61.preset: 'default'
==> Using default configuration file: '/etc/mkinitcpio.conf'
==> WARNING: Deprecated option 'ALL_microcode' found. Update '/etc/mkinitcpio.d/linux61.preset' to use the 'microcode' hook instead.
  -> -k /boot/vmlinuz-6.1-x86_64 -g /boot/initramfs-6.1-x86_64.img
==> Starting build: '6.1.90-1-MANJARO'
  -> Running build hook: [systemd]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [kms]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [sd-vconsole]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: '/boot/initramfs-6.1-x86_64.img'
  -> Early uncompressed CPIO image generation successful
==> Initcpio image generation successful
(4/4) Updating Grub-Bootmenu
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-
Found initrd image: /boot/amd-ucode.img /boot/initramfs-.img
Found initrd fallback image: /boot/initramfs--fallback.img
Found linux image: /boot/vmlinuz-6.8-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-6.8-x86_64.img
Found linux image: /boot/vmlinuz-6.1-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-6.1-x86_64.img
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Adding boot menu entry for UEFI Firmware Settings ...
done


ls /boot -l                                          

total 181720
-rw-r--r-- 1 root root     81920  4 mei 00:15 amd-ucode.img
drwx------ 3 root root      4096  1 jan  1970 efi
drwxr-xr-x 6 root root      4096 12 mei 19:34 grub
-rw------- 1 root root  11298565 12 mei 19:34 initramfs-6.1-x86_64.img
-rw------- 1 root root  11175172 12 mei 19:30 initramfs-6.8-x86_64.img
-rw------- 1 root root 114389927 12 mei 19:31 initramfs--fallback.img
-rw------- 1 root root  11175195 12 mei 19:31 initramfs-.img
-rw-r--r-- 1 root root        21  3 mei 05:58 linux61-x86_64.kver
-rw-r--r-- 1 root root        20  9 mei 19:01 linux68-x86_64.kver
-rw-r--r-- 1 root root        23  6 mei 04:47 linux69-x86_64.kver
-rw-r--r-- 1 root root  13197824 12 mei 19:30 vmlinuz-
-rw-r--r-- 1 root root  11670016 12 mei 19:34 vmlinuz-6.1-x86_64
-rw-r--r-- 1 root root  13050368 12 mei 19:25 vmlinuz-6.8-x86_64
system details
inxi -Fazi                                                                                                                                 \ue0b2 \u2714 
System:
  Kernel: 6.8.8-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: kvm-clock avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.8-x86_64
    root=UUID=29304a65-1f4d-48f7-8b15-f6a6cdfe5187 rw
  Desktop: GNOME v: 46.1 tk: GTK v: 3.24.41 wm: gnome-shell
    tools: gsd-screensaver-proxy dm: GDM v: 46.0 Distro: Manjaro
    base: Arch Linux
Machine:
  Type: Kvm System: QEMU product: Standard PC (Q35 + ICH9, 2009) v: pc-q35-7.2
    serial: <superuser required> Chassis: type: 1 v: pc-q35-7.2
    serial: <superuser required>
  Mobo: N/A model: N/A serial: N/A uuid: <superuser required> UEFI: EDK II
    v: N/A date: 2/2/2022
CPU:
  Info: model: AMD Ryzen 5 3600 bits: 64 type: SMP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 6x cores: 1 smt: <unsupported> cache:
    L1: 6x 128 KiB (768 KiB) desc: d-1x64 KiB; i-1x64 KiB L2: 6x 512 KiB (3 MiB)
    desc: 1x512 KiB L3: 6x 16 MiB (96 MiB) desc: 1x16 MiB
  Speed (MHz): avg: 3593 min/max: N/A cores: 1: 3593 2: 3593 3: 3593 4: 3593
    5: 3593 6: 3593 bogomips: 43139
  Flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT disabled
  Type: spec_rstack_overflow status: Vulnerable: Safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines; IBPB: conditional; STIBP:
    disabled; RSB filling; PBRSB-eIBRS: Not affected; BHI: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Red Hat Virtio 1.0 GPU driver: virtio-pci v: N/A ports:
    active: Virtual-1 empty: none bus-ID: 00:01.0 chip-ID: 1af4:1050
    class-ID: 0300
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 23.2.6
    compositor: gnome-shell driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: virtio_gpu gpu: virtio-pci display-ID: 0
  Monitor-1: Virtual-1 model: QEMU Monitor built: 2014 res: 3440x1300
    dpi: 109 gamma: 1.2 size: 800x297mm (31.5x11.69") diag: 851mm (33.5") modes:
    max: 3440x1300 min: 640x480
  API: EGL v: 1.5 platforms: device: 0 egl: 1.4 drv: virtio_gpu device: 1
    drv: swrast surfaceless: egl: 1.4 drv: virtio_gpu wayland: egl: 1.4
    drv: virtio_gpu x11: egl: 1.4 drv: virtio_gpu inactive: gbm
  API: OpenGL v: 4.5 compat-v: 4.3 vendor: mesa v: 24.0.6-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: virgl (AMD Radeon RX 6600 (radeonsi
    navi23 LLVM 17.0.6 D...) device-ID: 1af4:1010 memory: 7.81 TiB
    unified: yes display-ID: :0.0
Audio:
  Device-1: Intel 82801I HD Audio vendor: Red Hat QEMU Virtual Machine
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:293e
    class-ID: 0403
  API: ALSA v: k6.8.8-2-MANJARO status: kernel-api tools: N/A
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Red Hat Virtio 1.0 network driver: virtio-pci v: N/A pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 01:00.0 chip-ID: 1af4:1041
    class-ID: 0200
  IF-ID-1: enp1s0 state: up speed: -1 duplex: unknown mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  WAN IP: <filter>
Drives:
  Local Storage: total: 50 GiB used: 12.17 GiB (24.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/vda maj-min: 254:0 model: N/A size: 50 GiB block-size:
    physical: 512 B logical: 512 B speed: <unknown> tech: N/A serial: N/A
    scheme: GPT
Partition:
  ID-1: / raw-size: 49.7 GiB size: 48.62 GiB (97.82%) used: 12.17 GiB (25.0%)
    fs: ext4 dev: /dev/vda2 maj-min: 254:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/vda1 maj-min: 254:1
Swap:
  Alert: No swap data was found.
Sensors:
  Src: lm-sensors+/sys Message: No sensor data found using /sys/class/hwmon
    or lm-sensors.
Info:
  Memory: total: 4 GiB available: 3.81 GiB used: 1.21 GiB (31.8%)
  Processes: 251 Power: uptime: 17m states: freeze,mem,disk suspend: s2idle
    wakeups: 0 hibernate: shutdown avail: reboot,suspend,test_resume
    image: 1.52 GiB services: gsd-power,upowerd Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 896 libs: 260 tools: gnome-software,pamac
    Compilers: clang: 17.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9
    running-in: gnome-terminal inxi: 3.3.34
Name                  : mkinitcpio
Version               : 39-6

Okay, but it is contained in the repo. I noticed when packages get removed from repo there are appear in pacman -Qm

I remove these packages if I have not installed them myself (AUR).

But I install it on my systems as soon as kernel-alive get removed to don鈥檛 mess up things

regarding mkinitcpio 鈥 has anyone checked the contents of:
/usr/share/mkinitcpio/hook.preset of the effected vm鈥檚?

Yes.


Just because something is in the repos does not mean you should have it installed. But its your system.

It seems it was not the source of this issue though.


I do find it interesting that most (if not all?) of the reported issues are in VM.

Pacnews may be another thing?

pacdiff -o
1 Like