Mixxx >= 2.2.2-2 No more sound with file.m4a

Hi .
Since update to mixxx-2.2.2-2, any files with m4a extension are recognized but no sound . Other files such .opus, .ogg or .mp3 work fine . I tried the arch package mixxx-2.2.2-3 on kernel 4.19, 5.3 and 5.4 with the same result.
Here is the terminal return:

[steph@steph-pc ~]$ mixxx &
[1] 1021
[steph@steph-pc ~]$ Warning [Main]: Configuration file is at version "2.1.1" instead of the current 2.2.2
error: failed to expand CURIE `xsd:float'
ALSA lib pcm.c:2564:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2564:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2564:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_route.c:869:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_route.c:869:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_route.c:869:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_route.c:869:(find_matching_chmap) Found no matching channel map
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=Aucun fichier ou dossier de ce type)
attempt to connect to server failed
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=Aucun fichier ou dossier de ce type)
attempt to connect to server failed
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=Aucun fichier ou dossier de ce type)
attempt to connect to server failed
Warning [Controller]: USB permissions problem (or device error.) Your account needs write access to USB HID controllers.
Warning [Controller]: USB permissions problem (or device error.) Your account needs write access to USB HID controllers.
Warning [CachingReaderWorker 1]: SoundSourceM4A - Unable to determine the fixed sample duration of track 1 in file "file:///home/steph/Musique/Disco/Zouk Machine - Maldon _ La Compagnie Créole - C'est bon pour le moral-TzRiye09xRg.m4a"
Warning [CachingReaderWorker 1]: SoundSourceProxy - Unable to open file "file:///home/steph/Musique/Disco/Zouk Machine - Maldon _ La Compagnie Créole - C'est bon pour le moral-TzRiye09xRg.m4a" with provider "Nero FAAD2" using mode Strict
Warning [CachingReaderWorker 1]: SoundSourceM4A - Unable to determine the fixed sample duration of track 1 in file "file:///home/steph/Musique/Disco/Zouk Machine - Maldon _ La Compagnie Créole - C'est bon pour le moral-TzRiye09xRg.m4a"
Warning [CachingReaderWorker 1]: SoundSourceM4A - Fallback: Using a default sample duration of 1024 sample frames per block
Warning [CachingReaderWorker 1]: SoundSourceM4A - AAC decoding error: 21 Unexpected channel configuration change "file:///home/steph/Musique/Disco/Zouk Machine - Maldon _ La Compagnie Créole - C'est bon pour le moral-TzRiye09xRg.m4a"
Warning [CachingReaderWorker 1]: CachingReaderWorker - Failed to read chunk samples for frame index range: actual = [0 -> 0) , expected = [0 -> 8192)
Warning [CachingReaderWorker 1]: CachingReaderWorker - Readable frames in audio source reduced to [0 -> 0) from originally [0 -> 15476736)
Warning [Main]: QPixmap::scaled: Pixmap is a null pixmap
Warning [Main]: QPixmap::scaled: Pixmap is a null pixmap
Warning [Main]: QPixmap::scaled: Pixmap is a null pixmap
Warning [Main]: QPixmap::scaled: Pixmap is a null pixmap
Warning [Main]: QPixmap::scaled: Pixmap is a null pixmap
Warning [Main]: QPixmap::scaled: Pixmap is a null pixmap
Warning [AnalyzerQueue 1]: SoundSourceM4A - Unable to determine the fixed sample duration of track 1 in file "file:///home/steph/Musique/Disco/Zouk Machine - Maldon _ La Compagnie Créole - C'est bon pour le moral-TzRiye09xRg.m4a"
Warning [AnalyzerQueue 1]: SoundSourceProxy - Unable to open file "file:///home/steph/Musique/Disco/Zouk Machine - Maldon _ La Compagnie Créole - C'est bon pour le moral-TzRiye09xRg.m4a" with provider "Nero FAAD2" using mode Strict
Warning [AnalyzerQueue 1]: SoundSourceM4A - Unable to determine the fixed sample duration of track 1 in file "file:///home/steph/Musique/Disco/Zouk Machine - Maldon _ La Compagnie Créole - C'est bon pour le moral-TzRiye09xRg.m4a"
Warning [AnalyzerQueue 1]: SoundSourceM4A - Fallback: Using a default sample duration of 1024 sample frames per block
Warning [Main]: QPixmap::scaled: Pixmap is a null pixmap
Warning [Main]: QPixmap::scaled: Pixmap is a null pixmap
Warning [Main]: QPixmap::scaled: Pixmap is a null pixmap
Warning [Main]: QPixmap::scaled: Pixmap is a null pixmap
Warning [Main]: QPixmap::scaled: Pixmap is a null pixmap
Warning [Main]: QPixmap::scaled: Pixmap is a null pixmap
Warning [LibraryScanner 1]: QSqlDatabasePrivate::removeDatabase: connection 'MIXXX-2' is still in use, all queries will cease to work.


I tried other files.m4a too
Unable to downgrade mixxx from cache due to a pixbuf version conflict.
Any idea ?

And did you backup/delete that 2.1.1 config file and let the 2.2.2 to generate a new one ?

I don't know were this configuration file is. I did find nothing in /etc and I did try with a brand knew profile into ~/
Here is the result of pacman -Ql mixxx : I did cut many lines into skin/ and tranlation/ cause that was too heavy to post here.

Résumé

mixxx /usr/
mixxx /usr/bin/
mixxx /usr/bin/mixxx
mixxx /usr/lib/
mixxx /usr/lib/mixxx/
mixxx /usr/lib/mixxx/plugins/
mixxx /usr/lib/mixxx/plugins/soundsourceqt5/
mixxx /usr/lib/mixxx/plugins/soundsourceqt5/libsoundsourcem4a.so
mixxx /usr/lib/mixxx/plugins/soundsourceqt5/libsoundsourcewv.so
mixxx /usr/lib/mixxx/plugins/vampqt5/
mixxx /usr/lib/mixxx/plugins/vampqt5/libmixxxminimal.so
mixxx /usr/share/
mixxx /usr/share/appdata/
mixxx /usr/share/appdata/mixxx.appdata.xml
mixxx /usr/share/applications/
mixxx /usr/share/applications/mixxx.desktop
mixxx /usr/share/doc/
mixxx /usr/share/doc/mixxx/
mixxx /usr/share/doc/mixxx/LICENSE
mixxx /usr/share/doc/mixxx/Mixxx-Manual.pdf
mixxx /usr/share/doc/mixxx/README
mixxx /usr/share/mixxx/
mixxx /usr/share/mixxx/controllers/
mixxx /usr/share/mixxx/controllers/Akai MPD24.midi.xml
......
......
mixxx /usr/share/mixxx/controllers/us428.midi.xml
mixxx /usr/share/mixxx/fonts/
mixxx /usr/share/mixxx/fonts/OpenSans-Regular.ttf
mixxx /usr/share/mixxx/fonts/OpenSans.LICENSE.txt
mixxx /usr/share/mixxx/fonts/Ubuntu-B.ttf
mixxx /usr/share/mixxx/fonts/Ubuntu-R.ttf
mixxx /usr/share/mixxx/fonts/Ubuntu.LICENCE.txt
mixxx /usr/share/mixxx/keyboard/
mixxx /usr/share/mixxx/keyboard/cs_CZ.kbd.cfg
mixxx /usr/share/mixxx/keyboard/da_DK.kbd.cfg
mixxx /usr/share/mixxx/keyboard/de_CH.kbd.cfg
mixxx /usr/share/mixxx/keyboard/de_DE.kbd.cfg
mixxx /usr/share/mixxx/keyboard/el_GR.kbd.cfg
mixxx /usr/share/mixxx/keyboard/en_US.kbd.cfg
mixxx /usr/share/mixxx/keyboard/es_ES.kbd.cfg
mixxx /usr/share/mixxx/keyboard/fi_FI.kbd.cfg
mixxx /usr/share/mixxx/keyboard/fr_CH.kbd.cfg
mixxx /usr/share/mixxx/keyboard/fr_FR.kbd.cfg
mixxx /usr/share/mixxx/keyboard/it_IT.kbd.cfg
mixxx /usr/share/mixxx/keyboard/ru_RU.kbd.cfg
mixxx /usr/share/mixxx/skins/
mixxx /usr/share/mixxx/skins/Deere (64 Samplers)/

.......
.......
mixxx /usr/share/mixxx/skins/Tango/waveforms_container.xml
.......
.......
mixxx /usr/share/mixxx/translations/mixxx_zh_TW.qm
mixxx /usr/share/pixmaps/
mixxx /usr/share/pixmaps/mixxx_icon.svg

Edit:

On Linux, AAC playback is disabled by default due to licensing restrictions. To enable the playback of AAC files, build Mixxx from source with m4a/AAC files support.
.....

Optional: Build with m4a/AAC file support

If you want to play m4a files, add faad=1 to your scons commands above. This requires the libraries faad2 and libmp4v2 (or libmp4) to be installed.

This option is in the PKGBUILD:

build() {
  cd "${pkgname}-${pkgver}"
  export SCONSFLAGS="-j $(nproc)"
  scons prefix=/usr \
        build=release \
        faad=1 \
        modplug=1 \
        perftools=1 \
        perftools_profiler=1 \
        qt_sqlite_plugin=0 \
        qtkeychain=1 \
        test=1 \
        target=linux \
        virtualize=0 \
        wv=1

Here is the answer from a mixxx dev:

The message "No AAC track found" appears if MP4v2 is not able to find an AAC audio stream in the MP4 container. This is a libmp4v2 issue and not a Mixxx issue. The MP4v2 code in Mixxx has not been modified and works as expected on all other Linux platforms.

Please note that MP4v2 has been removed from Debian Buster: https://bugs.launchpad.net/mixxx/+bug/1842208

I'm not aware of the current situation for Manjaro.

Fedora is not affected yet. The current RPM Fusion build 2.2.2-4 works as expected.

Uwe Klotz (uklotzde) wrote 15 hours ago: #5

This version is confirmed to work:

Name : libmp4v2
Version : 2.1.0
Release : 0.19.trunkREV507.fc31
Architecture : x86_64
Size : 1.9 M
Source : libmp4v2-2.1.0-0.19.trunkREV507.fc31.src.rpm

The library libmp4v2 2.0.0-5 is out-of-date since ...2012.
So how replace link to libmp4v2 while compiling mixxx and why others players can still read file.m4a ?
Should I compile on my own from libmp4v2-2.1.0-0.19.trunkREV507.fc31.src.rpm ?

Well, I took some time to snoop around. I tried many unsuccessful things, then I decided to recompile from the Archlinux PKGBUILD by adding ffmpeg=1 \ in the build() scons parameters under faad= 1.
Very long compilation, but I can now read the.m4a files.

Hi!
mixxx 2.2.3-1 into Arch repo with ffmpeg=1\ option works now perfectly with protobuf 3.11.1-2 .
Please update mixxx as soon as possible.

2.2.3-1 is already in testing (which you seem to use according to your profile), see http://manjaro32.org/repo-compare/community.html.

Ok
I did saw the protobuf update but not the mixxx update .
I didn't saw it cause I still have the Arch package with same version.
Mixxx of course did not appears in the last update list of packages provide by pacman.
My bad, I can see mixxx in the overlay package(s) in repository community x86_64

Thanks

I have with mixxx version 2.2.3 the same problem. In the package version 2.2.3 m4a support is enabled, but the tracks are not loading.

This is the error:

Warning [CachingReaderWorker 1]: SoundSourceM4A - AAC decoding error: 21 Unexpected channel configuration change "file:///home/wolfgang/Musik/Charts/Charts 2000/38 I'm Outta Love.m4a"
Warning [CachingReaderWorker 1]: CachingReaderWorker - "[Channel1]" Failed to read chunk samples for frame index range: actual = [0 -> 0) , expected = [0 -> 8192)
Warning [CachingReaderWorker 1]: CachingReaderWorker - Readable frames in audio source reduced to [0 -> 0) from originally [0 -> 10708992)
Warning [AnalyzerQueue 1]: SoundSourceM4A - AAC decoding error: 21 Unexpected channel configuration change "file:///home/wolfgang/Musik/Charts/Charts 2000/38 I'm Outta Love.m4a"
Warning [AnalyzerQueue 1]: AnalyzerQueue - Aborting analysis after failed to read sample data from "/home/wolfgang/Musik/Charts/Charts 2000/38 I'm Outta Love.m4a" : expected frames = [0 -> 4096) , actual frames = [0 -> 0)

So it's very bad for me, because manjaro is a very good system for my dj jobs, i have been gone back to ubuntu LTS, but it isn't so performant like manjaro :expressionless:

There are two solutions:
The package have to be support m4a with ffmepg
or
The package have to be no support for m4a,

the current state is more than unfavourable

Hi.
I confirm that mixxx-2.2.3-1 works fine with .mp4 files.
Try to rebuild yourself from PKGBUILD with makepkg -si
Long work but that did the job for me.

Forum kindly sponsored by