Mixing incompatible Qt library (5.15.8) with (5.15.9)

Application Style: seems to be mixing incompatible Qt library (5.15.8) with (5.15.9)

kcmshell5 kcm_style                         ✔   4s   8:58:14 am +07 
Cannot mix incompatible Qt library (5.15.8) with this library (5.15.9)
23 -- exe=/usr/bin/kcmshell5
13 -- platform=xcb
11 -- display=:0
18 -- appname=kcmshell5
17 -- apppath=/usr/bin
9 -- signal=6
10 -- pid=10101
18 -- appversion=5.27.4
35 -- programname=System Settings Module
31 -- bugaddress=submit@bugs.kde.org
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kcmshell5 path = /usr/bin pid = 10101
KCrash: Arguments: /usr/bin/kcmshell5 kcm_style 
KCrash: Attempting to start /usr/lib/drkonqi
fish: Job 1, 'kcmshell5 kcm_style' has stopped

I’ve just tested our latest 22.1.1 ISO of Plasma Edition and it worked as it should. Most likely you may have some installed from the AUR installed, which may need a rebuild due to Qt5 update. You can check via dependency-checker qt5-base or install rebuild-detector to see what is missing on your end.

I just gave that cmd a run on a fresh 22.1.1, which includes this update. I was able to open KCM Style normally. Hence check if you have added some package from the AUR which does your theming and might need a rebuild for qt5 as mentioned earlier @Ben

1 Like


That didn’t help - rebuild-detector brought up nothing, but I figured I’d look at qt5-base.

yay qt5-base - only one version installed, selected to reinstall and got a warning. that qt5-styleplugins needed rebuilding.

Settings works now, Thank you.

I don’t know that package qt5-plugins. Was it once in the AUR?


Sorry :mushroom:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.