Missing sound on Asus Rog Strix G713PV after update from Kernel 6.6.0 to 6.6.1 and 6.6.2


first of all: great job for fixing a problem which I had with the sound on my Asus Rog Strix G713PV 2023 laptop. I found this discussion

and tried the October image which made my soundcard/amplifier work immediately. Alas, after an update last week and just now, the soundcard can’t be found anymore.

I could revert the update thanks to timeshift but not updating somehow is no solution. Just wanted to ask: are the patches not included or is there something I missed?

Kind regards


Can you post some information ?
inxi -Fza.

1 Like

I’d love to but the forum software tells me, there’s a link in it which I must not post. Can’t find anything.

New users are not allowed to post active links, to prevent spamming and trolling

But inactive links can be posted in pre-formatted text (using </> or Ctrl + E)

1 Like
  Kernel: 6.6.0-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.6-x86_64
    root=UUID=58c13a9b-4d41-4637-9b43-23aa24fc64af rw rootflags=subvol=@
    quiet splash udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: ROG Strix G713PV_G713PV v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: G713PV v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: G713PV.327 date: 08/23/2023
  ID-1: BAT0 charge: 86.1 Wh (100.0%) condition: 86.1/90.0 Wh (95.7%)
    volts: 17.3 min: 15.9 model: AS3GWAF3KC GA50358 type: Unknown
    serial: <filter> status: full
  Info: model: AMD Ryzen 9 7845HX with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 4 gen: 5 level: v4 note: check built: 2022+ process: TSMC n5 (5nm)
    family: 0x19 (25) model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
  Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
    L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 12 MiB desc: 12x1024 KiB
    L3: 64 MiB desc: 2x32 MiB
  Speed (MHz): avg: 4152 high: 5239 min/max: 400/5298 scaling:
    driver: amd-pstate-epp governor: performance cores: 1: 5236 2: 5239 3: 5121
    4: 5235 5: 5215 6: 5238 7: 5010 8: 4876 9: 5063 10: 5049 11: 5063 12: 5055
    13: 5239 14: 5237 15: 5237 16: 400 17: 5212 18: 5234 19: 400 20: 5046
    21: 5050 22: 400 23: 400 24: 400 bogomips: 143789
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow mitigation: safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB:
    conditional, STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA AD107M [GeForce RTX 4060 Max-Q / Mobile] vendor: ASUSTeK
    driver: nvidia v: 535.129.03 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2023-11) arch: Lovelace code: AD1xx
    process: TSMC n4 (5nm) built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 8
    ports: active: none empty: DP-1, DP-2, HDMI-A-1, eDP-1 bus-ID: 01:00.0
    chip-ID: 10de:28e0 class-ID: 0300
  Device-2: AMD Raphael vendor: ASUSTeK driver: amdgpu v: kernel
    arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
    gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-2 empty: DP-3,DP-4,DP-5
    bus-ID: 08:00.0 chip-ID: 1002:164e class-ID: 0300 temp: 75.0 C
  Device-3: IMC Networks [] driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1:2 chip-ID: 13d3:5458
    class-ID: fe01 serial: <filter>
  Display: x11 server: </X.Org> v: 21.1.9 compositor: kwin_x11 driver: X:
    loaded: amdgpu,nvidia unloaded: modesetting,nouveau,radeon
    alternate: fbdev,nv,vesa dri: radeonsi gpu: amdgpu display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
    s-diag: 777mm (30.58")
  Monitor-1: eDP-2 mapped: eDP-1 model: BOE Display NE173QHM-NZ2 built: 2022
    res: 2560x1440 hz: 240 dpi: 171 gamma: 1.2 size: 381x214mm (15x8.43")
    diag: 437mm (17.2") ratio: 16:9 modes: max: 2560x1440 min: 640x480
  API: EGL Message: No EGL data available.
  API: OpenGL v: 4.6 vendor: amd mesa v: 23.1.9-manjaro1.1 glx-v: 1.4
    es-v: 3.2 direct-render: yes renderer: AMD Radeon Graphics
    (raphael_mendocino LLVM 16.0.6 DRM 3.54 6.6.0-1-MANJARO)
    device-ID: 1002:164e memory: 500 MiB unified: no
  API: Vulkan v: 1.3.269 layers: 5 device: 0 type: discrete-gpu name: NVIDIA
    GeForce RTX 4060 Laptop GPU driver: nvidia v: 535.129.03
    device-ID: 10de:28e0 surfaces: xcb,xlib device: 1 type: integrated-gpu
    name: AMD Radeon Graphics (RADV RAPHAEL_MENDOCINO) driver: mesa radv
    v: 23.1.9-manjaro1.1 device-ID: 1002:164e surfaces: xcb,xlib
  Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:22be
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
    driver: snd_rpl_pci_acp6x v: kernel alternate: snd_pci_acp3x,
    snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci, snd_pci_ps,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt pcie: gen: 4 speed: 16 GT/s
    lanes: 16 bus-ID: 08:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 08:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.6.0-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.83 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    vendor: Foxconn driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 04:00.0 chip-ID: 14c3:0616 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  Device-1: Foxconn / Hon Hai [] driver: btusb v: 0.8 type: USB rev: 2.1
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-2:3 chip-ID: 0489:e0f6
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 953.87 GiB used: 97.66 GiB (10.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2400 MTFDKBA1T0QFM
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: V3MA003 temp: 38.9 C
    scheme: GPT
  ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
    used: 97.66 GiB (10.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
    used: 97.66 GiB (10.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
    used: 97.66 GiB (10.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Alert: No swap data was found.
  System Temperatures: cpu: 83.1 C mobo: 38.0 C
  Fan Speeds (rpm): cpu: 3100
  Processes: 470 Uptime: 17m wakeups: 0 Memory: total: 16 GiB note: est.
  available: 14.84 GiB used: 4.17 GiB (28.1%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1265 pm: pacman pkgs: 1254 libs: 348 tools: pamac,yay pm: flatpak
  pkgs: 11 Shell: Zsh v: 5.9 running-in: konsole inxi: 3.3.31

nikgnomic: please use proper formatting: [HowTo] Post command output and file content as formatted text

Thanks, that did the trick. It was the </x.org> under Display. But how to remove a link which you never put in? :wink:

and here the alsa-info.sh-output:

Can you also post pacmd list-sinks ?

1 Like

Well. Those newer Asus laptops might not provide the needed info in BIOS. For example the ALLY did that with 323 the last time. Newer 33x BIOS versions fixed that. 6.5 and 6.6 kernel series I patch regarding that.

So check if any kernel worked for you and if which kernel broke it again. Else a BIOS update might have broke it.

Also read the asus linux project

1 Like

Please find the output below. Weirdly after I updated again (the 3rd time), The sound and the bluetooth worked. Will put the status on solved.

pacmd list-sinks                                                ✔  base    at 14:51:39   
1 sink(s) available.
  * index: 0
        name: <alsa_output.pci-0000_08_00.6.analog-stereo>
        driver: <module-alsa-card.c>
        state: SUSPENDED
        suspend cause: IDLE
        priority: 9039
        volume: front-left: 49152 /  75% / -7.50 dB,   front-right: 49152 /  75% / -7.50 dB
                balance 0.00
        base volume: 65536 / 100% / 0.00 dB
        volume steps: 65537
        muted: no
        current latency: 0.00 ms
        max request: 0 KiB
        max rewind: 0 KiB
        monitor source: 0
        sample spec: s16le 2ch 44100Hz
        channel map: front-left,front-right
        used by: 0
        linked by: 0
        configured latency: 0.00 ms; range is 0.50 .. 1999.82 ms
        card: 1 <alsa_card.pci-0000_08_00.6>
        module: 7
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
                alsa.name = "ALC294 Analog"
                alsa.id = "ALC294 Analog"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "0"
                alsa.card = "1"
                alsa.card_name = "HD-Audio Generic"
                alsa.long_card_name = "HD-Audio Generic at 0xfc5c0000 irq 111"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:08:00.6"
                sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:08:00.6/sound/card1"
                device.bus = "pci"
                device.vendor.id = "1022"
                device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
                device.product.id = "15e3"
                device.product.name = "Family 17h/19h HD Audio Controller"
                device.string = "front:1"
                device.buffering.buffer_size = "352768"
                device.buffering.fragment_size = "176384"
                device.access_mode = "mmap+timer"
                device.profile.name = "analog-stereo"
                device.profile.description = "Analog Stereo"
                device.description = "Family 17h/19h HD Audio Controller Analog Stereo"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
                analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
                                device.icon_name = "audio-speakers"
                analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
                                device.icon_name = "audio-headphones"
        active port: <analog-output-speaker>

Yes, I read that from you in the other thread. Unfortunately, there’s no updated BIOS, yet. I hope ASUS fixes this. They stated they fully support Linux but if such essential hardware info is missing, that statement has to be partially doubted.

The “problem” is I got the laptop quite cheap compared to others with that specs.

Luckily and thanks to your great work, it works now. No other distro does by now.

Many, many thanks to all of you. Happy to learn more about Manjaro.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.