Missing mouse settings?

I actually expected that it was. Rats. Ta anyway.

Is that a laptop or desktop pc pls?

Could you pls guide me how i would make a workable new file to do that? Looking at the post by @cscs, would it be something like:

 Section "InputClass"
    Identifier "mouse"
    Driver "synaptics"
options
options

https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Configuration

Just accessed my Lappy now… bad news, it also only has one file, the keyboard file, in that directory, yet its mouse has the full settings. Clearly i am barking up the wrong tree here.

Not necessarilly. I dont have a synaptics file either.
But synaptics may not be autoloading for you for some reason, which is why petsam suggested using xorg to ‘set’ it.

But awell.

Create a new file, i.e. 70-synaptics.conf and paste a Section in there. Save it and restart X.

Edit:
Example from Archwiki

Section "InputClass"
    Identifier "touchpad"
    Driver "synaptics"
    MatchIsTouchpad "on"
        Option "TapButton1" "1"
        Option "TapButton2" "3"
        Option "TapButton3" "2"
        Option "VertEdgeScroll" "on"
        Option "VertTwoFingerScroll" "on"
        Option "HorizEdgeScroll" "on"
        Option "HorizTwoFingerScroll" "on"
        Option "CircularScrolling" "on"
        Option "CircScrollTrigger" "2"
        Option "EmulateTwoFingerMinZ" "40"
        Option "EmulateTwoFingerMinW" "8"
        Option "CoastingSpeed" "0"
        Option "FingerLow" "30"
        Option "FingerHigh" "50"
        Option "MaxTapTime" "125"
        ...
EndSection

Ta for this. Only a quick glance so far, but it is focused on touchpads. My problem is the reverse… i need KDEs on pcs with only mouses/mice, to stop using libinput. Maybe when i have time later [i have to go away for an hour or two now] to read the link completely, i might glean a way to adapt it to my mouse scenario.

So if they are desktops and they have no touchpad … then yeah no synaptics will be loaded.
I could be wrong but this is still the likely root cause of why its missing the options in KDE settings.

Sorry for the edit @kdemeoz

but surely that is not relevant to my NON-laptop KDEs? Shouldn’t i replace that with, eg, “mouse”?

Change

MatchIsTouchpad "on"

to

MatchIsPointer "yes"

The Identifier name doesn’t matter. Driver and MatchIsSomething does.
You may want to check Xorg configs and the Wikis, to get some idea.
Mouse Accel, Mouse buttons, Xorg catch

Welcome to KDE Plasma. This is life on the leading-edge, where you get a much closer experience with Plasma (or GNOME, etc.) than you will with one more customized by it’s downstream developer.

You may not always like the results.

I’m on desktops only. One is testing, my main rig and has 3 tabs options for mouse. The other one is an experimental desktop on unstable, just the simple option in mouse settings. Checked on another unstable install VM and is the simple option too.

Summary from a long frustrating partial-day of unproductive experiments, aka… Adventures with /etc/X11/xorg.conf.d/70-synaptics_for_mouse.conf

  1. I created that new file by copying /usr/share/X11/xorg.conf.d/70-synaptics.conf, btw fyi whose default contents are:
Summary
# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
#
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
#       MatchDevicePath "/dev/input/event*"
EndSection

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"
EndSection

# This option enables the bottom right corner to be a right button on clickpads
# and the right and middle top areas to be right / middle buttons on clickpads
# with a top button area.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
        Option "SecondarySoftButtonAreas" "58% 0 0 15% 42% 58% 0 15%"
EndSection

# This option disables software buttons on Apple touchpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Disable clickpad buttons on Apple touchpads"
        MatchProduct "Apple|bcm5974"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
EndSection
  1. I renamed this copied file to /etc/X11/xorg.conf.d/70-synaptics_for_mouse.conf, due to reading this at the beginning of its default contents:
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
  1. I left all the original contents of this file unchanged, then appended the following verbatim per the Arch Wiki, except for the modification as per Missing mouse settings? :
Section "InputClass"
    Identifier "touchpad"
    Driver "synaptics"
    MatchIsPointer "yes"
        Option "TapButton1" "1"
        Option "TapButton2" "3"
        Option "TapButton3" "2"
        Option "VertEdgeScroll" "on"
        Option "VertTwoFingerScroll" "on"
        Option "HorizEdgeScroll" "on"
        Option "HorizTwoFingerScroll" "on"
        Option "CircularScrolling" "on"
        Option "CircScrollTrigger" "2"
        Option "EmulateTwoFingerMinZ" "40"
        Option "EmulateTwoFingerMinW" "8"
        Option "CoastingSpeed" "0"
        Option "FingerLow" "30"
        Option "FingerHigh" "50"
        Option "MaxTapTime" "125"
        ...
EndSection

The VM refused to boot after this. :frowning:

  1. I then modified the above appended text to be:
Section "InputClass"
    Identifier "touchpad"
    Driver "synaptics"
    MatchIsPointer "yes"
EndSection

This time the VM was happy to boot, & i could login to my plasmadesktop, & move the pointer, but all mouse button & wheel functions were non-existent. Nothing at all happened when i clicked the mouse buttons & wheel, or scrolled the wheel. :frowning:

  1. I repeated #3, but this time deleted those strange " …". Now the VM booted ok, & login was ok, but the instant i tried a mouse left-click the pointer vanished, & never returned. Sigh :frowning:

  2. I then repeated #4, but commented out those five lines. After reboot, normal mouse functions resumed, but [of course] the mouse settings in System Settings were still only the undesirable simplistic ones. Hence, a totally unproductive test. :frowning:

  3. Based on https://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html, in the original contents of /etc/X11/xorg.conf.d/70-synaptics.conf as copied from /usr/share/X11/xorg.conf.d/70-synaptics.conf , I uncommented the line # MatchDevicePath "/dev/input/event*", thus:

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
        MatchDevicePath "/dev/input/event*"
EndSection

This was done together with repeating #6. The VM booted & logged in ok, & the mouse was clickable & scrollable, but [of course] the mouse settings in System Settings were still only the undesirable simplistic ones. Hence, a totally unproductive test. :frowning:

  1. I repeated #7, but instead of blending it with #6 i blended it with #4. The result this time was boot ok, login ok, but NO pointer at all, hence of course also no clicks or scrolls. :frowning:

  2. This extract from https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Other_external_mouse_issues totally confuses me. The file it describes as needing editing [/etc/X11/xorg.conf.d/xorg.conf] does not exist at all here; i cannot edit what does not exist, & i can’t create a new file there because i don’t know what other information would have to be in it.

Other external mouse issues
First, make sure your section describing the external mouse contains this line (or that the line looks like this):

/etc/X11/xorg.conf.d/xorg.conf
Option     "Device" "/dev/input/mice"
If the "Device" line is different, change it to the above and try to restart X. If this does not solve your problem, make your touchpad is the CorePointer in the "Server Layout" section:

/etc/X11/xorg.conf.d/xorg.conf
InputDevice    "Touchpad" "CorePointer"
and make your external device "SendCoreEvents":

/etc/X11/xorg.conf.d/xorg.conf
InputDevice    "USB Mouse" "SendCoreEvents"
finally add this to your external device's section:

/etc/X11/xorg.conf.d/xorg.conf
Option      "SendCoreEvents"    "true"
  1. I don’t understand if i need to apply stuff from https://wiki.archlinux.org/index.php/Mouse_buttons . Also, this Wiki discusses xorg.conf, which as noted in #9 does not exist at all

I am certainly just flailing around in my puddle of ignorance here, & feel that there’s probably little point in me continuing just randomly trying my naive guesses.

You are doing an excelled job investigating Sherlock!
To help you understand about conf files:
whatever .conf is inside whatever.d/*.conf replaces/substitutes whatever.conf “taking” .d as directory/folder.
So, these whatever.d/*.conf are all added consecutively as one conf.
I hope it makes sense.

1 Like

“Surveying” the apparent status via the preceding posts [below, i also count VMs running on a desktop in the desktop column]:

Manjaro KDE Plasma 5.13.2 with Full Mouse Settings		
Manjaroo	Laptop	Desktop
@kdemeoz	1 / 1	0 / 3
@michaldybczak	0 / 1	
@petsam		0 / 1
@bogdancovaciu		1 / 3
@DeMus		0 / 1
@cscs	1 / 1	

Hmmm, that’s not very pretty, is it? Hence a supplementary pic:

20180710_004

I conclude these initial points:

  1. A laptop is not automatically a guarantee of having the Full settings.
  2. Something is super-duper-hyper-mega special about ONE of @bogdancovaciu 's desktops. Is this a fertile ground for deeper investigation?

Not sure is relevant, i have 2 desktops. Well, actually 3 but the mac i don’t use for quite some time now, and moved everything on my main tower - testing branch, where happens to have 8 VM on VBox, and i do all my work (KDE Plasma of course). Most of the VM’s are Manjaro on unstable, different DE’s and combinations of them for experimenting purposes.
The secondary tower is on an older hardware, not very powerful. The installs on that one are unstable branch: KDE Plasma, Enlightenment and i used to have OpenBox + the older MaBox, Cinnamon and Budgie - those last ones i mentioned are broken installs now, got no time to fix them back. Different partitions and separate old 160GB HDD - combinations done like that also for experimenting.

If i can help with more information just let me know. :slight_smile:
Related to the topic i hope that is clear that on my Plasma installs on testing - the mouse settings has 3 tabs, and on unstable is just the main window with the simplified options … On all of them i have done this:

sudo ln -s /usr/share/X11/xorg.conf.d/10-evdev.conf /etc/X11/xorg.conf.d/10-evdev.conf

and commented it as i mentioned here. I need that for my tablet and create new profiles and test them for different programs, and then adopt them on my main rig.

Yes exactly – this is specifically what i was targeting in my previous post. So far in this thread you are the only Manjaroo to have achieved the full mouse settings in a desktop pc, but only on one of your pc’s. The key to it cannot simply be that this pc of yours is Testing branch, given that my VM is also Testing yet annoyingly only has the simplified mouse settings. Though atm i don’t have any idea what, logically there must be something installed/configured in that one KDE system of yours that is different to your other KDEs, & also different to all of our various KDE systems.

That is what intrigues me so much; the fact that we are not all having the identical result of being stuck with the silly simplified settings. One of “our” laptops, & one of “our” desktops, in this thread, have something unique that is causing/allowing them to have the Full mouse settings. It makes me deeply curious, because it logically implies the possibility that we could all acquire the full settings too, if only we can deduce what is the key difference between that installation of yours, vs all the others…

You are correct :slight_smile: I didn’t think about it till you mentioned. I have a Logitech G400s Optical Gaming Mouse and i make use of xbindkeys on startup to make use of the extra buttons. This is part of the .xbindkeysrc file:

# Present Windows
"xte 'keydown Control_L' 'key F8' 'keyup Control_L'"
   b:10
   
# Present Windows Curent
"xte 'keydown Control_L' 'key F9' 'keyup Control_L'"
   b:12

# Desktop Grid
"xte 'keydown Control_L' 'key F10' 'keyup Control_L'"
   b:11

# Back
"xte 'keydown Alt_L' 'key Left' 'keyup Alt_L'"
   b:8

# Forward
"xte 'keydown Alt_L' 'key Right' 'keyup Alt_L'"
   b:9

and this are the *input* related packages that are installed on all of my installs:
image

My guess is that libinput takes over xf86-input-mouse because of that 10-evdev.conf file i was mentioning. The reason i say that is because i just checked … For my surprise, on the unstable VM install the symlink to it disappeared and i didn’t noticed till now (quite odd actually). Made it again, had to comment it as i mentioned previously (so, the original file was also overwritten), rebooted and the mouse settings has now 3 tabs :slight_smile:
I’ll check that too on my experimental tower and see if is the same case … and report back.

Edit: Just made the test and that’s the “issue” … Also on that machine the symlink got removed and the original 10-evdev.conf was overwritten. Made the symlink again, commented it, rebooted => Mouse Settings has 3 tabs now.
That’s not quite good for those that want to play with wayland :frowning: … or maybe is not an issue … ha … :slight_smile:

1 Like

Ignoring wacom [i do not use tablet], my “input” packages are the same as yours [albeit one or two in my Tower are older versions, being Stable not Testing or Unstable], BUT one exception… I do NOT have xorg-xinput installed. Whilst i can find it in the Arch package search, i cannot find a dedicated Wiki for it, so i have no idea if i should have it installed, or how to configure it if i do.

Re xbindkeys, i have now read its https://wiki.archlinux.org/index.php/Xbindkeys , but still do not understand if i “must” also install this or not [in terms of this thread’s objective, i mean].

Edit: Oh, just saw your Edit above. So it seems that maybe i/we DO need to install that & set it up as you did. Given you found your previous changes had been removed, does that suggest we will have to repeat this procedure EVERY update?

1 Like

Try only with

and the commenting part like i described here. Ignore the fact that helps for wacom and other tablets. Is something that can be reversed any time, might not need the xorg-xinput package … and also no need for xbinkeys

3 Likes

OMZ OMZ OMZ … it works!!! You are a genius [again]. :star_struck:

I still don’t understand WHY we need to go to this amount of trouble [compared to older Plasmas], but i am so grateful that you have now solved this by your clever workaround.

Thank you :+1:

1 Like

Forum kindly sponsored by Bytemark