Missing mouse settings?

“Surveying” the apparent status via the preceding posts [below, i also count VMs running on a desktop in the desktop column]:

Manjaro KDE Plasma 5.13.2 with Full Mouse Settings		
Manjaroo	Laptop	Desktop
@kdemeoz	1 / 1	0 / 3
@michaldybczak	0 / 1	
@petsam		0 / 1
@bogdancovaciu		1 / 3
@DeMus		0 / 1
@cscs	1 / 1	

Hmmm, that’s not very pretty, is it? Hence a supplementary pic:

20180710_004

I conclude these initial points:

  1. A laptop is not automatically a guarantee of having the Full settings.
  2. Something is super-duper-hyper-mega special about ONE of @bogdancovaciu 's desktops. Is this a fertile ground for deeper investigation?

Not sure is relevant, i have 2 desktops. Well, actually 3 but the mac i don’t use for quite some time now, and moved everything on my main tower - testing branch, where happens to have 8 VM on VBox, and i do all my work (KDE Plasma of course). Most of the VM’s are Manjaro on unstable, different DE’s and combinations of them for experimenting purposes.
The secondary tower is on an older hardware, not very powerful. The installs on that one are unstable branch: KDE Plasma, Enlightenment and i used to have OpenBox + the older MaBox, Cinnamon and Budgie - those last ones i mentioned are broken installs now, got no time to fix them back. Different partitions and separate old 160GB HDD - combinations done like that also for experimenting.

If i can help with more information just let me know. :slight_smile:
Related to the topic i hope that is clear that on my Plasma installs on testing - the mouse settings has 3 tabs, and on unstable is just the main window with the simplified options … On all of them i have done this:

sudo ln -s /usr/share/X11/xorg.conf.d/10-evdev.conf /etc/X11/xorg.conf.d/10-evdev.conf

and commented it as i mentioned here. I need that for my tablet and create new profiles and test them for different programs, and then adopt them on my main rig.

Yes exactly – this is specifically what i was targeting in my previous post. So far in this thread you are the only Manjaroo to have achieved the full mouse settings in a desktop pc, but only on one of your pc’s. The key to it cannot simply be that this pc of yours is Testing branch, given that my VM is also Testing yet annoyingly only has the simplified mouse settings. Though atm i don’t have any idea what, logically there must be something installed/configured in that one KDE system of yours that is different to your other KDEs, & also different to all of our various KDE systems.

That is what intrigues me so much; the fact that we are not all having the identical result of being stuck with the silly simplified settings. One of “our” laptops, & one of “our” desktops, in this thread, have something unique that is causing/allowing them to have the Full mouse settings. It makes me deeply curious, because it logically implies the possibility that we could all acquire the full settings too, if only we can deduce what is the key difference between that installation of yours, vs all the others…

You are correct :slight_smile: I didn’t think about it till you mentioned. I have a Logitech G400s Optical Gaming Mouse and i make use of xbindkeys on startup to make use of the extra buttons. This is part of the .xbindkeysrc file:

# Present Windows
"xte 'keydown Control_L' 'key F8' 'keyup Control_L'"
   b:10
   
# Present Windows Curent
"xte 'keydown Control_L' 'key F9' 'keyup Control_L'"
   b:12

# Desktop Grid
"xte 'keydown Control_L' 'key F10' 'keyup Control_L'"
   b:11

# Back
"xte 'keydown Alt_L' 'key Left' 'keyup Alt_L'"
   b:8

# Forward
"xte 'keydown Alt_L' 'key Right' 'keyup Alt_L'"
   b:9

and this are the *input* related packages that are installed on all of my installs:
image

My guess is that libinput takes over xf86-input-mouse because of that 10-evdev.conf file i was mentioning. The reason i say that is because i just checked … For my surprise, on the unstable VM install the symlink to it disappeared and i didn’t noticed till now (quite odd actually). Made it again, had to comment it as i mentioned previously (so, the original file was also overwritten), rebooted and the mouse settings has now 3 tabs :slight_smile:
I’ll check that too on my experimental tower and see if is the same case … and report back.

Edit: Just made the test and that’s the “issue” … Also on that machine the symlink got removed and the original 10-evdev.conf was overwritten. Made the symlink again, commented it, rebooted => Mouse Settings has 3 tabs now.
That’s not quite good for those that want to play with wayland :frowning: … or maybe is not an issue … ha … :slight_smile:

1 Like

Ignoring wacom [i do not use tablet], my “input” packages are the same as yours [albeit one or two in my Tower are older versions, being Stable not Testing or Unstable], BUT one exception… I do NOT have xorg-xinput installed. Whilst i can find it in the Arch package search, i cannot find a dedicated Wiki for it, so i have no idea if i should have it installed, or how to configure it if i do.

Re xbindkeys, i have now read its https://wiki.archlinux.org/index.php/Xbindkeys , but still do not understand if i “must” also install this or not [in terms of this thread’s objective, i mean].

Edit: Oh, just saw your Edit above. So it seems that maybe i/we DO need to install that & set it up as you did. Given you found your previous changes had been removed, does that suggest we will have to repeat this procedure EVERY update?

1 Like

Try only with

and the commenting part like i described here. Ignore the fact that helps for wacom and other tablets. Is something that can be reversed any time, might not need the xorg-xinput package … and also no need for xbinkeys

3 Likes

OMZ OMZ OMZ … it works!!! You are a genius [again]. :star_struck:

I still don’t understand WHY we need to go to this amount of trouble [compared to older Plasmas], but i am so grateful that you have now solved this by your clever workaround.

Thank you :+1:

1 Like

To prevent that happening again at future system updates, would it be viable to finesse your method like this:

  1. Copy /usr/share/X11/xorg.conf.d/10-evdev.conf to /etc/X11/xorg.conf.d/10-evdev.conf
  2. Rename /etc/X11/xorg.conf.d/10-evdev.conf as /etc/X11/xorg.conf.d/11-evdev.conf
  3. Edit /etc/X11/xorg.conf.d/11-evdev.conf so that it contains only
#
# Catch-all evdev loader for udev-based systems
# We don't simply match on any device since that also adds accelerometers
# and other devices that we don't really want to use. The list below
# matches everything but joysticks.

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

.
.
EDIT: I have just verified that my modification of your workaround DOES work fine. The anticipated benefit is that future KDE updates, even if they overwrite /usr/share/X11/xorg.conf.d/10-evdev.conf with the default version, &/or even if they delete the symlink to /etc/X11/xorg.conf.d/10-evdev.conf, won’t be able to “break” the System Settings’ provision of the desired Full mouse settings again, because of the ongoing presence of the edited /etc/X11/xorg.conf.d/11-evdev.conf. A bonus benefit is that after applying this method we no longer need to have xf86-input-synaptics installed on a desktop pc. I’m pretty happy with this now.

2 Likes

Glad it helped!!! :blush:
Personally i find a bit of strange logic related to the way libinput and the other xf86-input-* stuff work together. Since it is required by xf86-input-libinput - that is a generic input driver (my understanding is that is not a physical device) it should be related and influence only the pointer events … nothing else, so that the real devices are handled by the drivers like xf86-input-mouse, xf86-input-keyboard, xf86-input-synaptics etc so the xf86-input-evdev should work as a bridge only when detecting and reporting events to that pointer … (i might be a bit off with my understanding on this part). But as i see it, that way there will be no overlaps and each real device will work trough the driver itself and its particular configs, so when there is a switch, the pointer becomes active trough the real device in use … Anyway, i need more study on this till i could say i understand completely the way is done.
Yes, removing the Sections bellow the pointer entry is also ok. In fact i think that should be the default, but … :slight_smile: I will investigate this more in depth one of this days.

2 Likes

I will take note of this !!! Thank you !!!
You see, you just had a better idea :wink: :brain:

2 Likes

Interesting read. I had some questions coming to my mind:

  • Is this behaviour wanted by KDE?
  • Should there be an issue created for this in the KDE bugtracker?
  • Should this be fixed in Manjaro or somewhere else instead of just manually editing a config file?

My understanding and speculation is that since KDE Plasma team are trying to make wayland perform better in plasma, in the same time the libinput (at device and event level) should work for both X11 and wayland - using the configs in /usr/share/X11/xorg.conf.d/*
Now is only partially working and for some reasons it conflicts with other drivers for input devices from (synaptics to all the xf86-input family), hence it needs manual tweaking in some particular situations.

1 Like

Sorry for my late reply. I take from your answer that there might be some problem, so I created an issue for this to get an official reply: https://bugs.kde.org/show_bug.cgi?id=401586

Thank you so much!! This worked for me also.

For other Linux noobs like me… here is exactly what I did:

Installed xorg-xinput package with Octopi (don’t know if I needed to but I did it before the other items)
In terminal:

sudo su
{your password}

ln -s /usr/share/X11/xorg.conf.d/10-evdev.conf /etc/X11/xorg.conf.d/10-evdev.conf

------This will create a duplicate file in the /etc/X11/xorg.conf.d/ folder and create a system link from the first to the new one.

rn /etc/X11/xorg.conf.d/10-evdev.conf /etc/X11/xorg.conf.d/11-evdev.conf

-------This renames the new file

leafpad /etc/X11/xorg.conf.d/11-evdev.conf

-------This opens the new file in a text editor.
-------leafpad is the terminal text editor I use. You may use or have a different one.
-------Modify the text in the /etc/X11/xorg.conf.d/11-evdev.conf file to be exactly this:

#
# Catch-all evdev loader for udev-based systems
# We don't simply match on any device since that also adds accelerometers
# and other devices that we don't really want to use. The list below
# matches everything but joysticks.
Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

------Save the file and exit text editor

Reboot system (again, I don’t know if this was needed but I did it)

Advanced mouse settings should now be there!

More experienced users, please feel free to correct me on any of this if I missed anything.

No need to login to root for all this. Just use sudo.
With the exception of your leafpad line.
That shouldnt be used by either root or sudo.
Use sudo micro sudo nano or configure EDITOR variable and use sudoedit
Do not launch graphical applications as root or using sudo

Is this an alias of yours? :wink:

heh. yes that probably should be mv
which is also kinda silly though when we can just change the ln command in the first place.

So, in summary,

we supposedly want this
  1. Make link
sudo ln -s /usr/share/X11/xorg.conf.d/10-evdev.conf /etc/X11/xorg.conf.d/11-evdev.conf
  1. Edit content
sudo nano /etc/X11/xorg.conf.d/11-evdev.conf

Replace contents with:

# Catch-all evdev loader for udev-based systems
# We don't simply match on any device since that also adds accelerometers
# and other devices that we don't really want to use. The list below
# matches everything but joysticks.

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Save and exit
Reboot.

What I still want to know is … why the link if the contents are being blasted anyways? Is there a reason for this, or are these 2 different solutions being mashed together?

I have a feeling that it should either be a link or have this content as above. And that those are 2 different things. If the new content is required it is likely the link is unecessary and we simply need to create the 11-evdev file with the correct contents.

So really … we probably just want 1 command:

sudo nano /etc/X11/xorg.conf.d/11-evdev.conf

With this content:

#
# Catch-all evdev loader for udev-based systems
# We don't simply match on any device since that also adds accelerometers
# and other devices that we don't really want to use. The list below
# matches everything but joysticks.

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Not probably, it’s for sure. Opening link for edit actually opens linked original file and makes edits to, in this current case, /usr/share/X11/xorg.conf.d/10-evdev.conf.

As for the topic, I can’t understand why this method does not work for me. It works only if I copy the original file unmodified or make a link to it. But this results in a disabled touchpad…

If you read on my previous post, the reason why i have to use the file as mentioned by @cscs and @kdemeoz is because of either wacom or synaptics that interfere with libinput
In your case, the touchpad is controlled by libinput and that means you need the file unedited :slight_smile:

2 Likes

Okay, it’s clear to me now. I wish there would be a way to make libinput control touchpad and let evdev control mouse, separate them somehow. Maybe explicit setting of /dev/input/event0-19 in each configuration file.

Forum kindly sponsored by Bytemark