Missing mouse settings?

Today i found an unexpected problem with missing mouse settings in my Tower’s real KDE Stable, & both my KDE VMs in Tower [one Stable, one Testing]. In contrast, Lappy’s KDE Stable has the correct settings. I am referring to KDE System Settings - Hardware - Input Devices - Mouse.

This describes what should be present… https://docs.kde.org/trunk5/en/kde-workspace/kcontrol/mouse/index.html … three tabs; General, Advanced and Keyboard Navigation. They are present & functional in Lappy:

Puzzlingly all three installations in Tower as listed above, have a completely different & much more restricted suite:

20180708_004

Initially i wondered if this was yet another hallmark of the impending Wayland code simplification of xf86-input-libinput over xf86-input-synaptics, but this seems untrue when i checked what is currently installed. Compare the above pair of pics; the same packages are present in Lappy [good] & Tower+VMs [bad].

When i researched this in the Manjaro forum, i found these;
a. Mouse wheel only scrolls half a line

sudo pacman -Rns xf86-input-libinput
sudo pacman -S xf86-input-synaptics
reboot

…but when i tried the first command with Konsole in one of those VMs [which i carefully Snapshotted first as precaution] it refused to proceed:

~ >>> sudo pacman -Rns xf86-input-libinput                                                                        
[sudo] password for kdemeoz: 
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: xorg-server: removing xf86-input-libinput breaks dependency 'xf86-input-libinput'

So after creating the VM snapshot i decided to force it with Pamac:

20180708_002

Post-reboot it was the disaster i expected; no graphical session available. Rolled back the snapshot.

b. Pad and mouse "no shared library" issue after today's - 19.06.2018 unstable update … but it did not seem to have a relevant solution for me.

c. Plasma 5.13.0 and KDE Framework 5.47 bugs … which also seemed to have no applicable solution for me. It referenced the preceding link.

A general DDG web search found this… https://www.youtube.com/watch?v=XzoOdIbWcj8 [watch only from 2’10"] … which is old [obsolete?], & in any event its “solution” of reverting to xf86-input-mouse is unproductive for me given that package is already installed in all my systems.

If it was not for the first link in this post, & Lappy’s physical corroboration of that, i’d be tempted to assume that 5.13.x had permanently removed this functionality, but clearly that is untrue. How Tower’s real & VM KDEs can so badly disagree with Lappy’s KDE, despite them all appearing to have the same relevant packages installed, confuses me. Is there another necessary package that i have not checked? Even if there is, it would be plain odd for it to have been omitted on all three of these independent installations.

1 Like

My laptop install shows (unstable branch):

Screenshot-2018-07-08-12%3A09%3A35

This is poor effort on translation team which hasn’t get up to date with Plasma 5.13.

Anyway, this looks like your tower install and I believe is proper and new, updated mouse menu. However, devs are planning to better the UI since the new one sucks. Also I think I saw some bug threads about bringing back mouse settings, so I guess this is work in progress.

On why this is different on laptops or tower installs I can’t say. Are your installs using the same branch?

Obviously, since xorg-server is tied (depends) on libinput. But you may install synaptics without removing libinput. Could this be the difference between your different Settings Layouts?
Also, the only obvious difference is the “Laptop”, it could be recognized from plasma and behaves (shows) differently.
I don’t have synaptics installed (Testing) and my KCM is the minimal one.

1 Like

Are we there already or was a typo ?
Same here on unstable branch, no tabs on mouse settings.
On testing branch i have the 3 tabs on mouse settings as you, @kdemeoz posted in the fist screenshot …
Currently doing a new update on my experimental machine (unstable) and see what is changed. Is quite slow so it might take a while. BRB :slight_smile:

LOL, a typo, fixed.

Wishful thinking?

So, the update on that unstable experimental desktop finished and the mouse settings remained ‘simplified’. The Xorg-server unstable (1.20.0-9) while on testing (1.19.6) so that might be a reason as pointed out by @AgentS
Hey, @michaldybczak - someone asked me how to get linux look like Mac OS, but i was for long time mac user i’m a bit sick of that look, i might point that person to your posts. Nice job on gathering so much information about it (and i presume is also working nice) Cheers!

No, that’s a long term thinking :wink: . 5.15 should be in June/July 2019 probably. They are already working on code for 5.14 and fixing bugs for current version and as well for 5.12 LTS. However, we went off topic.

1 Like

Well, I don’t have much experience on macs but as far I know, some things work slightly different, meaning: better on Plasma :wink: . I love the mac look but I dislike their limited system. In mac paradigm we can do much more cool stuff that mac wouldn’t allow. For example, mac setup works well for my home usage but at work I need something different so the layout changes with activity. There is no such freedom on mac. Also there are many other benefits that mac users are missing.
Anyway, my desktop shows Manjaro logo and “Plasma Desktop” notification to show that it is not a mac :smiley:

Oh no, off-topic again. You guys are messing with me :wink: .

1 Like

A shy guess (beause I don’t have Plasma at hand ATM): There is a setting in the start window of Settings where you can choose how Settings are supposed to look like. Have you selected the same layout for both systems?

I guess what you are talking about is the greater overview of all the settings, either in icons mode, tree mode or with the (new) sidebar.
Per settings the view is always the same, that doesn not change.
I don’t remember when things changed but I also have the minimalistic mouse settings and I hate it. I like to set the amount of lines the screen should scroll per mouse-wheel notch.Now it’s impossible.

3 Likes

Since libinput is the only input method on any wayland compositor, it’s the only one that can be used. xf86-input-libinput however has nothing to do with wayland, thats the xorg binding for libinput.

Do you run Plasma wayland session already?

echo $XDG_SESSION_TYPE 

in konsole

Thank you all for helping me :sunny:

Exactly! That is why today i went looking into these settings [I know for a fact, as you all also would remember, that older Plasma versions allowed us the fine-tuning, because in olden days that was how i had originally changed my mouse wheel scroll lines, & now i wanted to change it again]. This apparent inability for us now really is a shame. If i were to describe it with a special technical term, i would say “it sucks!!!”.

Hey, so you also know my Very Special Technical Term? :wink:

  1. Lappy is Stable [although a few months ago, for a few weeks, i changed it to Testing… but tired of that & returned it to Stable].
  2. Tower is Stable, & has always been that branch.
  3. One VM is Testing. When i created it last year i used the same ISO as for real KDE in Tower & Lappy, ie, manjaro-kde-17.0.6-stable-x86_64.iso. However since January this VM has been Testing branch.
  4. The other VM is Stable, & has always been this branch. Unlike the other installations, when i created this VM in late March i used manjaro-architect-17.1.4-stable-x86_64.iso.

Thanks but no. If you look at my OP’s pictures you will see that i have identical packages installed, including the synaptics one.

Oh? Hmmm, strange. In that case…
—> Open question to other Manjaroo Plasmoids who happen to have a Tower & a Laptop, & whose Tower also only shows the simplified mouse settingshow does it appear on your Laptops?

You DO? Yippee… except this variability now only puzzles me even more!

Teehee, it’s sooooooooo easy, isn’t it? :slight_smile:

Yes i do/have. I prefer the pre-5.12 layout [ie, Icon View], & always use that in each KDE installation i do, all distros. Anyway, it changes the appearance layout, but not the actual contents, afaik.

No, absolutely not. Based on my occasional reading so far it continues to have no support for Plasma functions i rely on, eg, multiple VDs, multiple Activities [but i have not bothered reading up on Wayland for months, so maybe i am now obsolete?]. Anyway fyi:

[kdemeoz@GA-Z97-HD3-Tower ~]$ echo $XDG_SESSION_TYPE 
x11

VD and Activities are Plasma features. they where always inside of Plasma/KWin so will work without X11.

Things that needed a rewrite in order to have a wayland compilant compositor where features that came from X11, like input, graphics, output handling and all the lowlevel stuff like this. So only there is a change to expect.

You can imagagine the situation with wayland that way: before there was Kwin running on top of X11, now Kwin runs purely without any layer in between.

libinput is now also the default driver on X11, but here you can make a xorg config file to set any other driver. What I dont know is if thats enough to also switch back to the “old” mouse settings.

2 Likes

Testing here… I have the 3 tabs.
And thats probably because I use xf86-input-synaptics
KDE should provide those settings for libinput soon enough, but to my knowledge, havent done so yet.

Libinput is new. Libinput is default. But not all options are available for libinput. Not everyone has integrated things like KDE settings for full libinput support. If you install synaptics over libinput it will take precedence. If you install synaptics I expect you will see the 3 tabs as well.

1 Like

But no, sadly this is incorrect. If you look at my pics in my OP you will see that i DO already have that installed, in all my KDEs, ie, they all have both the libinput & synaptics variants. Yet, only Lappy has those 3 tabs, whilst the other three KDEs do not.

Once the synaptics package is installed, is there a config file somewhere that i was supposed to have edited so that synaptics not libinput takes precedence? Maybe my three “bad” KDEs are currently not being allowed to actually use synaptics, because libinput is still calling the shots?

OK, maybe wrong.
I would more expect that, if for example, you have a forced libinput mod or xorg file or similar that might make it take precedence.
Like if you tried to set manual libinput options in xorg.conf.d with something like this:

Section "InputClass"
    Identifier "touchpad"
    Driver "libinput"
options
options

Apparently not. Here’s the full contents of that directory ‘/etc/X11/xorg.conf.d’ for my Tower’s KDE [ie, one of the KDEs having only the simplified mouse settings] … only a single, irrelevant, file:

[kdemeoz@GA-Z97-HD3-Tower xorg.conf.d]$ ls -la
total 16
drwxr-xr-x 2 root root 4096 Dec  9  2017 .
drwxr-xr-x 5 root root 4096 Oct 26  2017 ..
-rw-r--r-- 1 root root  266 Dec  9  2017 00-keyboard.conf

I can’t get to Lappy atm, but later this morning i shall check Lappy to see if it has an additional [& relevant] file, which if so i’ll copy to Tower then test.

EDIT: Hey, wait a moment, you said that your pc does have the full mouse settings. Is it a desktop or laptop? If latter, that does not progress the matter, given my Lappy is also ok. If the former however, then a comparison is valid; what files do you have in your ‘/etc/X11/xorg.conf.d’ directory?

Sorry, laptop.

The question is valid as well, I think.

1 Like

Forum kindly sponsored by Bytemark