Missing Icons in Default Icon Sets

I have switched my laptop from Ubuntu over to Manjaro this morning. Unlike my desktop this transition has been a bit more painful and I’ve been slowly fixing things all day. My latest woe involves my icons.

It seems that if I select any of the default icon themes for Gnome (hicolor, Adwaita) or apply a custom theme which has some icons missing then Gnome is falling back to generic blue icons. As an example case…

  • On my desktop: If I use one of these themes then KeePassXC and MS Edge show THEIR default icons (a key and a swirly e).
  • On my laptop: I get a blue box / half cog icon (and that appears for half the apps on the laptop).

This happens both when logged into my own profile and when logged in as root which throws me somewhat - my /home directory has been carried over from my previous Ubuntu world but root showing the same issue suggests something missing in the build itself.

I’ve been hunting around the webs for a good hour now - I’m toying with fresh reinstalling but would like to avoid that as my available noodling time is very limited and I feel like I’m at final hurdle stage.

Has anyone else experienced something similar? What am I missing?

Did you keep the same Home directory from Ubuntu? If so, that could have caused issues with icon caches.

Either way, are there icons in ~/.icons/ or ~/.local/share/icons/?

I did, and if it was just my own profile then I’d put it down to that but root being affected confuses the hell out of me.

~/.icons is not there.
/root/.icons is not there.
~/.local/share/icons is there and has a hicolor folder.
/root/local/share/icons is not there.

I feel something is missing - Is the hicolor folder the key one that needs to be everywhere?

I don’t have the answer for your issue - just a parenthesis.

I saw you’ve created a bunch of threads for various topics. If indeed you imported settings of home and/or root from Ubuntu, that could explain why you’ve known so much trouble for a brand new install.

If you’d create a new test user, with default configuration, I guess you’d encounter less or none of your current issues.

Looks like I deleted the ones from my own profile earlier in the day so I’ve restored those. Looks like root never had anything in either of these locations as I did a backup of the system drive not long after build. I may well have done this trying to fix the problem myself though as I was trying some restores from elsewhere (which just messed things up even more). Restored my profile files so both of my folders do now have a hicolor profile and the issue persists. after reboot

I dunno for sure, I guess you could find some default config in /etc/skel, but as you’ve imported some settings from Ubuntu, restored others…

It’s hard to advise what to do.

As suggested you could create a new user to check how a default config would behave, eventually copy/reproduce in your main account the correct parameters.

@Falav agreed and I expected some issues but my desktop migration was pretty seamless in comparison and I don’t think this is related to the profile import.

root hasn’t been imported from Ubuntu - That’s a fresh root account - only my /home was imported (just my own account) and these issues are affecting root as well.

I did have a fresh account earlier which I was using as a source - I might set it up again and see what I have their but I’m not hopeful. I had some issues with the install process itself - had no desktop - had to manually remount my home and do a command line update and reinstall on first boot - nasty.

It may be beyond resolving at this point - at the really annoying 90% there stage.

Well, is there anything in it? There’s a few more sub-directories if icons are therein. The reason I asked is because icons in the Home paths I mentioned will override icons in the system.

Can you reproduce it if you create a new user?

Can you reproduce it if you create a new user?

@Yochanan Yes. Seems to affect everyone (root, myuser, test). The effect is that under some themes the majority of the apps that were installed other than those that came with the distro (give or take a few) have no icon.

The hicolor folder is fully populated, using my desktop as a comparison - this is feeling like a red herring as this doesn’t actually have icons for the apps anyway…

Just for information, how did you install Manjaro? CLI, Architect, iso with Calamares ? If with an iso, which one was it?

I’m curious why you did have problems during install already.

@Falav It was an ISO USB with Calameres (21.0.7) - It was the Gnome ISO from the website downloaded about a week ago beyond that I’m not in the right part of my tech space to tell you any more.

I used the same USB to install my desktop and it went fine the laptop not so much. I kicked off the install to wipe and replace the Ubuntu partition and to use my existing /home and then after rebooting just got a black screen. CTRL+ALT+F2 to terminal let me run a pacmac command to check and update all the packages again then it booted up fine after that but it hadn’t mounted my /home partition properly and had created a /home on the system drive.

I feel something went awry at that point.

but you stayed with gnome, right? and your old home partition has been mounted even with some errors?

An existing home with .local, .config settings from a Debian based distro into an Arch based one… I guess issues ensue.

1 Like

just what i wanted to say too : -) , maybe some selective deletion, or the hard way by deleting the 2 . folders i guess ?

did not mean that red flag, I can not even unflag it, weird , sorry

@anon58039152 - Yep both Gnome. I had to manually switch the /home partition after the build, edit the fstab and remount. No biggie but it wasn’t expected behaviour, based on what happened a few days ago with my desktop which was much the same.

The /home directory feels like a red herring to me though as the issue also affects freshly created users and root.

It’s pretty much all the installed apps that got installed after the base install which seem to be icon-less in Adwaita or hicolor - They look fine in Papirus (because they have custom icons in that theme I would say).

@Falav - Not in my previous experience > I did the same with my desktop earlier in the week and the transition was faultless (blew me away in fact!) That being said…

I’ve fixed it!!!

I was testing what was missing - I theorised that something in my config from hangover may not have been fixed up from the Ubuntu transition BEFORE I ran my install scripts for my apps. I tried uninstalling and reinstalling Brasero via the GUI software tool - The icon for it appeared after reinstall. I then changed the theme from hicolor to Papirus-Dark-Maia and went to test another while in a different theme (expecting the same result). On switching BACK to hicolor again, ALL the icons had reloaded (not expected at all!).

It seems that my theory was correct and that simply kicking an install off fixed it (LOVE to know why…)

To anyone coming back to this with similar issues - the lesson here is…

If switching distros, consolidate your config BEFORE installing all your apps!

@Falav - You got my brain going in the right direction. I remembered that when I did my desktop I had to install everything AFTER I’d consolidated configuration so things like my Terminal worked nicely etc. (I am so in love with the Manjaro terminal) and I could put together an install script - my old apt script wasn’t much use here - whereas with my laptop I already had an install script so I kicked that off almost immediately.

I suspect that the underlying culprit was not having the terminal config files from Manjaro in place first.

Because there’s a gtk-update-icon-cache pacman hook. :wink:

@Yochanan …and that same hook probably didn’t trigger properly when I set up the laptop because I hadn’t consolidated my config with a base user before installing everything.

Thanks everyone for your help with this - learned a lot today!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.