Missing dunstify in package manager

The latest update wouldn’t install properly because of the dunstify package. After some different unsuccessful approaches, I tried to remove dunstify with the intend of reinstalling it after the update was successful.
Therefore I removed dunstify (which also removed: dunst, update-notifier, gnome-shell-extension-manjaro-update).
Unfortunately I was only able to reinstall dunst. update-notifier needs dunstify as a dependancy and both the dunstify and gnome-shell-extension-manjaro-update package are not listed.

I also have now two “package manager” icons in the tray bar.

Manjaro Gnome 3.36.5

Dunstify should be part of the dunst package

That’s been depreciated for a long time in favor of Pamac Updates Indicator which is part of pamac-gtk.

dunst replaced dunstify quite awhile ago as well.

Thank you for your replies.
So I don’t need to worry about not having either of those two installed (dunstify and gnome-shell-extension-manjaro-update)? pamac-gtk is installed.

What about update-notifier? When I try to install that (0.7.8-1), I get this error: "could not satisfy dependencies:

  • unable to satisfy dependency ‘dunstify’ required by update-notifier"

I don’t care much about which package is installed to do the job, as long as everything works.

But currently I still have the 2 tray icons (both a shield with a checked mark, one of them slightly smaller), which leaves me with the impression that things are not the way they are supposed to.

Remove them, they’re obsolete packages.

Under Settings (global, not in the package manager) -> Notifications:
There is also twice the line “Add/Remove Software”, and I can adjust the settings for those separately. Like check “Sound Alerts” for one but not the other.

Hey, I have same issue

error: failed to commit transaction (conflicting files)
dunst: /usr/bin/dunstify exists in filesystem (owned by dunstify)
Errors occurred, no packages were upgraded.

The difference is I am running i3-manjaro where I have dunst package required by manjaro-i3-settings package. It looks i3 settings app is not migrated yet or something. So am I correct that I cannot just uninstall dunst ? What would you recommend doing in this scenario?


You can find more information in the update thread.

Specifically, I followed this comment:
https:// forum.manjaro. org/t/testing-update-2020-08-23-kernels-libreoffice-7-0-kde-git-mate-1-24-1-gcc-10-python-haskell/12894/24?u=jrwrigh

though I used yay -Syu --overwrite /usr/bin/dunstify instead of pacman and that worked for me. I’m also running i3-manjaro

Edit: The new forum won’t let me post links, so remove the spaces in the url above.

The answer is in the wiki section of the announcement. Please always read the announcement before updating.