Missing drirc files


I’m getting some errors using GPU apps(mostly games), when I run DRI_PRIME=1 LIBGL_DEBUG=verbose glxgears the same applies for my iGPU

libGL: using driver amdgpu for 5
libGL: Can't open configuration file /etc/drirc: No such file or directory.
libGL: pci id for fd 5: 1002:6900, driver radeonsi
libGL: MESA-LOADER: dlopen(/usr/lib/dri/radeonsi_dri.so)
libGL: Can't open configuration file /etc/drirc: No such file or directory.
libGL: Can't open configuration file /etc/drirc: No such file or directory.
libGL: Can't open configuration file /etc/drirc: No such file or directory.
/usr/share/libdrm/amdgpu.ids version: 1.0.0
libGL: Using DRI3 for screen 0
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
308 frames in 5.0 seconds = 61.415 FPS
301 frames in 5.0 seconds = 60.006 FPS
301 frames in 5.0 seconds = 60.004 FPS

I made some research and reintalling drivers libraries or using LIBGL_ALWAYS_INDIRECT=1(this give me others errors) not work :confused:

Here my spects:

System:    Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 
           wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: TOSHIBA product: N/A v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: TOSHIBA model: CA10SU serial: <filter> UEFI: TOSHIBA v: 1.40 date: 12/05/2014 
Battery:   ID-1: BAT0 charge: 25.6 Wh condition: 25.6/44.7 Wh (57%) volts: 16.1/14.8 model: PEGA G71C000HS110 type: Li-ion 
           serial: N/A status: Not charging 
CPU:       Info: Dual Core model: Intel Core i5-4210U bits: 64 type: MT MCP arch: Haswell rev: 1 L2 cache: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19162 
           Speed: 1696 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 1696 2: 1696 3: 1696 4: 1696 
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Toshiba driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0a16 
           Device-2: Chicony TOSHIBA Web Camera - HD type: USB driver: uvcvideo bus ID: 2-6:3 chip ID: 04f2:b446 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: amdgpu,intel resolution: 1366x768~60Hz s-dpi: 96 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 20.3.1 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Haswell-ULT HD Audio vendor: Toshiba driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           chip ID: 8086:0a0c 
           Device-2: Intel 8 Series HD Audio vendor: Toshiba driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:9c20 
           Sound Server: ALSA v: k5.9.16-1-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: Lite-On driver: ath9k v: kernel 
           port: f040 bus ID: 02:00.0 chip ID: 168c:0036 
           IF: wlp2s0 state: up mac: <filter> 
Drives:    Local Storage: total: 298.09 GiB used: 43.03 GiB (14.4%) 
           ID-1: /dev/sda vendor: Western Digital model: WD3200BEKT-60PVMT0 size: 298.09 GiB speed: 3.0 Gb/s serial: <filter> 
           rev: 1A01 
Partition: ID-1: / size: 292.12 GiB used: 43.03 GiB (14.7%) fs: ext4 dev: /dev/sda2 
           ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 43.0 C mobo: N/A gpu: amdgpu temp: 40.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 218 Uptime: 6h 57m wakeups: 1 Memory: 7.69 GiB used: 5.82 GiB (75.7%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 clang: 11.0.0 Packages: 1319 pacman: 1310 snap: 9 Shell: Bash v: 5.1.0 running in: konsole inxi: 3.2.01

Your system information only shows integrated Intel graphics. Do you have a dedicated AMD GPU?

What’s the output of:

mhwd -li

Yes sorry I didn’t post it, I just make some change so the output of mhwd is incomplete but while I reconfig the drivers here is the output of lspci -k | grep -EA3 'VGA|3D|Display'

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)         
Subsystem: Toshiba Corporation Device f903 Kernel driver in use: i915 Kernel modules: i915
03:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445 / 530/535 / 620/625 Mobile] 
Subsystem: Toshiba Corporation Radeon R7 M260 Kernel driver in use: amdgpu Kernel modules: amdgpu

Do what now? :thinking:

AMDGPU is already installed.

Ah no never mind, the problem is appear when I run a game and this appear


Testing ability to decode VAProfileH264Main failed: the requested VAProfile is not supported
here full output in 1046 line.

That’s confirm when I execute
sudo DRI_PRIME=1 VDPAU_DRIVER=radeonsi LIBVA_DRIVER_NAME=radeonsi VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/radeon_icd.i686.json:/usr/share/vulkan/icd.d/radeon_icd.x86_64.json vdpauinfo

display: :0   screen: 0
API version: 1
Information string: G3DVL VDPAU Driver Shared Library version 1.0
Video surface:
name   width height types
420    16384 16384  NV12 YV12 
422    16384 16384  UYVY YUYV 
444    16384 16384  Y8U8V8A8 V8U8Y8A8 
420_16 16384 16384  
422_16 16384 16384  
444_16 16384 16384  
Decoder capabilities:
name                        level macbs width height
MPEG1                           0 1048576 16384 16384
MPEG2_SIMPLE                    3 1048576 16384 16384
MPEG2_MAIN                      3 1048576 16384 16384
H264_BASELINE                  --- not supported ---
H264_MAIN                      --- not supported ---
H264_HIGH                      --- not supported ---
VC1_SIMPLE                     --- not supported ---
VC1_MAIN                       --- not supported ---
VC1_ADVANCED                   --- not supported ---
MPEG4_PART2_SP                 --- not supported ---
MPEG4_PART2_ASP                --- not supported ---
DIVX4_QMOBILE                  --- not supported ---
DIVX4_MOBILE                   --- not supported ---
DIVX4_HOME_THEATER             --- not supported ---
DIVX4_HD_1080P                 --- not supported ---
DIVX5_QMOBILE                  --- not supported ---
DIVX5_MOBILE                   --- not supported ---
DIVX5_HOME_THEATER             --- not supported ---
DIVX5_HD_1080P                 --- not supported ---
H264_CONSTRAINED_BASELINE      --- not supported ---
H264_EXTENDED                  --- not supported ---
H264_PROGRESSIVE_HIGH          --- not supported ---
H264_CONSTRAINED_HIGH          --- not supported ---
H264_HIGH_444_PREDICTIVE       --- not supported ---
VP9_PROFILE_0                  --- not supported ---
VP9_PROFILE_1                  --- not supported ---
VP9_PROFILE_2                  --- not supported ---
VP9_PROFILE_3                  --- not supported ---
HEVC_MAIN                      --- not supported ---
HEVC_MAIN_10                   --- not supported ---
HEVC_MAIN_STILL                --- not supported ---
HEVC_MAIN_12                   --- not supported ---
HEVC_MAIN_444                  --- not supported ---
HEVC_MAIN_444_10               --- not supported ---
HEVC_MAIN_444_12               --- not supported ---
Output surface:

So this means that my gpu is not full supported for the open source amdgpu driver or there is some way to active this decoder capability H264_BASELINE and others?