Missing "Apply colors to non-qt applications" checkbox

Greetings to the community!
I recently moved from Kde neon to manjaro kde and I cannot find that checkbox under system settings>colors which was labeled as "Apply colors to non-qt applications". I used to uncheck it in order to have readable toolboxes on gimp. Now I'm stuck with white fonts on white background on some toolboxes. Is there a workaround or a suggestion for that? Thanks in advance. running kde plasma 5.17.2

Have you tried the Kvantum manager?

It is a default installed app.

Thanks for the reply Aarhus. OK, I've installed kvantum. I cannot figure out the equivalent option. I am not familiar with kvantum. I will keep trying and post if anything comes up.

There is a reference to the said option in KDE Phabricator:
https://phabricator.kde.org/D12278

There is a FIXED-IN: 5.16.0 tag in the same page, which I assume is referring to the version of Plasma where this feature was removed.

I'm not a KDE user, so please forgive my ignorance, but is there any chance that KDE Neon is using an older version of Plasma than the one Manjaro is using?

Also, can you check in kcmdisplayrc (I don't have a clue what this is, a file maybe?) if you can manually disable the option as stated in the quoted text?

Καλωσήρθες στο Forum Βασίλη!

2 Likes

Καλως σας βρήκα! (nice to meet you)
Thanks everyone for your answers. I've found kcmdisplayrc (it's a file) under /etc/xdg, and changed its property "exportKDEColors=true" to false with no effect. It's a real bummer not to have Gimp working properly, appearance-wise, under KDE cause I use it a lot. I'll keep on looking and post any update. Thank you again for your answers and time. Cheers!

some update
As a workaround is to install gimp through snap. It downloads way too much probably usesles stuff but makes gimp look exactly as it supposes to be.

1 Like

What about other non-Qt apps? Could it be it's a Gimp issue?

I suppose you have to recheck or explain your kde configuration. How did you install Manjaro? Maybe used your previous $HOME folder?
IIRC Gimp looks fine on my KDE.
Θα το τσεκάρω μετά τον καφέ :coffee:
Καλώς τον! :wink:

1 Like

My install is fresh, formated disk and installed Manjaro-KDE. Here is my system info:

Operating System: Manjaro Linux
KDE Plasma Version: 5.17.2
KDE Frameworks Version: 5.63.0
Qt Version: 5.13.1
Kernel Version: 5.3.8-3-MANJARO
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-4440 CPU @ 3.10GHz
Memory: 7,7 GiB of RAM

Here is a screenshot of my mess.


Inkscape is partially themed and Gimp toolboxes seem empty. Even I have Breeze-dark enabled as you can see, colors from the Breath theme of Manjaro are showing.

1 Like

Here is my output:

and my GTK settings

I use Materia dark and (I don't know if it connects...) Behavior->Show icons->On buttons/In menus

Gimp has Preferences for User interface, about Theme, icons etc...

Got tired of messing around with settings, reinstalled manjaro fresh, with minimal ISO this time. Everything is just fine, menus, colors. No idea what caused all that with previous installation. Once again, thanks to all of you for your comments. Cheers!

2 Likes

I finally found it. In home folder there was a hidden file named ".gtkrc-2.0-kde4" alongside with ".gtkrc-2.0". As soon as I deleted ".gtkrc-2.0-kde4" everything started responding fully according to the theme options.

What if you check again... was it not re-created?
My info:

ls -la | grep gtkrc

.gtkrc-2.0
.gtkrc-2.0-kde4 -> /home/<myuser>/.gtkrc-2.0

Also

$ cat .config/gtkrc-2.0

# created by KDE Plasma, Τρί Νοε 12 20:23:36 2019
#
# If you do not want Plasma to override your GTK settings, select
# Colors in the System Settings and disable the checkbox
# "Apply colors to non-Qt applications"
#
#

gtk-alternative-button-order = 1

and
$ cat .gtkrc-2.0-kde4

# File created by KDE Gtk Config
# Configs for GTK2 programs 

include "/usr/share/themes/Materia-dark/gtk-2.0/gtkrc"
style "user-font" 
{
        font_name="FreeSans µεσαία"
}
widget_class "*" style "user-font"
gtk-font-name="FreeSans µεσαία 12"
gtk-theme-name="Materia-dark"
gtk-icon-theme-name="Papirus-Dark-Maia"
gtk-fallback-icon-theme="breeze-dark"
gtk-cursor-theme-name="Oxygen_Yellow"
gtk-toolbar-style=GTK_TOOLBAR_BOTH
gtk-menu-images=1
gtk-button-images=1
gtk-primary-button-warps-slider=1
gtk-modules=appmenu-gtk-module

I've checked and it only recreates the .gtkrc-2.0.
Just had to enable "show icons->in menus" in GTK application style to have icons in Inkscape menus.
Checked in two installations of the Manjaro KDE (home & work).

1 Like

Forum kindly sponsored by