[Minor] add patch for awk regexp warning to linux52

Just a minor suggestion, please consider adding this patch to linux52:
https://lkml.org/lkml/2019/5/18/223
(can possibly be backported to linux419 as well)
It just gets rid of a warning on compilation, no biggie.

Forum kindly sponsored by Bytemark