Minimise windows plasmoid wrong icon

The Minimise windows plasmoid is always displaying as a white square instead of the desktop icon. How can I change this?
I know this is a trivial issue, but I find it quite annoying and I do not know enough how to change this by myself nor was I able to find how to do so anywhere online. Thank you in advance :slight_smile: .

Welcome to the forum! :wink:

You probably have a couple of missing icons in the icon theme you’re using. I would suggest trying another icon theme. If you cannot find one to your liking in the repositories or in the AUR, then you can always look around at for an icon theme that suits you.

That said, I myself don’t use that plasmoid, but instead I have that functionality linked to one of the hotspots on the screen ─ concretely, the lower right corner. Moving my mouse pointer into that corner triggers the effect, and repeating it undoes the minimizing again.

System Settings → Wokspace → Workspace Behavior → Screen Edges

I am using breeze dark but i have also tried the breath 2 and oxygen themes. It’s always the same icon. It should look like this ibb{DOT}co/yg2RRVK but it looks like that ibb{DOT}co/nbK4LK6 exept for when i drag it. This is very confusing to me.
thank you for advice and time anyway

KDE Plasma did something (or is a bug) to show the symbolic icon of user-desktop regardless if is Show Desktop Widget or Minimize All widget when are shown on desktop or panel.
If you go to /usr/share/plasma/plasmoids and look inside org.kde.plasma.minimizeall or org.kde.plasma.showdesktop folders, you will see that the metadata.desktop files both show the colored version of icons, as those shown when you drag the widget - is defined in that file, that point as mentioned to user-desktop and should scale, but it doesn’t no matter what icons theme you use.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.