Minecraft can't launch

So the Launcher works well, but I’m unable to start the actual game. When I press Play I get this error in the logs:

GLFW error 65545: GLX: Failed to find a suitable GLXFBConfig

Installed as a flatpak, latest version (1.17), tried to reinstall the whole package.

Full error log:


Checking installations.


Minecraft client 1.17.1 is ready to start.




Using default game log configuration client-1.12.xml (outputs XML)


Environment: authHost='https://authserver.mojang.com', accountsHost='https://api.mojang.com', sessionHost='https://sessionserver.mojang.com', servicesHost='https://api.minecraftservices.com', name='PROD'


Setting user: exo


Backend library: LWJGL version 3.2.2 build 10


Failed to create window: dpr$a: GLFW error 65545: GLX: Failed to find a suitable GLXFBConfig at dpr.b(SourceFile:218) at org.lwjgl.glfw.GLFWErrorCallbackI.callback(GLFWErrorCallbackI.java:36) at org.lwjgl.system.JNI.invokePPPP(Native Method) at org.lwjgl.glfw.GLFW.nglfwCreateWindow(GLFW.java:1714) at org.lwjgl.glfw.GLFW.glfwCreateWindow(GLFW.java:1897) at dpr.<init>(SourceFile:92) at enx.a(SourceFile:21) at dvp.<init>(SourceFile:481) at net.minecraft.client.main.Main.main(SourceFile:179)



Process ended with exit code 0

Thank you, @megavolt . I ran glxinfo and my OpenGL is v4.6

OpenGL renderer string: NVIDIA GeForce GTX 1080/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 470.63.01
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 470.63.01

Running inxi -Gazy gave this:

OpenGL: renderer: NVIDIA GeForce GTX 1080/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.63.01 direct render: Yes

So it seems my OpenGL version is fine?

No idea then… flatpak is broken then. Maybe try the AUR:

AUR (en) - minecraft-launcher

pamac build minecraft-launcher

Here you can file an issue: https://github.com/flathub/com.mojang.Minecraft/issues

1 Like