Microphone not working with power_save off

After a week of looking through forums trying to fix my mic not sending any sound to apps, I decided to just reinstall manjaro and do things one-by-one to see what breaks it. And I found it almost immediately, since I had annoying popping sound when starting/stopping audio playback I followed the Advanced_Linux_Sound_Architecture guide from archwiki(sorry, I can’t post links) and popping sound disappeared after a reboot. And my mic stopped working. It’s still recognized as valid source, seen as plugged in, but no apps are getting any voice and even when using arecord -f s16_le -d 5 -r 44100 test.wav to test it, arecord just hangs in there, frozen in time. I let it be like this for around 10 minutes and interrupted it, file it created was just an empty 1 second audio file. The moment I enable power_save and reboot, mic is working again.
The question is - what should I do in order to use my mic normally and not deal with the annoying pop sound?

post output from:
inxi -Fazy

inxi -Fazy                                                                                                                  ✔ 
  Kernel: 5.15.41-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/vmlinuz-5.15-x86_64
    root=UUID=f8562208-a99c-43fe-a231-253bae0a6f48 rw quiet
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: P5QD TURBO v: Rev 1.xx
    serial: <superuser required> BIOS: American Megatrends v: 0301
    date: 08/04/2009
  Info: model: Intel Xeon X5460 bits: 64 type: MCP arch: Core Yorkfield
    family: 6 model-id: 0x17 (23) stepping: 6 microcode: 0x60F
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 12 MiB desc: 2x6 MiB
  Speed (MHz): avg: 3166 min/max: N/A cores: 1: 3166 2: 3166 3: 3166 4: 3166
    bogomips: 25343
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled
  Type: mds
    status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GK107 [GeForce GTX 650] vendor: Micro-Star MSI
    driver: nvidia v: 470.129.06 alternate: nouveau,nvidia_drm non-free: 470.xx+
    status: legacy-active (EOL ~2023/24) arch: Kepler pcie: gen: 2
    speed: 5 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:0fc6 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1280x1024 s-dpi: 95 s-size: 342x271mm (13.46x10.67")
    s-diag: 436mm (17.18")
  Monitor-1: VGA-0 res: 1280x1024 hz: 60 dpi: 96
    size: 338x270mm (13.31x10.63") diag: 433mm (17.03") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 650/PCIe/SSE2
    v: 4.6.0 NVIDIA 470.129.06 direct render: Yes
  Device-1: Intel 82801JI HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3a3e class-ID: 0403
  Device-2: NVIDIA GK107 HDMI Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0e1b class-ID: 0403
  Sound Server-1: ALSA v: k5.15.41-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Qualcomm Atheros AR8121/AR8113/AR8114 Gigabit or Fast Ethernet
    vendor: ASUSTeK driver: ATL1E v: N/A modules: atl1e pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: dc00 bus-ID: 02:00.0 chip-ID: 1969:1026
    class-ID: 0200
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
    driver: 8139too v: 0.9.28 modules: 8139cp port: e800 bus-ID: 04:00.0
    chip-ID: 10ec:8139 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  Local Storage: total: 1.82 TiB used: 209.93 GiB (11.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EADS-00M2B0
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
    type: N/A serial: <filter> rev: 0A01 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: HGST (Hitachi) model: HTS541010B7E610
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 1A01 scheme: MBR
  ID-1: / raw-size: 60 GiB size: 58.76 GiB (97.93%) used: 22 GiB (37.4%)
    fs: ext4 dev: /dev/sda3 maj-min: 8:3
  ID-2: /boot raw-size: 1024 MiB size: 973.4 MiB (95.06%)
    used: 68.1 MiB (7.0%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-3: /home raw-size: 870.5 GiB size: 855.76 GiB (98.31%)
    used: 187.86 GiB (22.0%) fs: ext4 dev: /dev/sda4 maj-min: 8:4
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 10 GiB used: 44.6 MiB (0.4%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 46.5 C mobo: 26.0 C gpu: nvidia temp: 39 C
  Fan Speeds (RPM): cpu: 2109 psu: 0 case-1: 0 case-2: 0 gpu: nvidia
    fan: 40%
  Power: 12v: 12.38 5v: N/A 3.3v: 3.34 vbat: N/A
  Processes: 242 Uptime: 18h 54m wakeups: 1 Memory: 7.76 GiB
  used: 2.98 GiB (38.4%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 12.1.0 clang: 13.0.1 Packages: 1136 pacman: 1102 lib: 304 flatpak: 34
  Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.16

click this icon in editor and paste the output inside of it: </>

Posted it

What he meant, was:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Thereby improving legibility and making it much easier for those trying to be of assistance.

Please edit your post accordingly.

Thanks, it’s done

install this:
sudo pacman -S sof-firmware
reboot and test

It was installed by default. Tried to delete it and then install it again before, didn’t help

install pipewire:

sudo pacman -Ru --nodeps pulseaudio pulseaudio-equalizer pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf pulseaudio-bluetooth pulseaudio-pa pulseaudio-alsa pulseaudio-ctl manjaro-pulse && sudo pacman -S manjaro-pipewire

reboot and test

Just tried uninstalling sof-firmware, reboot and test, then installing it again, reboot and test. Mic is still not working with arecord just hanging/freezing. Will try pipewire now

since these packages were not installed giving this error

error: target not found: pulseaudio-equalizer
error: target not found: pulseaudio-jack
error: target not found: pulseaudio-lirc
error: target not found: pulseaudio-rtp
error: target not found: pulseaudio-pa

I removed them from the command you gave me and run it. tt’s still the same result. mic is not working, arecord is frozen. Also all of this was done with power_save set to 0. And another thing, if I go into alsamixer>F6>hda intel>F3>turn rear mic volume to max, I can hear myself in all cases.

i meant that you test if you still have cracking sound from speakers if using pipewire, and if you dont, you can use your mic normally

Oh, I didn’t think of that, will try now

Nope, after commenting out power_save in modprobe, I still get pop sound every time I start any audio playback. Though it might have gotten a bit quieter than it was.

so did you installed wireplumber? if yes install instead pipewire-media-session, if you have pipewire media session instal wireplumber, reboot and test speakers…

Installed wireplumber instead of pipewire-media-session, the pop sound is still there

Just read a post on stackexchange about a similar issue with fix being disabling/unloading module -suspend-on-idle in pulseaudio. I will try this right now

so instal back pulse with:
sudo pacman -S manjaro-pulse
it will remove pipewire, then reboot
navigate to: /etc/pulse/default.pa
and edit this line:
load-module module-udev-detect
to look like this:
load-module module-udev-detect tsched=0
then reboot and test speakers again

Unloading module suspend-on-idle didn’t work, same with adding tsched=0, pop sound is still there